Ground Control Crashing

Continuing the discussion from About the Troubleshooting category:

Any help appreciated. I can’t get Ground Control to run.

I tried unsuccessfully all weekend to get my system going. I first tried 1.25 Firmware & Ground Control, but McAfee antivirus kept quarantining GC.exe. I finally shut antivirus down, but still can not get GC to run. I have tried earlier versions of firmware & GC. I tried running from code, all to no avail. Strangely, I get two different error screens depending on whether I Launch Ground Control normally or as administrator.


As Admin:


Here is the location I am running GC from:

Using a new Dell Laptop, but had similar issue on old Windows 7 Sony Laptop. Here are the specs for my Dell Laptop:

Arduino IDE seems to be working (1.8.8). Monitored Serial and see numbers streaming, although it does mention something about EEPROM read failure in the first section…


Windows and McAfee often over zealously blacklist executable and library files when they are run from certain directories or user accounts that do not have sufficient permissions.

Please follow the instructions which should result in a “GroundControl-Windows.Portable.v1.25” folder being on your current Windows user account “Desktop” folder. Double click on the folder and then double click on the “Launch Ground Control” or “Launch Ground Control.bat” file.

If you see ‘User Access Control (UAC)’ pop up asking for ‘Admin’ login then the folder you are extracting to will probably not work. Running files from ‘C:’ root directories (“C:\maslow” in your case) will probably be blacklisted and not work.

In your first pic “Normal” it looks like required Kivy files cannot be accessed.
In the second pic “As Admin” it looks to be running from the wrong directory.

Thanks for the pointers @tinker.

I have tried several locations. However, your comments on the UAC alerts are spot on. Currently working to resolve this with Admin access and exclusions. If this doesn’t work, I will do as others have and dedicate a box and remove all antivirus and internet access.

Kevin Sullivan

Update: Success at last! I figured out the issue with my new laptop not running ground control. I will share in case anyone else experiences this same thing.

When I set up the laptop, it prompted for the email address that I set up my Microsoft account with. It then created a username using the full email address. The confusing part was that when I would look into my file path, it would only show my first name in the path, not the entire email address. However, having a full email address as the username was the complete problem.

How I found the problem: The first error I was seeing in Ground Control screen shot was: “Error while activating file handler logger”. I looked this up and saw that it was failing due to having a non-ascii character in the username. That would be the @ symbol in the email address.

How I fixed it: I created another account on my laptop with the username of Admin (With admin control to set up exclusions to prevent false positive antivirus alerts). Tried Ground Control again and it worked like a charm!!! :smile:

I just completed the calibration and will be cutting my final sled this weekend…

Here is the link to information on the error I was getting: Logger does not create log files when username contains non-ascii characters · Issue #3912 · kivy/kivy · GitHub

Thanks again for your help @tinker.


Glad you sorted it out and thanks for sharing your solution! Too often people forget to update how they fixed it.