Maslow Home Maslow Community Garden Newsletter

General problems with gcodes, and z dragging

hey guys. I got my maslow up and running. Calibration went pretty smooth, cutting out the final sled went great. what i’m having trouble with is the tabs. I can not get makercam to work right, it only opens at the top of the screen. I have tried some google searches and the solutions there did not work. i have been using easel for a while with my millwright cnc, so i wanted to use that for my maslow, but I have cut 4 things now and it will not leave tabs. I’ve tried changing the size and length, still nothing. ive even added a lot of tabes, and it will not leave any of them. Im also having the zaxir drag across the work space. it’s not deep, but enough to leave a cut mark. i zero the z before ever cut, and make sure it is not touching the board before the cut, but it doesn’t seem to raise high enough afterwards.

Thanks for any help you guys have to offer.

1.) Did you check the g-code with an on- or offline g-code viewer? Alterantivly you can upload it here for us to check.
2.) What z-axis are you using with what motor, confirm the pitch and encoder steps per revolution are correct
3.) write a g-code with only 10 z-moves 10mm up and 10mm down. Confirm that it moves 10mm and you end at the starting position. If not, something is binding or slipping. For example check that the z-screw is tight on the flat side of the motor shaft.

1 Like

check the gcode for what?

im using the stock maslow zmotor

when i move it with the ground control software it moves correctly. and the couplers are sitting and tightened correctly.

Check the gcode if the retract safety height between cuts is actually in the gcode.

If this is the Ridgid router setup, the orange knob wears out and there could be binding of the router. Many posts here with these issues.

ill check the code. the router is brand new so hopefully it not that, but ill look into it.
any idea on the tabs not working?

If it’s no secret, upload the g-code and I can check for safty height and tabs, just to make sure the gcode is ok. If the gcode is ok, it can only be a setting or mechanical.