Getting webcontrol.service failed with result exit code

When I try launching webcontrol on my Raspberry Pi 4b, I get “webcontrol.service failed with result exit code”. I saw a post from Orob suggesting that the webcontrol.json might be corrupted. He said to remove the file and reboot and a new file will be made. I tried this but it did not work for me. It did make a new file. My system has been working fine for months with no problems. Today when I turned it on I could not get webcontrol to load. The image is a pic from my system.

Does anyone have any ideas?

Thank you,

try running “sudo journalctl -u webcontrol.service --since today”

that should give you more in depth logs and help pinpoint what is actually going wrong

Hello Digitydogs,

It said “no entries”. I also did it for all times and got the same results.

I am at a loss where to look next. I’m not very familiar with the inner workings of webcontrol so i wouldn’t know if there are any subprocesses etc to check for logs.

perhaps @Orob can be of assistance again :wink:

Hard to say what it is. I would ask you to stop the service:

sudo systemctl stop webcontrol.service

and then run it manually…

navigate to the webcontrol folder and try:

python3 webcontrol

or maybe just:


(it has been a while since i tried it with the compiled version)
anyway, you should see a bunch of text start appearing once it starts so then you watch the text messages that show up as it runs to see where it crashes. It could be that the log.txt file is too big. that file is in the .webcontrol folder and you just delete it, but it may be something else. Please screenshot or save what you find and we can try to help.

1 Like

Well i figured it out. I went and looked back at the note Orod sent me when i first did the install and it said to find the ip, so looked and low and behold it changed. Made the correction and now it works!

Thank you guys for your help, i do appreciate it.

1 Like