Maslow Home Maslow Community Garden

Ghetto build. Assistance needed


#1

Hi guys. I have problem, and I am not sure what to do.
I have windshield wiper motors from mercedes w204 with cnikesin 400 encoders (https://pl.aliexpress.com/item/400-pulses-Incremental-Optical-Rotary-Encoder-AB-Two-phase-5-24V-400-Pulses-Incremental-Optical-Rotary/32725917082.html) and I want to setup maslow. Gearing in this motor is 55:1 and I get 400ppm from encoder so it equals to 22000 points per rotation. And now I am not sure what is going on. Cause when I click test motors and encoders in GC red mark is moving but the motor is not changing direction. And now I don’t know if I should change some data in firmware, or my encoders spin to fast. Here short video. Please HELP !
https://discourse-cdn-sjc2.com/standard11/uploads/maslowcnc/original/2X/6/628a521f756a4f6d857433bf2fe9c0c9fd1fb56f.mp4


#2

No idea and this comes with no warranties :slight_smile:


#3

Thank you for fast response.
Wiring checked few times so it is ok, and so the encodersteps in GC config.
Firstly I was confused about max rotation speed of encoder but in datasheet I found that it is 5000 rpm and my motor is spinning less than 3000 rpm so I believe this is not the case.
Also I found out that if I connect encoders to my shaft after gearbox it gets PASS while spining both directions.


#4

Are those 12V motors?
Do you have a spec sheet?
Could they be drawing to much amps from the power supply?
What motor shield do you have?


#5

Yes, It is 40 W windshield wiper motor. It spins 50 rpm after gearbox which is 55:1.


No spec sheet. But motors draw less than 3,5 A.
I have power supply from xbox which is good for 16,5 A.
Motor shield from aliexpress, but this not the case I believe
https://pl.aliexpress.com/item/2-Channel-CH-Dual-H-bridge-DC-Motor-Driver-Module-Positive-Negative-Rotate-PWM-Regulation-Optocoupler/32802163315.html?spm=a2g17.10010108.1000016.1.54db2b92uLCF1R&isOrigTitle=true.


#6

WOW, that’s impressive!
So you went into the firmware to get the pins on how to connect the motor-driver?
A link to the motor shield would interest me.

First ‘off the shelf’ motor shield I’ve seen with Maslow.
This goes to deep for me, hope some experts will join the discussion soon.

I’m a fan of Ghetto builds!


#7

Pinout was easy to get. I linked shield in previous post.
Till I know that my encoder is capable of doing 5000 rpm I am confused about frequency of ?probing?.
Original maslow gets 8k ppr my hits 22k I am curious if this is not to fast for MEGA2560 to read it.


#8

Might want to check the temperature of the chips to see if they are hitting thermal shutdown. Careful if it is it will be HOT.

My 2 Cents

Thank you


#9

Yeah,I know that chips can be extremly Hot. But at this moment are slightly warm. At this moment I am Able to do the test with passes on L and R motor, but I am a little confused. This small Red marker while testing should go to the left corner and go back to middle and then the same with right motor? Cause while going first direction Red marker is going faster than while going second direction. Can somebody show me how this motor and encoder test looks like in normal fully Operating machine?
And I almost forgot. I had second shield with “broken” tle5206 but after resoldering new chips it is still not working in maslow condition, but after writing short code I checked that motors are spinning both directions without a hiccup. And I am a little bit confused about GC informations about PCB version. Since I am setting this by jumpers on mega 2560 not on shield I am getting strange numbers while using tle5206 shield. Few weeks ago was something like this: PCB v1.4 Detected
TLE5206
And now i can get v1.4, 1.52, 1.53 but nothing that this board is Tle5206.


#10

Firmware:
In the cnc_ctrl_v1.ino, line 59 calls to ->getPCBVersion
This is found in System.cpp https://github.com/MaslowCNC/Firmware/blob/e1e0d020fff1f4f7c6b403a26a85a16546b7e15b/cnc_ctrl_v1/System.cpp#L98

and https://github.com/MaslowCNC/Firmware/blob/e1e0d020fff1f4f7c6b403a26a85a16546b7e15b/cnc_ctrl_v1/System.cpp#L265

I only see 4 possible options GC could report back the PCB version. (1.0/1.1/1.2/TLE5206 1.3)

Edit: A dicription of the board in english is here https://www.aliexpress.com/item/2-Channel-CH-Dual-H-bridge-DC-Motor-Driver-Module-Positive-Negative-Rotate-PWM-Regulation-Optocoupler/32958066014.html

I’m confused about the ‘optional PWM generator’ and how that board deals with the pwm from the arduino.
I can’t read the motor driver chip from the pictures.


#11

Yeah, I know. It confuses me. Now I am testing this board from aliexpress, and since I get 4 pases in motor test I want some more progress. But for now whatever I click (I mean run calibration test or some default gcode I get connection lost after few moves on L and R motor :confused:


#12

Can you send pictures of the board you are using. My comment was on the board you linked.

Thank you


#13

Sure, here it is.


#14

And with tle5206.


#15

"I had second shield with “broken” tle5206 but after resoldering new chips it is still not working in maslow condition, but after writing short code I checked that motors are spinning both directions without a hiccup.

Please be clear if you want clear guidance.

Choose what you want to work on and clearly indicate it. You say “shield” but link to and show pictures of a Board - Where is the shield and how is it involved? Is the board hooked to the shield and the shield to the Arduino - give us all the details! I see a board and some jumper wires. Fort all I know the jumpers are connected to a microwave. Take a wide shot. Draw a diagram - Give me something. What I have right now is there is an Ardunio, some stuff and wires between them something isn’t doing something I expect. In other words I have 6 miles of fluff and 2 inches of substance. Please help me to help you.

Thank you


#16

OK, I will start from the begining.
I have:
Mercedes W204 windshield wiper motor 12V 40W 55:1 connected to shield with 2 wires x2
with encoders (https://www.hobbytronics.co.za/Content/external/1102/High%20Quality%20360PPR%20dual%20output%202%20phase%20A.pdf this is datasheet of same encoder but with 360ppr) mounted to motor shaft. Encoders are directly connected to arduino on pin 20,21 and 2,3.
Motor h-bridge XY-1600 linked in 1st post, it has 10 pins +5V ENA(10) IN1(11) IN2(12) GND, +5V ENB(5) IN3(4) IN4(6) GND in brackets is PINOUT to arduino, 5V and GND as follows.
Arduino +5V on pin 22, 23 and GND on 52, 53 for PCB recognition(I am aiming at v1.2 cause I am using pinout of this version). Arduino is connected to pc with short cable with ferrit bead not crossing powerlines etc.
And a the end there is 12v power supply from old XBOX rated at 16,5 A.


#17

In GC I have setup PWM to 4,100Hz cause I found that this XY-1600 motor h-bridge can handle PWM 0-10kHz, also I changed encoder steps per revolution in my case 1spin shaft after gearbox is 55 spins of motor and there is 400 steps x 4=1600, 1600x55=88000 steps per one revolution of shaft.
This what i have in GC after testing encoders and motors.

I apologize for being generic and thank you for your time. If you want some more information let me know.


#18

So your current setup is based on ?https://www.sparkfun.com/datasheets/Robotics/L298_H_Bridge.pdf

There are no TLE chips currently involved?

Do you have top or bottom feed set for your motors?

@johnboiles do you have any input on this?

Thank you


#19

Yes. Current build is on L298 board like SPARKFUN cause I dont know why my shield with tle5206 is not working while using GC. For now there is no feed, cause I am testing if it is working. But I am aiming at Top feed. Yesterday I made L298 to work after carfully calibrating in GC. All those message about connection lost gone after setting chain lenght manually. Now I can See that motors are spinning right, just like gcode says.


#20

Good Work, Good Progress!

Do you have any Gears or Chain yet? Do you have access to a 3D printer?

Thank you