Maslow Home Maslow Community Garden

Ground control closure


#1

Hello,
I have been busy with work and have left my Maslow sit for a few weeks. I have cut stuff out and used ground control a bunch so I know I installed it correctly. I just went to open ground control and it opened fine the first time and crashed when I tried to open a file. When I tried to re-open it again, the black code screen opens for a short second, then closes and ground control never opens. I tried re-downloading a newer version and it did the same thing. I am not quite sure what to do, or what other information to give. I know my mouse is working and the program didn’t need updating. This was on 1.17, and I tried with both 1.19 and 1.18 versions with the same luck. Any thoughts or helpful comments would be great.
Jdeboer1999


#2

Try updating your video drivers. Also try creating anew user as an administrator and login as that user then install ground control.

Thank you


#3

I am currently the only user on my computer, and I have tried opening the file as administrator, and when I download it should be as administrator due to the fact that I am the computers administrator. Are you talking about my computers video drivers? I am not super tech savvy so I am not to sure what that is exactly. thanks for your quick responce!
Justin


#4

What Operating System is on your computer? Create a new User and give them Administrator access. You are not the Administrator on a PC because it is the only account you see. There is an account called Administrator it’s different. Under other type of Operating Systems it is called Root. Yes you may have a problem with the video driver that is stopping ground control from working. Updating the video driver will kick off several reactions that my resolve your issue.

Thank you


#5

This sounds like the problems I’ve had. Check the installation directory to verify the Groundcontrol.exe file is still installed on your computer. For me, McAfee was quarantining the groundcontrol.exe file. No white listing GC helped. I ended up running GC on a dedicated laptop w/o antivirus, disconnected from the Internet.


#6

There is an issue with 1.19 which could be causing this, are you sure you see the same behavior with 1.18?


#7

I was running 1.17 when it first happened, then I tried both 1.18 and 1.19 with the same results. I might end up running GC on a dedicated computer as I do have one that can be used. I saw the thread about the issue with 1.19, that’s why I tried 1.18.


#8

Let’s see if we can slow down the closing window to figure out what’s going on. If you put the .bat filie in this zip folder next to the Launch Ground Control.bat file you normally click and use the new one to start the program the window should stay open so we can read what is going on.

Launch Ground Control Debug.zip (190 Bytes)


#9

Hi Bar,
I did what you said. When the window opens it shows what is in this picture. It says press any key to continue and so I hit a key and it closes.

Thanks,

Justin


#10

That is strange but good to know. What happens if you open the folder there and click on the GroundControl.exe file manually?


#11

Try installing Ground Control in the root of C. Something like C:\Maslow\

You may be hitting a Windows file path limit.

This would shorten the path quite a bit. Also are you sure this is an unzipped file?

The statement " not and executable file is suspect "

Thank you


#12

Hello again, thus far I have tried everything stated above to the best of my ability. I’m not entirely sure how to install in the root of C. I did however get it to open for a short time by downloading the latest version, 1.20. But it quit on me before I could do anything. then I used the debug file bar gave me and it opened for a short period again and closed. I got a picture of the command window shown below.


Thanks,
Justin


#13

Okay I figured out how to install as the root of C: or whatever you want to call it, and it still did the same thing, so i shouldn’t be hitting a Windows file path limit.
Thanks,
Justin


#14

Hmmm I don’t see anything that looks wrong in that screen shot, the Ground Control window had opened and then closed by the time you took that picture? Here’s what mine looks like with everything working normally:


#15

That was while it was on still I quick took a screen shot and then it closed pretty quick after. The command prompt closed with the rest of the program so I cannot see what it is doing. The only difference I see is the ‘start application main loop’ and I am not sure if that is anything important.
Thanks,

Justin


#16

Jdeboer1999, have you verified the groundcontrol.exe file still exists within the installation directory? The behavior you are experiencing is very similar to what I experienced with McAfee quarantining the groundcontrol.exe file. When (if) GC started, it might run for a while then just stop and close, then the shortcut wouldn’t reopen it because the groundcontrol.exe file was no longer in the installation directory (McAfee had removed it).


#17

Please navigate to the location you are starting ground control from send a screen capture? What type of PC is this?

Thank you


#18

Hello everyone,
I am very sorry that I have not responded, as I stated at the beginning of the thread I am very busy with work and now school. I ended up restoring my laptop in order to get ground control to run, and thus far is has worked. I have not had time to correctly calibrate as the machine has been giving me a few difficulties, but I will figure those out in the near future! I want to thank everyone who gave me input. These forums are very helpful!
Thanks,
Justin


#19

Hello again,
I have come up again with the same problem yet again. Ground control will not open again. I restored my computer as I said in my last post, and it seemed to work, but I couldn’t get my machine calibrated so I left it for a short period of time. When I went to try again, ground control would not open just the same as before. I know it is not my computer updating because I un=installed all the updates since I re-installed ground control to see if some update was causing it. I also know that it is not my Mcafee because i have not renewed my security thing yet. I would really like to use my machine, but this is holding me up. Here is a little more info: I am in windows 10 with all the updates, on an hp laptop. I have tried running the most recent version of ground control as well as 1.16 to see if an older update would work. I am really confused on what could still be causing this. If anyone can help in some way that would be great.
Thanks,
Justin


#20

Here I have attached a video of me trying to open ground control.
As you can see, the command box closes immediately after I launch the file.

Here I also added a video of me opening the debug you gave me in the past. I don’t know if this helps, I hope it does. The command box closes when I hit enter.