Ground control cursor not keeping up with sled

Hello Team,

Just recently updated from 1.10 to 1.25.

All functions are running like a charm, only issue is the cursor on my ground cotrol is not keeping up with the speed of the sled. I have looked everywhere for a fix …nothing to be found.

Is there a setting in ground control to speed up the cursor?
(i have already re-calibrated with the cursor lagging :frowning: )

Thanks in advance…
P.S. I have attached my current project :slight_smile:

Jumping this amount of releases could have caused this. I would do a ‘clean start’ with 1.25, meaning wiping the eeprom, deleting or renaming the groundcontrol.ini and start again. I would not put much trust in a calibration with a lagging cursor. Did you check the log.txt from the GC folder if there is some clue there?

the update was incremental… in one sitting though!!,

I am able to run other programs correctly(currently testing ) but i will try the wipe if all else fails

1 Like

The g-code looks fine in camotics and currently running it in fake mode, but not expecting to find a fault in those cool wings. Hope to get to see the cut project soon.


I also am on either version 1.10 or slightly older (it was the “most stable” back when it was released). I figure everything has been running fine for me so why break it. Doesn’t seem like anything monumental has come out since then (please correct me if I’m wrong). Was there a reason why you updated?

Are there instructions on how exactly to do this? I’m a little rusty since I haven’t messed with this in a year.

1 Like

:frowning: :frowning: :frowning:

I NEED MY 1.10 BACK!! :slight_smile:

1 Like

Could not find it in the wiki.
There is a built in ‘wipe eeprom’ in GC, reached with Actions → Advanced.
Fighting with a bug in in fake GC 1.25 mode today, that wipe did not work for me and i used one that i’ve downloaded from an arduino forum. That worked for me. (824 Bytes)

The groundcontrol.ini should be in your user folder. I rename it, and GC will create a new one, but with all values set to default. I edit the main settings in the new .ini like motor-distance etc. with the values that i know and can read out of the old .ini. I hope that gives GC a better start for improved calibration restults.


im still in “re-CAL” mode… on attempt number eleventeen,

I been able to… wipe, reload, re-mesure numerous times no problems.

But still the cursor in ground control, will not keep up with the sled… I have no Idea at this point.

it has to be a glitch in ground control.

Im just short of a factory restore to 4 months ago!!

Hi @Nigel851

Let’s try to collect a little more info -

What OS are you on? What version?

What PC are you using ? Make ? Model?

Where are you located?

What controller shield do you have?

do you have a stock Z Axis?

I’d like to see if we can come up with a correlation on what is happening for you.

Thank you

Hello Bee,

First off Thanks for Everything !!! (MASLOW=GREATEST THING EVER)

I have spent most of the past 24 hours re calibrating, cutting the test pattern, and so forth…

I am seriously stumped as to why this is occurring!

Thank you for your time

Nigel M


I think I might see the problem - Display Color 262,144 (6bits/color)

The 6 bit color adaptor it probably not got a very current display driver. In fact I bet it was written in Windows 98 days.

My guess is this is a Vista wrapper driver wedged into Windows 7 and it is having a hard time communicating with modern software framework. The 6 bits have to be calculated for each pixel, most likely an 8 bit routine then re-interrupted taking extra time.

Do you have another Computer you can test with?

Thank you

1 Like

Thanks for the quick response…

I am currently working on setting up the following:

This unit will run Win 7 Ultimate 64Bit + I will have a Virtual WIN 10 64 bit As well for testing.

I will try and do a complete new setup with this unit and hope
to have some results later on in the week.

Please advise, what is your recommendations on setting up
the maslow on a new PC ??

Good Morning Team,

Spent most of the night…and it all back up and running, I ended using a new PC.
I did a cycle jog up to 20% and everything seems to be running normally.

No deviation between sled and Ground Control cursor.
I will try running it later on today.

Thanks for all the support!!
Keep up the great work
Nigel M


Yip… All back up and groovin again…

My associate who ordered these wings is a professional wood burner, so I will update once it’s completed!

Thanks again Team!


Wow, that with a stock z-axis and not even a ring/linkage kit on triangular kinematics?? Impressive!

Yes This generation 1 Maslow seems to be indestructible! I have no need for the newer “bell’s n whistles” for now…
I have run multiple projects with no issues what so ever!!!

BTW… the reason for updating the software, still unknown!!! :slight_smile:



You are a great case for if it ain’t broke don’t fix it!

Keep making sawdust and don’t be on fire.

Seriously good work!

Thank you