Ground control do not start on WinXP

It is official! Maslow is on the other side of the pond! I’ve got my kit and I think that my Maslow is first installation in Poland!
But I immediately run into problems ;-((

I have old lenovo with WinXP.
Firmware compiles with no problems

When I am attempting to run Ground Controll - cmd widow flashes couple of lines and disapears…
I am stuck - please help. I do not even know where to start debugging. I’ve checked all connections, latest versions etc. etc.

1 Like

Hi Tom, sorry for the trouble!

I think that the issue may be Windows XP is very old and is probably not supported by the program we use to create Ground Control.

Is it possible to update the computer or install Linux?

1 Like

Darn! Let me check my options. I may use my MacMini or swap disk with Linux. What do yo suggest as better option?

If you don’t use that computer for anything else and it will be a dedicated computer to run the CNC I would say installing Linux is a good plan. If you haven’t used linux before it can be intimidating, but there is a strong and very helpful Linux community here which can answer questions you have along the way. Something like Ubuntu might be a good place to start

Thank you - wii do. It means slow start ;-))

@Bee has a ‘Linux on a stick’ that you can run from a USB drive for testing. If the graphics card does not support Opengl 2.0 you have no luck with Linux either.


Thank you Gero - good point with graphic card…

I have an older computer, not XP, i had trouble with the windows installer version of the ground control and switched to the the source version in the zip file. After installing python and putting it in the windows path, it worked fine. Hope this helps Bar has great instructions to install this option in the instructions. :grinning:


Thank you guys! Great feeling when you have such support ;-))
My first option is to fire up my old Mac Mini and try to dedicate it to Maslow: advatage of this option is that I will stay within the same OS in my workflow - Fusion 360, Meshmixer etc. and on one wi-fi network (ease of file exchange)
Second option is to swap disk on lenovo and install Linux: hate this because I have to learn yet another system ;-((. I still want to maintain my old Rhino and Delphi programs under XP. Problem with graphic card may show its ugly face…
Third option - my neighbour offered me his one-board PC so maybe running it under Linux will do
Definitely I will follow advice of Leon (@Blsteinhauer88) - sounds like The solution :wink: (graphic card permitting)

1 Like

That is not true, my maslow laptop does not support 2.0 in windows, but ubuntu runs it perfectly, appearantly linux emulates opengl 2.0

If you run it from a stick and it works, you can just make it a dual boot, a lot more practical then a stick, and you don’t lose your windows. I just installed linux, because the laptop won’t be used for anything else, and maybe in time i’ll come to love linux :slight_smile:

You could try one of the raspberry pi solutions, i haven’t found a real stable one, but you could have more luck, ask @Bee i think he found a way.


Finally I’ve got it right!
Good description how to convert Mac to Linux is here
but… I had 10.6 version of OS X and it does not work.
What worked is CD with installation image. (One tip - in order to eject CD after installing Linux, hold left mouse button during boot ;-))
I choose Fedora (another pain) and was close to throw towel after two days of trying to figure out which packages are needed to run Ground Controll. Thanks to my neighbour, who knows Linux I finally GOT IT - huraaa!!!
To the next task - Settings.
I have latest version of Maslow with the ring. “Distance between sled mounting points” and “Vertical Distance Sled Mounts to Cutter” does not make sense to me ;-(( Is this 0 as chain points to cutter all the time?

1 Like

With the ring kit, those values will be ignored when you select the “Triangular” way the chains attach to the sled. Are you using the most recent version of GroundControl?

1 Like