HELP Mac OXS! Cannot install Ground Control or Web Control

Using a Macbook Pro 2019 with OSX 12.0.1 Monterey. Solid State Drive.

I purchased the Maslow CNC and received it today, built the stand, and have been frustrated ever since. I will admit that I am a total newb as far as it comes to coding. I like pre-packaged “click to install,” everything runs, and after a couple seconds boom the software is up and running.

I cannot get Ground Control to open. I’ve downloaded it, I’ve clicked to install it, I’ve dragged it into the applications folder, but when I click to open it I get a command that says the application needs to be updated. (See Picture) Then it doesn’t do anything. I click the MakeSymLinks but that gives me no help it seems

I’ve tried reading on other ways to install it, or even other programs, but again I don’t know what I’m doing or what I have now installed on my computer via the terminal.

I’m lost and I want to scream…

Hmmm that is a bummer. I’m guessing this is an issue with the switch to M1 macs.

The error message is the same with WebControl?

Do you have any experience with Raspberry Pi or Linux by any chance?

Were you able to get this to work? I can look into it more if not.

I have not been able to get my maslow set up using my mac, which is what I want it to do.

I bought a windows laptop, but it will not open ground control. I get an error code saying that my OpenGL is only version 1.0 and it needs 2.0.

The only computer I’ve gotten to work is my mother-in-law’s. I can open ground control on it. I’ve tried for 4 hours to go through the calibration steps. When I get to the calibration cuts I get another error code saying that the sled won’t keep up.

I’m so frustrated and want to call it quits. I’m not, but that is where I am. I literally would be willing to let someone call/remote into my computer to get me through this process.

for what its worth, your exact frustrations have been felt by the majority of us so you are treading common ground so dont feel like you are alone.

for starters, who did you buy your kit from?

1 Like

Bought it from Makers Made I believe. Off the website.

And thank you. Though I’m a bit overwhelmed right now with my inability, that statement of shared frustration is both kind and helpful.

1 Like

I should note, I was able to get to the calibration cuts but then my sled was catching and jumping. So I figured I would redo them. But the connection dropped to the Maslow and just kept connecting and dropping in systematic rhythm.

ok Maker Made. Im assuming you have the M2?

Also, just to clarify. You attempted to use ground control on both mac and Windows?

there are other options available but i just want to clarify what you’ve tried so far.

I bought the Maslow, not the M2.

I tried opening Ground Control on Mac. It says the program needs to be updated and to contact the developer. No option to go any further.

I then tried to open it on a Samsung laptop that I purchased brand new yesterday. It would not open due to OpenGL needing to be 2.0 and the computer only had 1.0.

That being the case. I exchanged that laptop for another one. This one I am on now will open and run Ground Control.

However, NOW my problem is that the ground control will not stay connected to the Audrino board. I’m a bit confused there because when I used my mother-in-law’s computer earlier it was working just fine and I was going through the calibration steps. Now none of our computers will allow Ground Control to stay connected.

I’m also not sure I understand all the lingo of firmware. I downloaded Audrino from online. I went through the steps to upload the Mega2560 to the board. Says it uploaded successfully. But doesn’t stay connected to Ground Control. And Makerverse won’t even connect to it at all.

The fact that at one time you had established communication with all three of your clients, (one mac and two windows machines) is a good sign. The loss of connection issue is actualy a common problem that many have experienced and there are some best practices to mitigate this.

Let’s start by trying to get some terminology and technology squared away.

It’s helpful to know which version of kit you have because it determines what firmware and from what source you need to load on the controller and to a degree, what control software will work with your controller. There are multiple versions of Maslow kits that are available from a few different vendors. Maker Made sells two different versions of Maslow. A kit version using the Arduino Megga 2560 controller (similar to the original Maslow kit) and a kit version using the Arduino DUE controller (a version developed by Maker Made as part of the M2 kit). I’m not sue which version you have.

Take a look at the controller from your kit. If it’s self contained in a single enclosure than it’s probably an Arduino DUE and therfore probably an M2. If the controller consists of an Arduino Megga 2560 and a seperate motor shield (board with heatsinks) than it’s the other kit style.

I was FINALLY able to get my set up up and working. I started to cut out my final sled, but then realized my board was not going to be big enough to do the full circle. Other than that though everything finally seems to be working.

And I was a pure fool for thinking I wouldn’t need/want the z-axis at first. Installing it and it working properly made me realize you’d be crazy to not utilize it.

2 Likes

I’m glad to hear you got it working. If you have any further issues, don’t be afraid to continue to reach out here as someone somewhere has probably run into that problem.

A few notes to hit based on the issues you had here so far. As @jonatpridesleap was asking, how familiar are you with Raspberry Pi? I ask as you are talking Ground Control which has been deemed old and no longer fully supported. WebControl has taken the place of GroundControl. It can be run as a server on a Raspberry Pi that you would access through a web browser on ANY PC you have (Mac, Win10, etc.). This could also help with some of the connection problems you indicated you has as you could place the Pi next to the ArduinoMega and keep the USB cord as short as possible (one of the main issues that causes the drops in connection you mentioned).

And as for the Z-axis, I would always recommend one. The basic Z-motor kit works just fine, but there are many others here that have created updates/upgrades that with the proper gearing, you can speed up the Z-movement. I am a fan (and have done) the Meticulous Z-axis created by @MeticulousMaynard. There is is post on the forum that covers everything for this to include a parts list and what files need to be used to cut the parts out with your current Maslow. There are many other versions out there as well, so just some food for thought as you continue on this journey.

Good cutting!!