OpenGL won't read current version

Help! I cannot open ground control. It fails. I’ve uploaded the current version and extracted everything then when I try to open the application it gives me the opengl kivy fatal error. This goes deeper than I know about computer. Never even knew what openGL was until after this. I’ve tryed Bee’s disciples of CNC method but I can’t get the Linux on the stick to get onto the stick. Maybe I’m missing something. If anyone out there is willing and able to Help that would be amazing. I’m using a Dell Inspiron N7110 I bought it new back in 2011 or 12. Windows 10 Home. It’s done everything amazing up until this openGL thing. Do I need a new graphics card? I know the HD graphics 3000 is pretty dated. Any feedback whatsoever would be appreciated. If your reading this I know you have something to add. Please Do! Thank you in advance.

First of all, thanks for the screenshots, those bypassed a number of questions I might have asked. You seem to be getting conflicting reports of the version of OpenGL. A couple of possibilities suggest themselves.

  1. Do you have a docking station or a secondary graphics card? Windows may be reporting OpenGL from one card’s perspective but the version is downgraded for the other or something like that.

  2. Could you run the following? It might not tell us anything new, but…
    Check the graphics card type (Windows):

    1. Open the Windows Run dialog box (Click Start > Run ).
    2. Type dxdiag to access a diagnostic tool listing the graphics card information.

Sorry, I’m really more of a Linux guy, but I wanted to get us started on diagnosing our problem.

1 Like

Don’t know if this has been covered, had something similar with a HP workstation i used with on-board graphics.

Updated the graphic driver to the latest, chipset drivers to the latest, and made sure ALL windows updates were applied, including all optionals. That fixed it for me.

1 Like

Thanks for the reply.

  1. I don’t have a docking station or secondary graphics card. Just a standard laptop with to only “upgrade” being the free upgrade to Windows 10.

  2. I’m not really too sure of what to be looking for, but this is what I saw.

Yes, especially make sure that Windows Updates have been performed. @Brendon isn’t the only person for whom that worked. I think @mooselake has helped some other users with Windows OpenGL problems. Otherwise @Bee should be able to help you with getting linux on a stick. I’m running linux natively on some pretty ancient Toshiba hardware and it works just fine. Boots slow as molasses, but works fine!

Thanks for the replies. I’m going to do some tinkering and some cursing lol hopefully I can reach a conclusion and get some dust flying soon. I’m about to pick up a laptop to run dedicated Linux on and just go that route.

Have you tried googling “Intel hd 3000 opengl”? Might add windows 10 to that but I didn’t need it.

The official answer is that that intel no longer supports the device. However the win7 and 8 drivers do support openGL, and if you giggle around you can find out how to install one if them (I suggest first try using what your vendor supplied back then, then the latest win8[.1] driver for it.

I found several references that installing Windows 7 might work (depends in which openGL version you get with it), although I’d only do that if you have no other use for the laptop.

Looks like that’s a 2011 vintage computer. While it’s sad that spending that kind of money gets you something that’s been abandoned 7 years later that’s just the way the industry treats it’s customers. Hyper rate change means short lifetimes, alas

1 Like

where is groundcontrol installed?

if it’s in the root of the c drive, it will not run.
I do have a environment variable you can set that will fix this issue if it’s in a location it can safely run.
open powershell as an administrator, and run this:
[Environment]::SetEnvironmentVariable(“KIVY_GL_BACKEND”, “angle_sdl2”, “User”)

1 Like

Here’s my story as of right now.
My good laptop would not do run Maslow and I didn’t want to screw up the drivers because everything else on the computer ran awesome and I didn’t want to impact anything on there. My solution was to buy a cheap laptop.
I was lucky enough to find an amazing Lenovo ThinkPad T400 for 10 bucks without a hard drive or OS from a co-worker. I did the eBay thing and got a cheap 750GB HDD and booted Windows 7 on it. Guess what? still had the same friggin Kivy Fatal Error message. So I dug deeper and deeper. I found that going to the Device Manager it actually highlights the drivers that need tending to (I had no Idea about this I’m a legit noob) so a little more digging and found a site that would give me a driver for the ever popular and not supported AMD 3400 graphics. Downloaded the driver and now I’m able to actually open GroundControl. It was a long race to find out that I just needed to update an non supported graphics card. Someone on here told me to google and definitely should have done that before buying a secondary laptop but now I have a Maslow dedicated laptop and getting ready to let the dust fly. Thank you everyone for the help and advice. I’m sure I’ll run into more things I need help with in the future.