Maslow Home Maslow Community Garden Newsletter

Ground Control Not Responding and Malware Warning

#1

Software: Ground Control 1.24 and 1.26
OS: Windows 7
Computer: Dell Inspiron 1720 laptop (kept around as better than nothing spare)

Was just trying to calibrate after initial build.

Initially GC 1.24 with Firmware 1.26. Warning was issued about version mismatch but I proceeded. GC stopped responding after some progress to the goal and I aborted the program. I repeated this cycle several times.

So, about that version mismatch. Loaded GC 1,26 and my antivirus threw a malware warning and refused to run it, (This PC uses my internet provider’s antivirus software). I copied that GC 1.26 image to a USB stick and later launched it on a different PC with different antivirus software and there was no complaint but that didn’t help progress in the shop. (I would rate the original malware complaint as concerning but not critical)

So I loaded Firmware 1.24 and used it with GC 1.24 and was able to cajole everything through calibration.

The software behavior seemed to be that if I tried to step backwards from the current step or change an entry that GC would stop responding,

The version mismatch may not have been responsible as I became very careful about my entries. I did manage to make the sled move with a manual entry, but still haven’t made a cut.

Unfortunately, that one move created enough slack to allow the slack chain to fall under the operating chain. That doesn’t seem like a good thing to happen. And. Is also covered in a different forum.

#2

I’m not sure why some people are having malware strikes against ground control 1.26.
I ran it through virustotal and my local antiviruses and nothing was flagged.

#3

You could try running Windows in safe mode.

Thank you

#4

I have had similar instanced where for some reason the antivirus sees GC as a threat. I think what mine was saying is that there were many “editors” of the software and then there was not enough information about the file on the internet. I went through and made it an exception. I would try doing that or if you can turning that feature off just to test and see if that fixes your problem.

#5

I’ve been out of the loop because I don’t have all of my computer parts yet but are Ground Control & firmware versions 1.26 ready for Windows?

#6

I was operating 2 different machines on 2 different windows on 1.26 this week. All seemed to be fine for me.

2 Likes
#7

I spent $220 on a new windows laptop to dedicate to my shop and (aside from my usual annoyances with setting up windows) most things are better. Both GC 1.24 and 1,26 open. For reasons I didn’t explore, firmware 1.26 failed to build so I am using firmware 1.24 (previously built and loaded from the older PC) with GC 1.24.

At some point one just wants to cut wood.

So, after cutting two sled blanks (ruined the first trying to position the router mount, added the router mounting geometry to the second).

On Sunday at noon I was where I wanted to be on the previous Wednesday.

3 Likes
#8

Thanks for posting @alanmoerdyk . I’ve had too long of a process not to benefit from the patience this could help me to foster.