Ground Control On Raspberry Pi 3 Model B

Trying to use a Raspberry Pi instead of a standard laptop. Followed all of the KivyPie steps and finally got Ground Control running. I’m have two issues though. First, my mouse and keyboard are not working. I followed the steps to comment out something… should I comment it back? Secondly, Ground Control wants me to update to pyserial 3.x, which I’ve done. But GC still thinks I’m using 2.6. See attached image. Any ideas?

I have had a great experience with Ubuntu Mate Linux on the same hardware, following the generic Linux setup.

Here are a group of other discussions in the forum:

The following only works with a Pi foundation touch screen & Pi * ( the current image only works with the older Pi3 B not the newer B+ model)

Hope this is helpful

Thank you

1 Like

Wow! Thanks for all of the great info. I’ll try a couple of these out and see which one works best, and report back.


Anyone tried Raspberry Pi 2 Model B ? (previos 2nd model)
I have one lying around, mint unused in a box. That would be better as I cry every time dust falls on my new MacBook :frowning:

any pi2 should be easily good enough.

Sorry for bringing this topic up again but while I am preparing the Raspberry Pi3+ I am confronted with some issues.
I followed this instructions

And now I am stuck and get this error

"pi@raspberrypi:~/kivy/kivy/kivy/kivy $ cd /home/pi/kivy

pi@raspberrypi:~/kivy $ python build

File “”, line 1024
def glob_paths(*patterns, excludes=(’.pyc’, )):
SyntaxError: invalid syntax

pi@raspberrypi:~/kivy $ sudo python install
File “”, line 1024
def glob_paths(*patterns, excludes=(’.pyc’, )):
SyntaxError: invalid syntax

Anybody knows how to help me?

best regards

It’s been a while and kivy is a moving target. I used the Linux instructions in the past to get it fully installed locally. I remember getting errors and having to work through them with Google but got it to run eventually. This is over a year ago now.

Or you could use - WebControl Releases for Testing

Webcontrol is not based on Kivy

Thank you

Finally I did it…took me hours of doing stuff that I did not understand, but I think I managed :smiley:
Now I just have to wait for the touch screen to build my new control-brain.

1 Like

Yesterday the worst thing happened…my micro SD card broke into two pieces :cry:
After buying a new one I am stuck again in installing the Kivy in combination with the Ground control.
Always get the same issue with the same error like in my post before.

Is there anyone out there who could make things easy and provide me a raspbian image with already installed GC?
Or anyone that can help me out installing it?
I tried all methods out there and don´t understand the problem

What a bad deja vu :frowning:

I think that if you switch to webcontrol you will be much happier.

David Lang

Good evening @dlang
Thanks for your answer.
Maybe I understood this wrong but doesn´t Webcontrol needs an internet connection?
If yes its not an option for me because in my basement there is no internet…
As far as I understood every device has to have the Internet Connection.

By the way the problem with GroundControl seems to be the Version of Kivy.
If you follow the GitHub wiki it will download the latest Kivy running on Python3.
Seems like GroundControl is not working with that. :thinking:


No, WebControl does not need an Internet connection (other than to update itself

it’s a webserver that runs on the Pi and you use a browser to connect to it (it
can be a browser on the Pi, on your phone, or on a computer)

David Lang

Aha! So correct me if I am wrong
I install everything on my Raspberry like described here…

…and then? How do I get the connection between this device and for example my iPad?
I connect it via WIFI to the PI correct? So I need a router connecting these things :thinking:


If you followed the setup instructions then the Raspberry Pi should be connected to your WiFi. You should be able to see it listed on your router in DHCP list or attached devices.

Then you connect your IPad to your WiFi and go to http://maslowpi.local:5000. If that fails then you will need to know the IP address of your RaspberryPi and use that instead. e.g.
change the ‘’ part to the IP of your Raspberry Pi.

Please note that the first time you start the Raspberry Pi it will take a long time to download the WebMCP image (10-20 minutes) during which you will NOT be able to connect to it via http.