Maslow Home Maslow Community Garden Newsletter

Ground Control Up and Running, Errors Showing

Just installed V1.26, firmware 1.26 (previouisly had v.73) on a Windows 10 platform.

Getting the error -
"Please set $12, $13, $19, and $20 to load old position data "

How do I go about doing this?

Just a side note for those who might see this who are involved in generating the Ground Control code,

I’m visually impaired, and the friend of people with vision issues in high contrast. V.73 was fantastic, virtually all white on black background. The new version is torture for people like me. Allt he shades of gray on top of one another make it very hard to see.

Love the platform and really appreciate the time you’ve spend on it, just wanted to give my inpute. Thanks!

I just happened to read a thread on that the other day, although I was searching for something else entirely. But if you search on that message without the quotes it brings up about five old threads.
Also in this wiki:

Fantastic, thank you!

It’s funny, I see your username and I was just thinking earlier today that I’d love to build another kayak, and I was wondering if there were form files available anywhere.

I build a strip-built sea kayak about ten years ago, and it was such a fun project. I built the strongback and forms from paper prints, pasting and cutting them. It’d be so much more accurate to cut the forms using a CNC.

And now to figure out how to clear an EEPROM…

in webcontrol -> Actions -> Wipe EEPROM:

I cleared it using instructions I found on YouTube, created a new blank program and uploaded it, didn’t work.

Sorry, what’s this WebControl? Where is it located/do I have to download it?

Ugh, not a computer guy, I’m a woodworker! lol

Assuming your are using windows

download the windows 64 bit version here:
https://github.com/WebControlCNC/WebControl/releases/download/v0.932/webcontrol-0.932-win64-singledirectory.zip

or 32 bit version here:
https://github.com/WebControlCNC/WebControl/releases/download/v0.932/webcontrol-0.932-win32-singledirectory.zip

find the file, right click on it-> extract all, put it somewhere easy to find like in my documents. Then open that folder and double click the webcontrol.exe file. You will need to have ground control turned off so the serial port is available. Select the serial port in the Settings->maslow settings menu option and find the correct COM port and then the action buttons will work. Good luck!

WebControl’s color scheme is nicer to me, ground control I found visually difficult on my eyes. Although WC has some gray screens too.

Wow this is frustrating! This is the reason I never upgraded from V.73, it seemed like every time I updated, it caused issues.

That being said, I super appreciate everyone’s help and support!

I installed Web Control, wiped the EEPROM, reinstalled the newest firmware via WebControl, nothing worked, morots ran for a split second when I jogged, then wouldn’t respond. WebControl says I’m connected, but it won’t even test the motors.

Closed WebControl and opened Ground Control, will not connect.

Re-wiped via WebControl, tried reinstalling the latest firmware via Arduino IDE, keep getting an error message that it can’t write.

Re-confirmed via WebControl, it says I’m connected.

Wiped the board a few more times and re-installed via Arduino IDE. Finally connects using Groiund Control and will move, with errors. Looks like I have a bad X-Y motor. It’ll move, but doesn’t seem to be reporting position. I ordered a new one.

Thanks for all of your help, I’m definitely learning a few things…