Haven't touch maslow for a while went from 1.13 to 1.16 version for software and firmware

I haven’t touch the maslow for a while and now that I’ve just started again, I uploaded the new firmware into the arduino and setup the new version of Groundcontrol.

The first cut went well, when I tried to upload a new g code file, the arduino couldn’t connect to my laptop(macbook Pro 2014) and i wasn’t able to reconnect at all.

What I did :
Reset the arduino and tried to upload the firmware again.
Still no connection able with Ground Control.

What it did a while back on the 1.13 version, the machine got disconnect a lot from groundcontrol in the middle of the cut and cut straight through to home position.
The problem was identified and I’ve already change my USB cable for one with ferrite at both ends and a shorter one than the stock one.

Here is my log file :
log copie.txt (1.6 MB)

Please Help.

So the firmware upload works, meaning the connection to the port seems ok. If you open the serial monitor in the adruino software are watch for a few minutes, any disconnections?
After you close the arduino software and open GC, what happens if you go to settings, select the same port as the arduino software used and click connect?

1 Like

Looking through the log file, it certainly looks like intermittent interference on the serial connection. Electrical noise from nearby motors could be a cause - any vacuum or dust collection equipment running? The interference doesn’t start until about 2/3s of the way through the log file, what changed in the shop then? Once in the past, Bar found that using a drill motor caused something like this.


the things running are the AC unit (big one), the shopvac for dust collection and the Ridgid of Maslow.

Since you’ve already got the ferrite-protected USB cable, those motors might be good suspects. From the log file, you must be running a Linux or macOS setup. Taking a look at some of the last few lines of the log file in a text editor we can see the ‘Sent: G20’ from the GroundControl program and the garbled stream received back from the PowerControl board:

Sent: G20  
bõ,H@M%4Aü†w	ê¨  1üœwú¨4$ %(
Jª $9ñü–S ORSRsR4Ïžû¼4$4-(

If you’re comfortable in the command line, you could tail -f the log file, run a cut file without a bit in the router, and watch while various motors turn on and off to find the culprit…


Looking back, I think I might have misunderstood your present situation, sorry if that is so. Are you able to upload the firmware from the Arduino program now, or has all communication between the computer and the Arduino board gone bad?

1 Like

No you understood correctly, I have a trouble keeping the arduino connected to my Mac and I didn’t understand why.
The first idea was that the interference had it disconnected on and off so that groundcontrol couldn’t follow.
Now, i’ve uploaded a blank program (like the one you have when you open IDE for the first time) and then I re-uploaded the firmware.
I tried to small triangle piece on my ply wood and even if the depth was off (the plywood was bendy) groundcontrol and the arduino seems to behave normally, even with the shop vac, the router and the AC unit running (cannot turn that off unfortunately)…

1 Like