Having a shot at building a distro (using Ubuntu Mate i386)

don’t even try, they are re-writing lots of core functionality to use Python3
isntead of python2

you just need to find the python2 version of the packages and install them.

1 Like

i’l give it a try to install all this from repo instead of pip

i hope i can make it work like that. allthough i see that pip has been chosen to be sure to get the right version.

1 Like

Python 2 and 3 can peacefully coexist. No reason to pull 3 from the Distro, just call your apps using the correct command line.



In the standard Pi - Raspian both Python 2 & 3 are included and indeed GC runs to the correct version when it is started. The only time it’s an issue is when as a dependency V2 is missing.

Thank you

1 Like

a little update on my progress:

i escaped the wrestling with the pytons in 17.10 looks like it needs a special version of cython that’s not in the ubuntu repo… but i don’t know that much about python.

i went back to 16.04.3 and i managed to make that work 100 on repo packages. with the current versions of GC and firmware (0.99)

i’ll have to find a nice place to upload the vm.qcow, so that people can give feedback and tinker with it

i also tried Kubuntu, but that felt very sluggish in the VM, so for now i stay with ubuntu mate

since many distro’s are about to drop 32bit support i’m having a look at distro’s that focus on 32bit this should be powerfull enough for GC and make it possible for us to run on ‘old cadavers’. People will soon give these old boxes away for free just to get rid of them so lets see if we can put them to use.

1 Like

@Bee , i will keep trying to get GC on 17.10 going, i have spent a bit too much time on it and got confused in the process so i shoved it aside for a few days. Also the bullshit of life is having a go at me again so i should sit back every now and then …

1 Like

I also want to add v-plotter.py to the distro somewhere. not yet sure how to do this so that it does not get lost when i make the ISO
Would anything that i have (Kivy + GC) be affected when i make the ISO? n the back of my mind i hear a tought that warns me about this

Does anybody know how to make a .desktop launcher to launch python.
the command sudopython main.py doesn’r seem to work there.

v-plotter.py needs python-skimage to wok
so i’ll add to the VM
sudo apt-get install python-skimage

create an icon and set it to run a command, and click the box “run in terminal”

yes, thats what i try to do, but for some reason this fails to launch GC.

I have made it executable

terminal=false (And also set to true both no joy)

EDIT removed some confusing content

Having a little setback, FireFox 57.0 Update turns out to create old fashioned mess.
I’ll try to see the educational value in it, but it still sucks…

OK, .desktop here i come…

On a machine where i installed maslow manually:

[Desktop Entry]
Exec=/usr/bin/python /home/maslow/apps/groundcontrol/GroundControl-master/main.py

this works fine.

however on a machine where i installed trough git this doesn’t seem to work that good

[Desktop Entry]
Exec=/usr/bin/python /home/maslow/GroundControl/main.py

whereas it can be launched from the commandline without issues.

also when Terminal=true like @dlang mentioned it crashes

I tried this:
#!/usr/bin/env xdg-open
[Desktop Entry]
Name=Maslow GC
Exec=python /home/whoareyou/Maslow/GroundControl-master/main.py

And put it in --> /home/whoareyou/.local/bin/applications
Then I pulled it from the menue to the desktop, had to mark it once as trusted and now it works. Thank you!

1 Like

is that essential?

I like the name Maslow GC

I see you also installed manually (GroundControl-master)

i wonder if my install from git has some permission issues

that line is not from me :roll_eyes: must have sneeked in when i pulled it to the desktop?
Let me delete it and see what happens :slight_smile:
It still launches, with a window though, but the window was there before. The first line can be ignored I guess

1 Like

in my git install the folder GroundControl belongs to root

once this is a real installer then this should not be root but the process should have it’s own user and group somehow

1 Like

User: Maslow
Passwd: YouWillCutIncredibleThings


I’m going to leave this one alone for today, it works when launched from commandline,

launching stuff as root from a desktop button should just not be done…

but how this should work from a git install i really don’t know. (is this even possible) far as i know this is dealth with from a .deb installer or ppa. but don’t have any experience with it

BTY I appreciate your work! I spent last Friday and Saturday trying to make a live version and an installer directly on a USB drive with all tools. I failed with Kubuntu, Lubuntu, ubuntu-mini and linux lite, killed one usb drive and managed to destroy the boot loader on my office machine before I gave up. It is always good to have a Boot Repair Disk lying around.


thats why i now meddle in a VM :slight_smile: i’ve messed up lots of boxes with stuf like this. :slight_smile:

in now i make a copy of a VM once it works… and try to keep the working image safe somewhere.