HELP Mac OXS! Cannot install Ground Control or Web Control

are you familiar with using the terminal on a mac? (iterm2 I think)

Nope. Like I said, when I bought this machine, the instructions were clear, everything worked as on the tin…seems like it’s kind of fallen apart now.

mac put out a new processor that doesn’t work with any of the old software. To make it work you have to go back to the source code and recompile it for your new processor. nothing broke, you just got a different machine that uses a different set of instructions. You can get a program called bootcamp and load a different operating system and run it from that. Or you can pull the source and load the dependencies and run it from the code. It is all there. It will work, but it will take some time to set it up.

Does anyone have groundcontrol or Webcontrol working on an M1 mac? If so, can you run the build script for @Brad_Wensley and share it so he can run it too?

I’d be happy to do it and share, but i do not have an M1.

GCC to compile the source code from GitHub?

It is python so you don’t actually have to build the release. You can just run it. You just have to install all the dependent libraries. those are found in the requirements.txt file. First thing to do is to open your application folder (in the finder?).

search for “terminal”

open the terminal application

it will give you a command line with the >_

make a folder for webcontrol: type (without quotes) “mkdir webcontrol” press enter
move to that folder: “cd webcontrol”

from there you need to install git: “brew install git”
Once that completes, type (without the quotes or the backslash before the https) “git clone \” that should pull the webcontrol source code from the github server and it will likely be in a Webcontrol Folder.

Now you need to see if python is installed. you can do a spotlight search (command + space) and type “python” and see if it is found. if not, back in the terminal, follow these instructions to get python and install it. Where it shows “pyenv global 3.9.4” instead use 3.8

once python is installed, you need to go into the Webcontrol folder and run this command: “pip install -r requirements.txt”
once that finishes, you should be able to run webcontrol by typing “python” in the Webcontrol folder.

If he hasn’t used terminal, he probably hasn’t installed homebrew, so will need
to do that as well.

David Lang

When trying to run % pip install -r requirements.txt I get the error "zsh: command not found: pip

Yup…worked on this for 4 hours last night. No luck on anything.

Here is an updated GC version that should work with your Mac

Ground Control 2022

1 Like

Thank you! Perfect.

@josm will Eastbay’s updated groundcontrol work with the original shield?

Pretty common thing for Macs, 68K to intel to this M stuff. A mess every time, but memories are short

I remember each of those, but that is their ecosystem. I choose not to repurchase software for each of their evolutions.

Sorry to hear that. I hope the Eastbay ground control release will work for you. I didn’t think of it when responding to your inquiry… would have saved both of us some time. Good luck to you!

I don’t see why it wouldn’t work. the only issue i can think of would be the max feedrate being too high for the old shield, but this can easily be fixed by throttling it down in the Advanced settings options.
My kit has the old TLE shield and this upgrade works flawlessly (no more alarms and it cuts much faster than before)

1 Like