Maslow Home Maslow Community Garden Newsletter

Still no images in ground control Calibration setup?

Set up my maslow over a year ago and during the setup I noticed there were no images where the instructions claim there should be. now nearly a year later I have returned to setup the maslow again and still there are no images in the calibration setup?

What gives?
am I doing something wrong? Dom I have to download an assets folder separately?

I am on a Mac, does that make a difference? I will gladly switch to a PC, the Mac was just handy and rarely gets used over my PC and Linux machines.

Anyone else experiencing the came issues? how did you fix it?

I don’t think the instructions are correct here - things moved on in terms of Calibration.

Considering you are just (re)starting I’d recommend switching over to WebControl instead.

There’s a range of releases at: https://github.com/WebControlCNC/WebControl/releases

One other option is to clone or git pull the actual WebControl repository and then follow this link to get it running locally on your Mac (or pretty close to it - the rest you’ll be able to figure out by looking up error messages on StackOverflow): https://github.com/WebControlCNC/WebControl#virtualenv

It may seem a little bit more involved, but if you ignore the stuff related to getting it working on a Raspberry Pi (or using Docker) you should find that the few instructions left will get you up and running on your Mac.

Maybe I’m a little confused, does this replace ground control? also does this contain info for calibration as well? In other words is this a full replacement for ground control or just better for controlling the gcode to the Maslow? I’m thinking this may be a little over my head getting it to run on a Mac, can you explain how I would go about making this work or at least steer me in the right direction?

Yes, yes, full replacement

Good point - I just checked the Releases and there’s no OSX version. So doing the “build it yourself” path will work for you.

So that’s the ‘one other option’ from my previous message.
Go to https://github.com/WebControlCNC/WebControl
Click the ‘Clone or Download’ button, and select the option that works best for you. You’ll want this to go into its own folder.
Then get yourself into terminal window of some kind (e.g. bash, powershell, whatever, something that gets you to a command prompt). Change to that folder above where you put everything, and follow the steps under:
https://github.com/WebControlCNC/WebControl#virtualenv

Most of the steps ‘do their thing’ pretty much automagically. Macs already come with a default Python installation, which should be enough to get you over the start line at least.

Can you send a link to where these instructions are? I might be able to fix them

It’s in the ground control application. If your asking about the images missing. Specifically the Mac version, I haven’t yet tried the pc version.

Do you think you could post a screenshot? There are absolutely supposed to be images there. I’m seeing them on the windows version.

Is anyone else on Mac seeing this?

Yes I’ll do that, for the record I haven’t ever seen images in ground control in the twoish years I have had it the images have never showed up, to be fair I have used the same computer the entire time so it could also be my computer, I’ll try it on my Windows machine later as well.

1 Like

Hey Brother

Sorry for the delay but i did go through the calibration and found that there are only two pictures missing here is a picture. the others seems to be fine and for the record this is on the mac version, haven’t checked the windows version yet because I don’t have a windows laptop.

1 Like

This could be the old issue with .jpg vs .JPG extension of the pictures. For mac and linux this makes a difference. A temp workaround would be to dig into the folder and rename the image extension.

sounds good I will give it a try, thanks!

I did check the current Master of GC for .JPG in the code and could not find any. Also all pictures are .jpg and confirmed to show on linux. So I was wrong. What version of GC is this?

FYI, the 2 missing pictures are referenced in groundcontrol.kv line 784 to 786.

          source: "./Documentation/Calibrate Machine Dimensions/Quadrilateral Kinematics.jpg"
             source: "./Documentation/Calibrate Machine Dimensions/Triangular Kinematics.jpg"

I checked the .dmg version of GC 1.26 in releases and found that the 2 images are simply missing.

yeah I am running 1.26 anyway its okay, I knew what I was looking for and the other images seem find and I was able to calibrate without issue.