Error Message that Sled is not Keeping Up

Uploading: IMG_5699.MOV…

Attempted to upload a video of the motor making electronic beeps etc, but the file is to large to upload here?
I am had bought a new motor cable awhile back when I cut through the z axis cable, but never used it…I had the other cable fixed by an electrical guy and its fine since…
Installed the new motor cable motors passed initial motor test, but failed when I tried to move the sled to a location.

i cleared the log file and loaded a quick gcode file for testing.
I will attach the files for review (please note, that i am still learning fusion 360 and i haven’t learned what to turn off, so there are a few lines that are ingnored)

log.txt (693.8 KB)

zplate (43.8 KB)

i really do appreciate all the help with this issue

1 Like

The clicking sound in post #3 suggests a possible stripped gear, the intermittentcy suggests it might be worn and not quite fully OPD

1 Like

I can hear a series of beeps. I don’t hear the electric motor trying to tire. Then you hear a beep and the motor turns in the opposite direction

A few thoughts:

  • Is what I heard the first time with measuring motor distance in calibration, indicating a stalling motor.
    But this is with the TLE5206 shield I’m using. Never heard it with the PCB v1.2 you are using.
    Since the heat sink fell off you also should consider that the shield is fried as one the possibilities. :frowning:

  • Unrelated (perhaps) to your problem, but strange is the “can’t keep up” in your log-file.

line:3697 →
Tool Change: Please insert tool 2
Maslow Paused
Sent: ~
Sent: S10000 M3
Sent: G54
ALARM: The sled is not keeping up with its expected position and has halted. Click the ‘Stop’ button to clear the alarm. More information at: Keeping Up · MaslowCNC/Firmware Wiki · GitHub
[Forward Calculating Position]
position loaded at:
Command G54 unsupported and ignored.

The sled has not moved at this point as it’s the header. However something seems to have triggered the Position Error to jump.

  • The gcode has a few things that would make me worry to run it my machine as it is.
    Was this done with the >Maslow-post-processor< in F360?
    Nothing that I can name to be an issue, but things that I do not know how thoroughly they have been test against FW/GC.
    – Many lines do not have a leading ‘G-command’. The last G is assumed I believe in most programs.
    – G3 commands do sometimes have I/J and sometimes only one of either
    – some moves have only X or only Y in the line
    – The first move is at Z0. Looks like you need to set a safety height in F360 as the Z0 can be found in the start of the gcode.

Consider to do a ‘clean start’ by wiping the eeprom and renaming the GC.ini to exclude that something is jammed in soft- or firmware and load FW/GC 1.24

1 Like

This is so very similar to my problems. When my motor test fails (direction 1) it makes a series of beeps (sounds not sure if they are beeps), then moves to the other rotation direction. I am going to try and get a recording of it tonight also and upload to my posting.

Any help you all can give to my situation would also be appreciated. @blurfl has been most helpful already in identifying issues with the firmware and my Gcode.

A couple pieces of information that would help in troubleshooting this issue would be

  • What PowerControl board are you using - stock Maslow, BlueSmoke, other (which?)
  • What is the version number shown on the silkscreen of the board
  • what version of firmware
  • what is the setting of ‘Advanced/PWMfrequency’

It would be especially useful for troubleshooting to find a way to make it happen at will. This seems like something that could involve the PID routines, but it’s tough to see what could be causing it.

I will find out the board version # tonight. My system was in the last batch sold. I am using an original board from Maslow, and the most current software versions (1.24)

Thanks, that’s enough to let me know which parameters are bing used.
That log file that you posted, moving in a 1" square and then testing the motors, ‘Fail motor test set 1 Log.txt’ - does that reliably fail the motor test, or even intermittently but often?

Almost always fails for both motors during the motor test. I did have a couple of times that the right motor passed the test in both directions. When I shut down GC and loaded again, it failed the next test.

I tried but can’t upload video but it gives off multiple rapid beep sounds when it tries to move direction 1.

This sure sounds like changing the post-processor would be a good idea. These
things are legal g-code to some systems, but not others.

David Lang

No, it was generated with GRBL generic at best I can tell

Can Maslow CNC Handle G3 commands? and I/J etc?

I went back and found a post about a MaslowCNC.cps for Autodesk/Fusion 360…I finally figured out how to load that file into Fusion 360 and generated G-Code…I noticed that gcode file looks cleaner, but there are still lines that only have a Y or X and it does have G3 lines in it?
000125 zplate test MCNC (69.2 KB)

I am very interested in figuring out a better post processor to use…please see above quotes and trials, any information would greatly appreciated…

I am using Stock Maslow v1.2b (I can attach picture if needed)
I am currently using GC and Firmware 1.2

where do I find this setting at?

Just curious what program do you use to generate G-Code?

Yes, the firmware handles G3, and all the absolute mode variations of I and J. If you update to v1.24, use this corrected version.

The file ‘zplate’ linked above includes commands intended for a full 3D milling machine. There are arcs around the X axis for instance, and the fact that the file is written for that geometry could be the reason for the sled errors with that file. The later file ‘000125 zplate test MCNC’ runs to completion without error in the simulator, so should cut properly.


I use Estlcam for gcode.

Settings->advanced settings->PWM frequency for motor control.

$39=3 (PWM frequency value 1=39,000Hz, 2=4,100Hz, 3=490Hz)

is in the log. The other settings also seem normal/default

1 Like

I cut the above file and another one that I generated with maslowcnc post processor.

I am happy to report that Maslow cut both parts to completion without any errors.

However thr sled didn’t move smoothly through the cut. (Kind of jerky movement )

Wil the new firmware and ground control fix that movement issue?

1 Like

can you post a video? there are lots of possible ‘jerky movement’ causes. Some
may be firmware, some may be hardware

David Lang

Sorry for the delay getting back to the topic, I have had to work non stop this week, and then my girlfriend had a pretty serious injury to her knee…I did managed to get a video…but due to size it won’t let me upload to the forum…I am cutting a part now, and for some reason its not as jerky as before…

I plan on updating the firmware and ground control this week…i almost hate to for some thing always goes wrong when i do…

Thank you so much for your help and suggestion of post processor…