Holey Webcontrol Testing

Sorry… I forgot to push it. It’s there now.

Testing Methodology:
Starting with a wiped Arduino and fresh Pi image. I used the “Quick Configure” and “Set Sprockets Vertical” options to populate the initial configuration. Once that was complete I set the z-axis zero and executed the “Holey” pattern cut.

Initial settings:
Height to Motors: 407 Distance Between Motors: 2999

Holey Measurements: M1:971, M2:972, M3:967, M4:969, M5:703, M6:697, M7:703, M8:1191, M9:1200, M10:1201, M11:1193, M12:289

Calculated Measurements: Height of Motors:493.23422, Distance Between Motors:3604.11278, Left Chain Tolerance: -0.05903, Right Chain Tolerance:-0.12675, Calibration Error: 1


  1. Typo under “Settings”. In “Maslow Setttings” the word “Setttings” should only have two "T"s.
  2. When setting zero on the z-axis there is no button to return to safe travel distance. Perhaps the first move in the holey g-code should insure that the bit is at least +5mm from zero.
  3. Holey suggests a HUGE deviation from the measured geometry of the machine. Any ideas how to account for this?

Please let me know what is needed next.


Thanks, I’ll look at it today… something seems off for sure.

To debug the GUI against the calibration, you could enter those measurements into the RunHoleyCalibration script. At least that would eliminate one potential source of error. Further, it could give you a good calibration.

I sent you a message… I’ll look at it this afternoon. Im worried that the quick configure might not have worked…

I’m not concerned about the quick configure as 407 and 2999 are the actual measurements I entered. My concern is that the chains let out too far. The 12 measurements describe a parabola and are symmetrical within a couple of mm. One thing that has always bugged me is that ~3000mm is the correct beam distance between motors, I’ve measured it 10 different ways with 3 tapes, but GC’s calibration finds ~2975. It’s a steel superstrut channel. There is no flex happening.

So the initial cuts came out very poorly is what you are saying. I was concerned that the quick configure values weren’t actually working and wasn’t updating the firmware (i.e., the controller cut thinking the distance between motors was ~3600 and not 2999)

I think I have a lead on the problem… I ran the values in @joshua’s standalone and see I get similar results if I don’t change the default motor distance and yoffset values… So it looks like webcontrol is not updating them in the calculations…

Yeah, the individual holes are pristine. 2999.6 was actual, 3600ish was the calculated correction. The parabola thing is described in the Mxx measurements. See below.

Look at the ratios of m1 & m2 to m3 & m4, then look at the relation of m8 through m11. I need to center and check the chain lengths.

1 Like

There’s an update dockerfile:

docker pull madgrizzle/holeywebcontrol

and then run it with the same command as before.

1 Like

I think this is common (but maybe not that much of a difference… one inch is a lot)… I don’t incorporate the machine measurement in webcontrol because I trust hand measurements more.

1 Like

The “Maslow Setttings” typo is still there.

Much more reasonable numbers!
Calibration error: 1

On a side note the ~2975 (corrected) is hilarious.

1 Like

Sled error after accepting results. See below.

Not sure where to go from here as the red crosshair is way off.

1 Like

Can you see what the chain length are? Looks like the X and Y positions (displayed in text) aren’t the same as the location of the red crosshair.

Actual or software? If software how to I find it?

Hmmm… has to take kid to doctor… will look at when I get back (or during the looooooong wait for the doctor)

Try hitting stop to see what it does… refresh browser… switch units to metric… one of those may help. Let me know.

Ok, things got weird. I now have a ~ 6 inch wide worksurface.

I think i found the issue in firmware that caused the positional error message. I had to add kinematics.init() calls to recalculate the sled position after updating settings. If this isn’t done and the amount of settings is significant, it will exceed the 2.0 mm position limit upon its first move… hitting stop should generally resolve the problem, but adding the kinematics.init() statements should avoid the problem.

As for screen display, how did that happen? Were you resizing?

ok, I pushed a new version. Update the firmware (Action->Upgrade Holey Firmware).