Maslow Home Maslow Community Garden Newsletter

How Do I Install and Calibrate? Pi to WebControl to Holey for complete newbs

I have a raspberry pi 3+ up and running and attached to the Arduino. I got it to connect to my wifi and WebControl runs just fine. I’m pretty happy with this so far because this is my first Rpi project and the Malsow is my first Arduino project.

I can’t get WebControl to actually make the Maslow move or make it run my Gcode. Also, I clicked the “upgrade to holey firmware” button and the update wheel has been spinning now for a good 10 minutes or so. From what I understand, the firmware upgrate button will pull the holey calibration firmwarea and then install it and flash the arduino for me right? Is the holey firware a big file with a long download time? How can I tell when it’s finished? Will WC restart automatically?

I found a good post with instructions for getting the Rpi up and working but it’s a bit patchy finding good step-by-step for holey. Can someone point me in the right direction?

I’ll be using these instructions if I can somehow manage to do the holey upgrade all by myself: https://madgrizzle.github.io/WebControl/Actions/Calibration-Setup/holeyCalibration.html

1 Like

Did you set the port in settings -> Maslow settings?

Just to be clear:
image
In the image above, the left green “Connected to 10.6.0.2:5080” indicates your web browser is connected to webcontrol (your IP address will likely be different). The red “Not Connected” indicates that webcontrol is not connected to the arduino. Most of the time this happens, its either that the port is not set in Settings->Maslow Settings .

I did change the port. I was able to get everything to work perfectly with the standard firmware loaded. I imported groundcontrol.ini and everything works exactly as expected. Then I tried to change to holey firmware and it stops working. After the holey firmware process finishes, I can still connect and feed commands but the machine doesn’t respond. I have a feeling I’m not resetting the arduino or some simple step like that. I read that WebControl will flash it for me but then I get an unresponsive arduino/motor conrol. I tried the “test motors/encoders” button, tried uploading some simple gcode and running it, and sending a variety of commands. WebControl reacts as if it is sending the commands but the machine doens’t respond.

are you able to see the terminal screen from which webcontrol runs? During the firmware upgrade process, there will be lots of messages there and that could help us figure out what is going on.

Also, is the top right indicator (re: the image in my previous post above) red with words “Fake Servo On”?

The area on WebMPC that reads out commands and status messages?

Oh, you’re running the docker-based version from the pre-built image?

Yes. Is there a better way?

Maslopi lite I believe.

Yeah… I’ve basically stopped work on that version when I ran into issues with adding new capability. I’ve moved to a new system that uses pyinstaller compiled releases.

How much of a guinea pig are you willing to be? I’ve created something that I think (does for me) creates an image for the rpi using the new release method, but as far as I know, no one has tried it. You would be a perfect candidate to try it out if you are willing.

I created a new topic with instructions on how to use PiBakery to make the image:

100% willing to try it and report back my findings. Thanks for the write-up, I’ll start on it this afternoon.

I have it installed and running near my PC with display and mouse/keyboard going. I see there’s a webcontrol folder here. What do I do next?

In my total newbness, I went into the webcontrol folder and found the executable and ran it. Webcontrol comes up as normal.

So, now, do I use the Rpi in place of the windows tablet I was running before and webcontrol just stands in for ground control? Does this eliminate remote access?

Well, I was hoping it would run automatically from start and you not having to manually start it.

Webcontrol is accessed via a browser and replaces Ground Control. That browser
can be a mobile device like your tablet (which can be completely wireless)

David Lang

1 Like

I had webcontrol working great from my PC to my garage on MalowPi lite but couldn’t get the holey calibration to run. Grizzle is helping me in private message so we should have some progress later today.

Following this too. I have my Maslow set up with a pi and webcontrol. Tested my motors with the stock firmware (worked), then updated to holey and the motors didn’t respond. Webcontrol just have me a fail message when it sent commands to the motors. I went back to stock and they responded just fine and I proceeded to calibrate.

Outside of updating to holey in the actions menu, is there anything else I needed to do?

This is the result of asking this question. I was hoping to add pictures but I may not get around to it now that my maslow is up and running and nearly calibrated using holey. Big thanks to @madgrizzle for the private help and editing the body of the post.

Raspberry Pi and WebControl setup for complete beginners.

Be forewarned: I added a bit of stuff that’s VERY rudimentary such as finding IP addresses. Skip as needed.

1 Like