Maslow Home Maslow Community Garden Newsletter

WebControl Holey Firmware not Updating

I am attempting to “Upgrade Holey Firmware:51.27”, but it is not working. And I did not find any threads where anyone was experiencing this issue.
Steps:
Click Actions
Click “Upgrade Holey Firmware:51.27”
Notification Popup displays “Holey Firmware Update in Progress, Please Wait”, for about 3 seconds
Alert Popup displays “Custom firmware update complete”
Click Close on popup
Click Actions

I would expect Holey Calibration to now be available
However, Holey Calibration is still greyed out.

It seems like the firmware update is not working… the output from Webcontrol is:
Connected on port COM3
PCB v1.3 TLE5206 Detected
Grbl v1.00
ready
position loaded at:
0.00
-0.00
B05
G21

I just switched from GroundControl to Webcontrol, and setup from scratch, so no calibrations have been run yet, just the “Quick Config”, “Set Sprockets & Chains” and manual Z-axis zero set.

I was also unable to find any direction on how to upload this firmware to the Arduino outside of Webcontrol.

did you restart all the software after the update just to make sure?

I did restart both the Arduino and Webcontrol several times, I was going to try a computer restart, but havent done that yet.

computer restart should not be necessary.

Looking back at your original post, flashing the firmware should take more than 3 seconds and Holey calibration should be available immediately. This is what it looked like when I did it.

Yeah, that is the video and series I have been working from- definitely not what I am experiencing. No luck after restart of everything either.
Is there a way to remove firmware from the Arduino…start from zero?

When you flash the firmware, you are starting fresh, but to really be at zero, you have to reset the on-board memory by sending it a command $RST=* once it is flashed

So here is my plan:
Use Arduino IDE to flash the HoleyMaslow to the Arduino:
From https://github.com/madgrizzle/HoleyMaslow
So, Open Arduino IDE, navigate to Sketch; Include Library; Add .ZIP Library, then navigate to $\HoleyMaslow-master\Firmware-master\cnc_ctrl_v1. And then click Upload

If that doesn’t work, then ill try the full reset and then try webcontrol to get Holey on the Arduino.

I am rather new to all of this, so is there anything I need to be aware/cautious of?

actually if you get the holey firmware from here
you can download the installer here

  • unzip the zip file, open the gui program.
  • select ATMEGA2560 as the target device
  • File format is intel hex
  • in the flash section, click the …
  • select the hex file (first link above), the press program

Using the arduino IDE you have to compile and unzip a mess of files and it creates the hex file that gets transferred to your controller. This hex file has already been created, so you just send it. Much faster, much easier. You probably have the hex file on your system in the webcontrol folder if you are running the release version of webcontrol. If you are running a development version, then you don’t have it and that might be why it isn’t working, but hopefully this will get you going faster.

Tried AVRDude and got the below:
image
Found that I should put the “Path” in environment variables (https://www.avrfreaks.net/forum/avrdude-not-recognized-internal-or-external-command)

Now I get this:
image

And it opens a new AVRdude, and sits… clicking upload again, just opens more windows. I was wondering if there should be something different in Setup:
image

So I tried my original thought using Arduino IDE, which successfully loaded the firmware, but then I get this from Webcontrol:
image

And when I try to update to ANY firmware from webcontrol, says its successful in 3 seconds, and nothing actually changes, just like always, for me it seems.

Also tried using Xloader to update using just the .hex file, and that never found the MEGA2560, and hung when I ran it anyways for the COM port the arduino is on.
image

that makes it look like avrdude gui can’t find the avrdude.exe file to actually do the flash.

With respect to webcontrol, does it recognize your mega and connects to it?

If you move the hex file into the correct folder, does the name on the button change?
From this or Holey:51.27

to this:

If the serial port is not set up corrrectly… I have no USB port open on my pc, then it does this:

It completes in 3 seconds and yet was never connected to anything. What port is your arduino connected to?

Also the lights on the controller board will flash rapidly while it programs

Go to the menu Settings -> Maslow settings press the refresh button and select your arduino serial port, then try again.

I do have it successfully connected on COM3. And when I remove the Holey firmware from the webcontrol folder, the GUI does show None as the option- and then when replaced it shows the 51.27 (the version i am trying to update to)

Back to the AVRDude GUI:


use the arduino programmer option.

can you see the console window messages when you press the button to program? Are you running this on windows?

you might consider 51.28 so if you want, you can move to makerverse at some point and it will work with both. They might say you have the wrong version, but they will work.

Thanks, I dont know how I missed arduino in the “Programmer”. Unfortunately, I am getting the same results. When the Path is not setup in environment variables I get the message:
image

Which, when any key is pressed, just terminates.

OR, when the path is set in environment variables, it just pops open new AvrDude GUIs and CMD windows that Say Connecting… (but dont do anything)
image

Does it seem like there is something fundamentally different with the way this arduino is communicating? I am just at a loss as to what is going on.
image

Does it actually work in webcontrol? It is a Mega? Can you open the arduino IDE and see output from the serial monitor when you connect to the mega at 57600 bps?

When using the original Firmware, webcontrol was working. I do see activity from the IDE, the screenshot is of the output from the uploading of the Holey firmware (the one I downloaded from https://github.com/madgrizzle/HoleyMaslow), which does look quite suspect…

That line of garbage is very suspect. The firmware I compiled to get 51.28 with a couple modifications was github/webcontrolcnc/firmware HoleyCalibration branch. Were you running Webcontrol single file or single folder version?

The single folder “directory”.

how short is your cable?
Have you wipee the memory on the arduino? (webcontrol has a button for that) or $RST=* is the command.

The cable is 12’ long.
I tried the reset button on the physical Arduino- and it doesn’t seem like that did anything…
I am not sure how to input the reset from Arduino IDE:
image

And as for webcontrol reset:
image

I did notice something off when looking at where it was trying to do the holey install from:
image
That “Maslow” folder does not exist… so maybe that is why nothing happens? I am not sure where to update the folders webcontrol should be looking in?

Start Webcontrol and use the menu ->Actions:


OR in the arduino IDE, you can open the serial terminal:

make sure you open the correct port

  1. set baud rate to 57600 for the mega
  2. enter the command
  3. click send. it should respond with OK
    if you see lines of garbage, you have the wrong baud rate.

These instructions work with the classic controller (mega). The due uses 38400, but the command will wipe its memory as well, but it will not work with webcontrol… at all.

1 Like