Maslow Home Maslow Community Garden Newsletter

How to start cut after GC pauses for "tool change"?

Unfortunately I cannot say if it worked before as I have only used multiple tools on GroundControl 1.2.7.

I absolutely know it worked at one point because I remember testing it at the time, but that was when I first added it a long long time ago. After adding the feature I didn’t find myself making many things which required tool changes.

I can’t find where in gc/firmware the change occurred, but I suspect that pause () was added due need to manage buffer gcode interaction (without the pause, it would continue to run gcode until buffer was empty).

That fits with my memory as well. I think that the buffer code was added after I last tested it.

Sorry we are starting to mix two problems/issues here. @Allan_Cook could not resume cutting when a tool change is requested when using Fusion 360 generated gcode. It is not about moving Z axis during tool change which is in thread Tool Change Functionality (Question About Ground Control)

So on this issue: I can confirm today that using Fusion 360 gcode tool change the cutting operation can be resumed using the Resume button. I previously WRONGLY stated that my GroundControl version number. It work on V1.2.6.

I will post more info on the second issue in the other thread linked above.

1 Like