Maslow Home Maslow Community Garden Newsletter

How to start cut after GC pauses for "tool change"?

Hi all,
I have loaded my first g code from Fusion 360 and was stopped short by “T1 tool change to tool 1 M6 Tool change please change to Tool1” message in GC. I am simply looking for how to move past this message - I don’t need to add/change the tool i just want to start the cut. Obviously i have been smashing the Play and Pause buttons to no effect. I read elsewhere that once a tool has been entered in GC this message no longer appears (until a tool change is requested). Where do I tell GC that the appropriate tool has been loaded into the router and we can proceed? All other posts on tool changes seem to gloss over this step and I feel like I am missing something super obvious. I have attached a screenshot of the GC messages, my NC file and log if that helps.

MidLowerShelf.nc (838 Bytes) log.txt (795.1 KB)

For more background (and since this is my first post), I have built my frame, calibrated the system and made my first cut (lettering created in Easel) and celebrated appropriately. I am a more or less a complete noob to CNC/CAD/CAM/programming but I have enough life experience to jump in and get started; I have taken the last few days to teach myself Fusion 360 and create my first file. Excited to make some cuts and give back to the community as I gain experience with the machine as the resources on this forum have helped solved my early issues.
Thanks in advance,
Leif

1 Like

Well, in web control I just press the resume button so the maslow can continue cutting, maybe in ground control is the same

That’s what I would expect to work…Hmmmm…Has anyone else run into a bug with the tool change code?

1 Like

anything interesting in the log file?

David Lang

Update - I was able to make the cut using Easel (something is going on with the depth but I will play with it) so it seems like the issue is in the F360 g code. I’ll continue with Easel for now but would definitely like to use F360 end-to-end.

Might as well post a pic since it is my first proper cut!

2 Likes

Isn’t there a Fusion 360 Maslow postprocessor?

Not engendered specifically for Maslow I don’t think but I use the GRBL post code set up .

1 Like

yes there is, I don’t have the link to it handy.

David Lang

Check this thread

1 Like

I have been using it since august, never had a problem with it

1 Like

Your g code looks wrong and uses Codes that are not supported: G17, G28, G54

‘S10000 M3’ is normally the other way round ‘M3 S10000’

Don’t know if Maslow support the format of multi line operations:

G1 X-21.7344
Z-0.0675
X-22.2344
Z-0.13
X-31.7031

Normally this is like:

G1 X0.594 Y-0.4918 Z0.0097
G1 X0.5947 Y-0.4913 Z0.0071
G1 X0.5959 Y-0.4904 Z0.0047
G1 X0.5976 Y-0.4893 Z0.0027

Use the Fusion360 post processor specifically for Maslow. I know this works with tool changes.

1 Like

I believe there is a bug in ground control that prohibits exactly what you are trying to do… read through this if interested:

https://forums.maslowcnc.com/t/tool-change-functionality-question-about-ground-control/11626/15

However, It does not appear you are actually trying to do a tool chain and its likely that Fusion360 just throws one it at the start. The .nc file is just a text file and can be edited in any text editor so just delete the T1 M6 command on line 10.

@tinker, have you done a tool change recently? If so, can you post a file that works because I’m having issues.

1 Like

This one worked for sure (GroundControl 1.2.7) and was generated from Fusion360 using the Maslow post processor. It has an unnecessary tool change at the beginning.
SJ1.nc (258.1 KB)

This one also worked, has multiple necessary tool changes, and I think it was made in Fusion360. Its from the Meticulous Z-axis project files.
MeticulousSled_All.nc (146.2 KB)

When did you last use them?

When you ran SJ1.nc, you said it had an unnecessary tool change at the beginning… so when prompted to change the tool, you just hit resume… correct?

When you ran the meticulous sled file, do you recall what version of ground control/firmware you were using?

Yes, clicking resume worked on both files. Ground Control is version 1.2.7.

The first file was cut about 6 months ago. The second one about 2 months ago.

Were you able to adjust the z-axis using the z-axis popup while you changed the tools?

No, Z-axis adjustment did not work. Was only able to resume cutting.

crud… I’m fairly sure z-axis adjustments worked at one time… just trying to figure out when they did so we can figure out why it stopped.