Maslow Home Maslow Community Garden Newsletter

I am just so damn frustrated it's not funny anymore

I tried to get onto my Maslow today. It’s bad enough I can’t use the ground control because Windows 10 has some issues with some drivers not being recognized. Now am trying to access the web control and I am getting a localhost5000 error message. I am at a loss… I have went as far as to totally disable my firewall just to test it and I still get the same damn message. I am just overwhelmed now…
Jeff Smith

can you post a screenshot of the error message. Should read “localhost:5000” (note the colon).

sorry to hear it is so frustrating.

Ok i uninstalled everything and reinstalled everything and I managed to get webcontrol to work again. Now I downloaded the Holey Firmware, but the Holey Calibration is greyed out. I am clicking on everything and nothing seems to allow the computer to talk to the Maslow.

I received a successful flash message yesterday, but the flash had never started. I forget the specifics, but try to flash it again. it should take more than 5 seconds to flash.

I keep receiving successful messages over and over again. But it still stays greyed out.

Now it is giving me a scrollong message about the chain length is too great

I am getting an alarm about my left chain length being too long. I don’t know how to fix it. I haven’t been able to calibrate it yet.

Screenshots of the messages would help us greatly in figuring it out.

It’s helpful to look at the terminal window that comes up when you run it to see what’s going on in the background, particularly if there’s an error message or something. Not everything can be caught and presented out to the browser. For example, if there’s something that causes webcontrol, or part of webcontrol, to crash, there’s no way for webcontrol to notify the user since its crashed… You can only see that from the terminal window.

I just want to offer encouragement. Struggling through these problems/issues is painful at the time but don’t give up. I think you will find in the long run these issues will end up bringing confidence and understanding. Good luck!

1 Like

I had tried updating to holey firmware from windows 10 single directory, it would go really fast said successful but still grayed out. This was from web control 0.929 single directory. Ended up using 0.929 single file and that took longer
but worked. We have newer releases now, but you may want to try a single file release.

Edit: another time it wouldn’t work because One Drive was doing something with WC 0.932 single directory. I moved WC and ran it from my downloads folder to keep one drives claws off it. Worked from there. Only figured this out by looking at the terminal window as madgrizzle mentioned.

Grrrr Microsoft, grrr one drive, I disabled that crap almost immediately.

I messed with it for the entire day. Got frustrated and couldn’t make heads or tails. I wanted to just scream… I couldn’t for the life of me figure out how the machine kept telling me that the Left chain was too long and was out of the … It was a scrolling banner on the right side of the screen right above the play, pause, stop buttons. I couldn’t click on anything to make it stop. Also I never input anything it just appeared like this once I finally got the Holey Firmware to work. I downloaded the firmware restarted the computer and the greyed section was no longer greyed out, but this new issue was there. FML…
JEFF
P.s…Anyone interested in a never been used Maslow CNC , with a brand new Ridgid R22… Router? I am over this

Have you tried resetting the chains so it will know how long they are? Lift the chains off the sprockets, do the 90 degree set, then put them on at the extended marks you made when you first extended them.

If/when you get the scrolling error banner again, press stop to clear.

I had the same issue with the left chain a while back when I first assembled it. If you haven’t calibrated yet, it just has garbage data in it. Like Orob says it won’t go away until you initialize the chain lengths to zero. Make sure you have gone through the preliminary steps.

From my notes to myself, review your own settings!

Start with help->Maslow getting started

  1. Set ComPort

  2. Set Distance to Extend Chains (Chains should not be on initially, bare sprockets)

If using a 12-foot beam, change to 2032, else 10 foot 1651mm (values should be divisible by 6.35), this is just to extend the chains enough to attach the sled.

  1. Quick Configure (my choices, yours may differ)

Kinematics Kit

Ring
Rotational Radius Enter value in mm only
138.4

Chain Around Sprocket

Bottom

Distance Between Motors

3577.6

Height of Motors Above Workspace

719

  1. Set Sprockets Vertical

This is the step where you initialize chain lengths and that message should go away. This is all pre-calibration.

Be very careful you don’t get a chain wrap in the extend chain step!!! Review the procedure. Make sure to mark your top sprocket and chain link with paint/marker if you need to reset one day.

After this you calibrate. Good luck, any questions just reply back.

Edit: there is also a spot somewhere to tell it how much total chain you have. If you have a 10ft beam default is fine, don’t worry about it, I have a 12ft and changed it, but else it shouldn’t effect you (didn’t seem to make any difference with me anyway). Can’t remember where it is located. Just an FYI.

1 Like

I will have to try that at a later date it’s raining here today.

Ok I will try that tomorrow or another day when it’s not raining.
Thank you for the information