Is there a way to set the com port to stay constant

Since I up graded my laptop to windows 10. Ground control doesn’t remember the com port. Every time I boot the lap top up I have to set the com port to com3.

Last week it lost the com port during a g code program. And that resulted in major problems and waste of material?

I upgraded to 1.2 today and it seems to be worse
I had to select the com port 3 times during calibration.

Thank you for your help in advance

do you have two identical ardunio’s plugged into the windows laptop?

Windows assign the COM port according VID, PID and serial number. So with the same device plug in, it should always get same COM port assignment. However, two devices with same VID, PID and serial number might be treated as same device. When you plug in them in sequence, Windows can assign different COM port for them. However, after rebooting the Windows with the two USB devices attached, the COM port assignment should be decided by Windows for the two USB devices with same VID, PID and serial number.


Hmmm I’ve never heard of the COM port not being constant before. Are you saying that the number changes and you have to select a new one each time you connect, or that Ground Control is not staying connected?

1 Like

I’m not sure that it is the problem in this case but Windows can assign a comport form 1 - 254. Each time the device can be assigned a new number, it depends on how the device identifies it’s self and the windows registry. If one or both are “less” then 100% then things could go wonky. I’ve seen the same device install 253 times using all the comports.

Also if the device is duplicated but never completed set up you now have 2 of the same product fighting with it’s self for the same space.

Most of the time it goes smoothly. When it doesn’t there is a reason. It normally means something is “boogered.” You could remove all for the com devices and start over, if the issue stems from a hardware issue you can loose access to your USB port until the hardware is repaired or replaced so I normally don’t have users do the delete everything and reboot these days. With laptops that only have 1 port if you loose the hub up stream in the laptop it’s likely you may not be able to use external devices to troubleshoot anymore.

I hope this information is helpful.

Thank you

It’s always com3, when I click on the shortcut icon to start ground control. It starts up, but before the Adriano/MaslowCNC will move I have to go into the Actions Menu and select Ports and choose Com3

Does that make sense?

Try this -

Right click on whatever you use to start Ground Control and try run as administrator. Go in set The port, connect. Exit Repeat - see if it remembers

Thank you

1 Like

when I click on ground ground control it a window pops up and ask if i would like this program to make changes…I click yes…and it just disappears…

Put ground control on your desktop or somewhere else in your user account. Running it from C: will cause issues on windows 10.

1 Like

My installs run on a large number of machines from c:\maslow\ Insert folder name here. I wrote an installer that puts it in this location. Not one problem so far - Ok this is a problem but running form c:\ should not be an issue unless it is joined to a domain with group policy that makes it a problem or there is another issue with the pc. I’m going for the latter. Vanilla Win 10 will prompt you for Admin access to write to C: you accept and move on.

There may be another simple answer based on something we are not seeing. However this is an instance where I would consider wiping it and reinstalling windows or moving to Linix on a stick.

Thank you

The problem with this approach and the standalone version of ground control is that if you have a different version of python with a different package load-out installed on the machine, then it will see that one instead of the embedded version that is included in the portable app. Moving the ground control app to userspace is a troubleshooting step that eliminates that possibility.

1 Like

The reason I removed it from there is users with long names were hitting file limitations from windows internal file structure names.

I don’t think it’s that the user has multiple versions of Python but Multiple versions of Windows. I don’t have too many upgraded computers. I also suspect a corrupted registry because this is an upgrade.

Just a guess based on my experiences.

I appreciate your input as it is an angle I had not looked at.

Thank you

My mason files are located on C drive.

I have tried running it from a short cut, from the directory itself, as admin. However it will. It remember com3 under ports

apologies if this has been said before (I haven’t been following this, but it’s
been going on way too long)

There is no way to guarantee that windows will use the same port for the same
USB device.

port names are dynamically assigned as (USB) devices get plugged in. If you
unplug a device while some software still has it open, the OS cannot remove the
port name, and so when you plug it in again, it will get a different port.

In addition, if you plug in a different device, it can get the port number that
you want the maslow to get.

There are some tricks that you can try to pull to detect serial numbers and
other such things to try and get consistant naming, but they are very fragile
and break under fairly common conditions.

David Lang

1 Like