I could sure use a call

Hi everyone,
newby here stuck on setting up software - firmware.
Not a computer wiz. Have used Mac’s but got a PC because groundcontrol wouldn’t open.
Could use some help… talk through what I’m doing wrong. Thanks


What kit do you have (where did you get it, what controller and sled setup)? Have you looked at the manual in the wiki or seen any of the setup videos linked from the manual? Maybe check that out. there is a wiki entry on the basics of arduino IDE software to get your firmware installed. If you still have questions/concerns please be as specific as you can. There are several here who want to help.

Thanks for replying Orob,
I’m away from the machine right now but it’s the $600 kit I got it on Amazon and my problem is it’s saying that it can’t find the USB connection and I’m not sure what else to do because I’ve tried plugging it into every USB port.
I bought a mini PC that’s windows 10.

Have you tried installing the Arduino IDE? It could be a drivers issue

Yes I have the Aduino and groundcontrol installed.
It keeps saying - lost connection with USB.
And I need to change USB ports, but I’ve tried all of them and nothing changes.

on available ports, what is COM3?

Windows numbers serial ports (our usb connection is a serial port emulated over USB), the real thing often has jumpers to set the port number, for USB ports it seems to be rather random and can change if you plug into a different USB connector on your computer. Windows will also change them on a whim just to be annoying, what’s com3 one day will become com something else on another.

The short answer it’s the port number that Windows picked today. If you don’t have any other devices plugged in then it’s most likely your Maslow. Connect to it and see

Thanks mooselake, I have tried them all… no difference.
If I can’t get this solved soon I will pack it back up an send it back.

@newby , you might want to delete your phone number. These forums are public and you’ll end up with a lot of spam calls. Better to solicit some phone help publicly and maybe share number in a private message.

1 Like

What a great community… Absolutely no help from the forum or from Maker Made (of crap).
Thanks for a waste of money and time. I am returning this worthless shit and getting my money back, and will leave so much negative remarks about customer service I hope the business folds. A big middle finger for all the help!

A phone call to a stranger didn’t fit my schedule when you asked. I have at times phoned people to help out but it doesn’t always work in my situation. I’m sorry you had a bad experience.

We are all volunteers. This is a free forum with contributions from users just like you. Your beef is with Makermade who sold you the kit. This forum is a community of users and we sometimes get treated like customer service for the kit sellers. I’m sorry to hear your experience sucked. Systems like these are not for everyone. All the best to you.


Sad, I was actually going to offer to call him tomorrow when I had time.


One thing that would help is more clearly differentiating between vendor support and the open source project as a whole. We seem to take the brunt of abuse when things that are vendor specific go south.

where is @makermade in all this? Were they even aware that this guy had a problem? from the sounds of things he tried to reach out to them but they ignored him so he came here thinking we were their support?

1 Like

6 support tickets to Maker Made

Not to make you rehash your experience but did they respond to some of them? any of them?

It looks like your first problem was trying to connect to the Arduino controller. were you eventually able to do that?

1 Like

I called him today. We got everything set up and going with webcontrol.


Good job!!!

1 Like

Great work @TimS! @newby, welcome aboard!


This is a good place to start too. Plenty of people who can help him here now.

Do you have some specs for his system for future reference?

It’s a Makermade classic with a mega and 1.2ish board. Same version as mine.

10ft beam with bungie, chain off bottom. Ridgid router in the classic setup with the router base mounted to the sled and the z axis motor on the router adjust screw. Ring attachment.

Some setup problems and the user is a Mac guy with limited experience with windows. We corrected everything and got the holey calibration marks cut.

Currently he is measuring the holes. To input the measurements. Told him he may have to reaccomplish the Calibration if the error is too high.

1 Like