Left Motor test fails

Sorry for the delay! I was out in the woods. We can send you a new motor right away, but let’s be 100% sure that’s the right thing to send. Do you see the same behavior if you move the other end of the cables? (to test the cables and the controller board)

Welcome back, Bar! Hope you had a great time away.

1 Like

It seems to be the motor. I changed the cables between motors and still the left one keeps failing.

What is rather strange is that on my first try today it did not fail. I then went on to calibrate and when I started to position the sprocket it began acting weird on 1° increments (turning into the other direction, being completely off.) After this the test failed. I restarted everything and now i kept failing. I then passed on to change the cables with the same result

1 Like

My guess is that there is some sort of faulty connection in the encoder which is giving the firmware faulty information about if the motor is moving or not. If you shoot and email with your address to info@maslowcnc.com we’ll send you a new one right away

I am having the same issue that Dany had with his left motor. I thought it was a bad connection because it worked for a while, but just recently it stopped working again and is giving me ‘sled not keeping up’ errors, and the motor test fails on the left motor direction 1. It does not fail every time, but it fails at least half the time, and works fine the other half the time. I switched the cables from left and right motors to see if it could be that, and the issue was still the same. I sent an email to the info@maslowcnc.com at the end of last week. Is there anything you can do for me? Or should I just pay for a new motor myself.

Do you think it could be the gear? That would come with some ‘grinding’ noise.

I have not heard any type of grinding noise, when it does move, it moves smoothly, just about every other time I get the error telling me that the sled is not keeping up.
I will check the gearbox to make sure it is not stripped.
Is there anything else I should check before I buy a new motor?
Thanks for your input

I opened up the motor and the gears look just fine, no grinding or anything like that.

1 Like

Fishing in the dark here, but might be worth a look. Open the black cap on the motor and check if the ‘encoder disk’ is tight glued to the shaft of the motor.

Alright, I will look into that,

So I opened it up, the black disk spins with the bronze disk in unison.
I am not quite sure what I am looking for…

So, new problem. It is not the motor. I flipped the motors and I am having the same issue I had originally, still with the left motor (which was the right motor) in the CCW direction only. I posted on this issue a while back and I seemed to have resolved it after unplugging all the connections and re-connecting them, but the issue has made its way back to the board. The issue was originally in the left motor going CCW, I switched both the cable and the motor, and the same issue is on the left side with the right cable and motor. The motor only moves about 3/4 of a full 360* when I spin it in the CCW direction.

Motors switched and cables also and it stays left?

Yes, the problem is only on the left side (Doesn’t matter which motor) going CCW usually.

The left motor shield chip is the first to die. Changing motors and cables is kind of pointing to that direction, although i hope i am wrong.

Well, when I first got my machine, I had the same problem right of the bat. I unplugged everything, turned everything off, then plugged everything back in and it seemed to fix the issue temporarily. I cut out a bunch of stuff that turned out great, and now it is having the same issue again. I turned everything off again to see if it will help with the issue. the turning issue seems to be temporarily fixed again, but I wont be sure until I finish calibrating.

The ‘wipe EEPROM and rename/delete GC.ini’ seems then to be the approach if i was in this situation.
Some ‘b-commands’ and a tail on the log could perhaps give some insight.

What is the GC.ini?

A file with some of the GroundControl settings, actual name groundcontrol.ini
It’s found in the root of your user folder, like c:/user/{your-user-name}

Ok, where would that be located in the Ground Control folder? Under settings? or somewhere else?

:point_up_2: on win$

on linux /home/{user-name}/