Maslow Home Maslow Community Garden Newsletter

Connection timed out during calibration

calibration
#1

Hi I’m hoping someone can help me.

So I have built everything for my Maslow cnc and have begun the calibration process. I get all the way to the end and try to perform the last stage which is the test cuts that once done are measured.
Problem is every time I try to run this step it moves to the first position starts to plunge the router then freezes.

The last few lines of the code read:

G17
Command G17 unsupported and ignored
G91
M3
G0 X-965.2 Y+368.3
G1 Z-7 F500
Connection timed out

Tried re installing Arduino, firmware and ground control. Also tried running through several different ports 3-7 so far.

I can move it around manually all day and it never times out. Also disabled the USB time out in power options that I found is a similar thread.

Any help appreciated

0 Likes

#2

the typical cause of this is that your computer is invoking some power saving
mode from being idle and powers down the USB port. Try disabling all power
savings on the computer.

David Lang

0 Likes

#3

Hi David,
I have disabled every possible power saving setting there is, still no luck.

0 Likes

#4

Has anyone else got any ideas?

0 Likes

#5

Take a look at this thread to ensure you didn’t miss anything

0 Likes

#6

Power management goes down to the BIOS of the computer. Check there also.
“Noise” in the power lines is a very common source of lost connections. Test with keeping everything else OFF and simulate cuts without the bit in the material and router and vac and all other machines off.

0 Likes

#7

Awesome thanks guys, right off the bat I have all my cables running lovely and neat all next to each other along my frame :weary: looks like I have to change my layout and maybe try a shielded cable with ferrites.
Will give it a go and let you know how I get on.

2 Likes

#8

I forgot the ‘Welcome to the Forum’.:pensive:
Please let us know how is going, as every input is of value.

Kind regards, Gero.

1 Like

#9

Yup, I ran into this. Was cutting the working desk and eventually the Z cable got on top of the router power cable. Bit didn’t get pulled to traverse height and messed up the cut.
I couldn’t get the Z axis to work until I unplugged everything and got those cable so they wouldn’t come in contact (or even near) each other

1 Like

#10

This is off-topic, sorry, but i noticed once a Z-down since using a spindle. Without GC showing a lowering.
Is a DC 0-100V more ‘noisy’ then AC? I remember 1 post with the same observation (also with spindle) and a post with you mentioning that we don’t have data. I’ll receive a Hantek 6022BE with luck tomorrow, but my osci experience is way back. That thing claims to run on linux and i found software for it. What would be the frequency range to set to discover?

0 Likes

#11

Soooooo cable moved… and for now success!!! Cable noise, who knew?

Thanks for the pointers from everyone, fingers crossed it doesn’t return.

Cheers

1 Like

#12

Nightmare, just timed out again mid job… aaarrrghhh

New usb cable it is and fingers crossed that solves it as it was much better just by moving the position of the original one.

Will report back tomorrow, fingers crossed

1 Like

#13

Guys/Gals - People. Always ask for a wide shot of the setup! You’er going to see cable problems. Once you see the problem you can advise what to look for.

Normal issues:

Separate the PC and the router power source, especially if running a vacuum too.

Don’t cross cables

Ray, if they ask if your a god say Yes! ( don’t cross the streams )

We now return you to your regular broadcast

These are not the droids your looking for , move along, move along.

Really thought visuals help everyone.

Thank you

1 Like

#14

Ok so I’m losing my patience now. New cable bought and tested (one with ferrites and shielding) removed any crossed wires and proximity to power lines… still connection timed out faults…

I’m completely lost…

Has anyone got any more ideas? Com port settings? Anything???

0 Likes

#15

More info:

  • is it a constants timing it happens or random?
  • does it happen with everything off, just moving the sled around?
  • do you have a different pc to test?

Worst case:https://www.youtube.com/watch?v=hMRFSuYll1w&t=305s

0 Likes

#16

I can move the machine around manually all day long and it never times out. Only ever happens when running an automated job

0 Likes

#17

So it’s the router or the vacuum creating the noise for the connection to drop (put 1 or both on a different circuit). Clip-on ferrites might help, but have not tested it.
I ordered a USB-oscilloscope, because i believe noise is slowly moving my Z down. Will try to measure.

0 Likes

#18

What about a g-code just moving the sled around?
Take a stop-watch and measure the time till it drops.

0 Likes

#19

Did you check the BIOS?

  • turn off internet connection (worth a try sopping ‘ET calling home’)
0 Likes

#20

Can you send a picture of your setup including the routing of the cables? Show us how everything is plugged in.

Have you tried more than one computer?

Do you have a shorter USB AB cable around from a printer?

Try running a Airjob - remove the bit. leave the router and vacuum off. Do you still get a disconnect?

Thank you

1 Like