Lost Connection Middle of Cut

A deep dive into the log might add information, but it sounds like one of the encoders wasn’t reporting movement. The motor would continue to run, but the gcodes wouldn’t advance. A loose plug could be the culprit, I’ve had that happen on the z motor.

I’m assuming I lost usb connection due to radio static and ground control just didnt report an error.

Earlier in the project I lost connection and the motors ran away on the same path they were on when connection was lost but it only went about 5 inches before ground control reported an error and the motors stopped.

I moved power away from the usb cable, used a shorter cable and i have not had that issue since.

2 Likes

I had the same lost connection issue and bought a 4’ usb with ferrite noise reducers on each end and that solved my problem as well. I would suggest that as a swap for anyone, its really cheap insurance to not ruin a cut over a comms drop out.

3 Likes

Well it just happened to me in my maiden voyage. About one minute in it said it lost connection. I couldn’t do anything (or didn’t know what to do). Now ground control thinks my “defined home” for that cut is where it lost connection (which is way off). Do I really have to re-calibrate? Why would a lost connection throw that off that bad? I would think the “return to center” location is almost hard programmed into ground control once calibration is done and nothing can destroy it.

Only the ‘calibrate chains’ part. The lost connection would cause this if the USB port sent to sleep, killing off power to the Mega board. The sled position is saved a couple seconds after movement stops. but if the power is lost that can’t happen.

Just the chain calibration is needed. I always do the automatic one because at the end of the automatic my sprockets are slightly off 12. I’m afraid the manual way will be slightly off the cuts that have already been done.

The main thing that helped me was to move the sheild power off of the power strip that has the router and shopvac. Also, disable any power management settings. If you are still having problems, get a shorter usb cable, add ferrites, dont run power along usb, or find a shorter sheilded usb cable.

1 Like

Thank you both for your replies. See comments below.

Are you referring to “Set Chain Lengths - Automatic?” I just did the full calibration but skipped everything but sprocket tooth at 12 o’clock and let it measure out each side. Is this what Set Chain Lengths - Automatic does?

I can’t image USB going to sleep after only two minutes in. I read about this a while back and disabled every power setting I could find. Power was never killed to the Mega board.

I care less about where the sled is in a cut than I do where the center of my Maslow is. With the center of the Maslow being retained, I can then restart the cut. With my center getting screwed up, the temporary home for the cut got screwed up and there was no hope.

Shield power and small USB powered fan are on one power strip, vacuum and router are on a different outlet (and soon to be different breaker). Disabled all power settings I could find. Shorter cable wont work for me due to my setup. I just bought a USB with ferrites on both sides. I also moved the USB cable away from the power cord for the motor shield. They ran in parallel for about a foot, now they are slightly farther apart. Hopefully this solves it.

Hard to believe it can be as simple as turning on a drill (I think Bar said that) to loose a connection. This has be worried since so many things could cause this. Hopefully the ferrites fix this.

Yes, it’s a link to the same two-step procedure, without having to do the ‘skipping’ :blush:.

The USB cable with ferrites will be a good thing.
Other things that can cause the ‘lost connection’ include contention with some other program over the USB port or a connector not fully seated.

What I did:
Ran Set Chain Lengths - Automatic. Mark the link that is on the top tooth(take note of the position of this tooth) after the chains have been fed to a know position.
Next time I need to recalibrate chain length, I run set chain lengths - automatic, Define 12, extend left and right(without the chains on) put marked chain on top tooth

In the forums, I read that people move a tooth to the 12 position put the marked chain link on the tooth and then click Set chain length -Manual. However, I am not too sure how accurate this is. Whenever I do a automatic chain length there is never a tooth at exactly 12 when the know fed length is done.

The ‘set chain length - Manual ‘ is best done along with the 12 o’clock step from the ‘…Automatic’ sequence. Then the Manual one just removes the need for watching and managing the chains while they extend. I’m an impatient guy :grinning_face_with_smiling_eyes:

When you feed the chain on automatic chain calibration does any of your teeth end back up at 12?
Mine is about 5 or 10 degrees off of 12, that’s why I don’t see how the manual one would put it back on the same cut

*Edit: I’m not sure that i am explaining this right
After automatic chain calibration:
image

Manual calibration: Place marked chain link on 12 position tooth
image

If we are using the manual chain calibration, isn’t that going to be off since the last cuts were actually 5 degrees past 12?

It was written on the assumption that the sprocket would end up with a tooth at
12 (that’s why the odd 1650 figure)

if you don’t have the teeth in the same orientation when you re-position the
marked link, you will be off.

1 Like

Throwing another option for “lost connection” out there, though, it is probably a long shot. Assuming a Windows machine is being used.

Buried deep in the dungeons of the Advanced Power Plan Settings in Windows there is a setting for “USB selective suspend”… probably be a best practice to disable that… just in case Windows thinks you’re done with that USB port and decides to disable it.

image

More on what this setting actually does.
https://docs.microsoft.com/en-us/windows-hardware/drivers/usbcon/usb-selective-suspend

1 Like

For sure3, that would be a ‘gotcha’ just lurking in wait!

For the same cut I lost the connection about 3 minutes in, 5 minutes in then again at like 30 seconds in. Out of desperation I switched to an older 6’ USB cable (no ferrites) and it ran through the whole cut. Coincidence? Time will tell. Seems like getting a shorter/different USB cable works for now.

I ordered a 20’ double ferrite USB cable (couldn’t find a shorter one with a double ferrite and didn’t know if manually installing ferrites to a random cable had the same effect). I’ll let ya know how it works.

1 Like

Ferrite on USB is good idea. Power settings a must. Moving USB away from shop vac power cord fixed issue for me few months ago. Today I lost USB twice in an hour. Realized I recently installed new Thingiverse Maslow case that has holes for heat sinks to stick out. Today is 93 in Atlanta and running Maslow in a hot shop. Pointed a fan towards everything and issue went away so I could finish cut :wink: Will have to add a small fan to this case in future. Jealous of air conditioned Maslow.

3 Likes

Cool! How much do your counter weights weigh? @dlang was looking for that information. In the near future there will be a option for a Beefier Shield with better cooling options. Thank you for the information.

I too have had this USB connection error even cutting the sled. I did overcome it and made a “hopefully” helpful video of the steps I did. Here it is on YouTube, Jon

3 Likes

Thank you for sharing this! Full of valuable information.

Edit (better late then never): Welcome Maslovian!

1 Like