M4 Stuck on calibration step. Fitness too low

Hello - I can’t get past the calibration step. I’m setup horizontal using flush knurled anchors and a 15/32 sheet of plywood as spoil board on a concrete garage floor. I haven’t set the anchors yet but they don’t move (or I can’t feel them moving when touching during calibration). After the first few attempts I found that my arms weren’t pivoting around the router freely and half of my arm screws had backed out. The manual says don’t over tighten and those were the only loose fasteners I found when taking it apart last night. I re-tightened them and ensured the nylon locks were engaged. This morning went back to calibration and the fitness numbers are basically the same as before, still not passing. Not sure what I’m missing at this point. I watched both the most recent calibration videos, I have read the guide and have it open in front of me when going through the steps. I made a video and I’m attaching the logs from the run on video. Hope it’s obvious to someone what I’m doing/did wrong.

Running firmware .76 in the video (and replaced the index html and maslow yml + re entered my config info)

Computing… This may take several minutesFitness: 0.4977614 in 100
Fitness: 0.4977614 in 200
Fitness: 0.4977614 in 300
Fitness: 0.4977614 in 400
Fitness: 0.4977614 in 500
Fitness: 0.4977614 in 600
Fitness: 0.4977614 in 700
Fitness: 0.4977614 in 800
Fitness: 0.4977614 in 900
Fitness: 0.4977614 in 1000


Maslow-serial(6).log (15.8 KB)


That’s really good enough. I would just change the value in settings to 0.4 and it should pass no problem.

I’m going to change the default on that in this weeks update

Cool - I just tried the calc mentioned in another post. I don’t really know how to interpret but it looks good to me? :laughing:

1 Like

Yeah, you should be good to use those numbers :slight_smile:

You should take some really good measurements of your anchor locations too; if you use approximate numbers or defaults it really messes with the controller!

This is how mine will be set up too!

Another theory: If your anchor pins have a little bit of wiggle room when they are inserted in their holes, that might create enough “flex” to reduce the accuracy of the calibration.

@bar, what if the program reported the calculated anchor points even if the calibration did not reach the threshold? That way the user could use those points if they decide the calibration is good enough. Maybe put a “Do not use” at the start of each line to avoid mistakes.

1 Like

I did measure multiple times, before and after the hammer drill. If I’m off its by 1-2mm max. I also had a friend spot check it for me after a few failed calibration attempts (same numbers reported).

It did pass after I set the threshold too .400 as @bar suggested. I’m just waiting for it to cool off (100F where I live today and then garage is basically an oven until dark). I have some engraving gcode ready and loaded for later tonight! Will post a pic of results.


I rented a Bosch hammer drill and bit from Home Depot, I was really surprised how round and accurate it drilled. The anchors I got have a slight knurling to them and fit very firmly. I have the set tool and although I was planing to set them permanently I’m really not sure it’s worth bothering (its really nice to just push in the eye bolts with the belts all attached). I think you can see how they work in the first few mins of the video II posted above.

1 Like

1/4 60 degree V Groove bit

1 Like

Hi Bar,

around 19:18 in the @Charlienofun video you can see the M4 moving in to position, and then taking the slack out for measuring. But on the last instance the TR gets slack, so I think there has not been a good measurement there. This happens a few times. Is this how it should behave?

Please correct me if I’m wrong, I’m trying to understand what I see:

  • the M4 moves to a new position
  • all belts (or just 2?) get slack
  • one by one the belts are drawn in until a certain motor current is reached (or 2 belts do not move at all, and the other two take slack one by one), this is measuring
  • the M4 moves to the next position, etc.

If this is how the measuring in the calibration works, there is room for faults: if the last belt that is drawn in and tensioned is giving an other belt (that already has been measured) slack. In the video it looks like that is happening. This behaviour is more likely to happen away from the center where the angles of two adjacent belts are wider, which could explain the difference in calibration results between the smaller and larger grids.

Could you (or another great coder like @ronlawrence3 or @md8n or @dlang ) explain how the measuring of a point is coded?

Thanks in advance,


In regards to slack belts, I used to have them… but now they have gone away. Here is what worked for me.

Originally I just whipped up a quick frame dimension that matched my space conveniently. But it turns out that once I got closer to the Red/White areas on @dlang frame checker, my belts wouldn’t stay tight. I’m in the vertical orientation, and it was when the Maslow was getting close to “inline” with the anchors. I suspect the Frame/Anchors need to be quite outside the work area. So I adjusted my anchors outwards, and recalibrated, and the first waypoints were a tiny bit slack, but then they all tightened up after each calibration round. In reference to the video that @Charlienofun posted… his anchors looked like mine when I got slack belts…depending on the grid size of course, but the anchors only look 8ft apart (in relation to the plywood visually). So getting waypoints “inline” with the anchors isn’t ideal (I don’t think)

1 Like

Yes exactly I made it 10x8 just like the wood frame in the docs.

1 Like

Yes! I have seen this behavior too. It’s happening exactly the way you describe.

I think that the solution is that we need to change up the order that we pull the belts tight in potentially.

Bar wrote:

I think that the solution is that we need to change up the order that we pull the belts tight in potentially.

just go around a 2nd time tightening all the belts. that will cover the cases
where the sled moves.

David Lang

1 Like

Yes, that is probably easiest.
And if the second time round the retraction current is lower, only the slack belt will move?