Maslow Home Maslow Community Garden Newsletter

Malsow crashed? Chain length message unresettable

I finally installed and started to run an orginal kickstarter Maslow. I followed the calibration procedure and everything looked great. I started some test patterns and a dialog box went missing in-between cuts.

I shut Ground Control down (v1.26), opened the G-code file and tried to start again.

I received a notification “Unable to find valid machine position for chain lengths xxx, xxx. please set the chains to a known length. Action - set chain lengths.”

I tried to re-run the automatic calibration procedure and almost destroyed one of my pulley systems, which started a motor overload warning. I power cycled the maslow and restarted the program because the motors wouldn’t turn happen after the alarm.

I ran through the automatic chain calibration procedure again with no problems, marked the chains, got everything connected, tried to run the pattern again. I received the “Unable to find valid machine position for chain lengths xxx, xxx. please set the chains to a known length. Action - set chain lengths.” again

I cycled power and restarted the program. Same thing.

I found this post “How To: Manually Reset Chains, the Easy Way” and followed the steps several different times. Same message again.

I deleted the grouncontrol.ini file and restarted Ground Control and power cycled the Malsow. Now I get the chain error almost immediately after starting gorund control.

I opened Arduino and resent the firmware, restarted Ground Control and power cycled the Malsow. Same error. I notice that I am getting the following errors

  • G21 Connection Timed Out. It is possible that the serial port selected is not the one used by the maslow’s Arduino, or that the firmware is not loaded on the Arduino.

*PCB V1.00 Detected

  • error: EEPROM fail. Using default settings. Grbl v1.00.

I tried resetting the eeprom through ground control. Then I tried Reset settings to defaults in Ground control.

These are the messages I get on ground control startup.
Ready
B05
Ground Control 1.26
Firmware Version 1.26
G21

I noticed that Arduino recommended updating my board to 1.82, so I did that and then uploaded the Maslow firmware again.

Same result.

I gave up on ground control and went to webcontrol.

Everything looks good when I open it and start setting it up. All green on the top and a green alarm cleared menu.

None of the buttons in the set sprocket menu work. Testing the encoders gave no results.

I went back to ground control and tried testing the motors and everything failed and I got the same message again.

I’ve run out of ideas. Any help would be appreciated.

It’s possible that fake servo mode got turned on (it should show up in the
logs), go to the gcode menu and then the send gcode item and enter
B99 off
to make sure that fake servo mode is off. Then see if you can test the motors
and get them to spin

Since you deleted your groundcontrol.ini file, you will need to re-do the
calibration. Since you are using webcontrol (which version??) you may want to
look at trying the holey calibration instead of the triangular calibraion.

David Lang

I did get everything back working again by downgrading the arduino back to 1.81. I re-calibrated everything using standard ground control The tolerances were within 2mm, but the center-point was slightly better the first time.

And then everything went downhill again when I tried webcontrol.

Thanks to your advice, I was able to figure out that Web control did, in fact, turn on the fake servo mode. That disabled both web control and ground control. I was able to get control of the Maslow from both control panels using your command in web control, but the Maslow lost its place again in both control programs.

I tried putting my marked chain lengths at top dead center on the motors and manually, but ground control won’t let me manually reset the center position and it looks like I have to recalibrate again. It doesn’t seem to be as catastrophic, but it looks like trying to use web control screwed up ground control.

It seems that I must choose on or the other. Should I stick with Ground control or web control?

Ground control seemed to work fine except for a couple of glitches during the calibration procedure. (At one point, the left motor would only jog in one direction, regardless of what button I pushed. Later on, the controls for both motors on the screen only turned the right motor.) I was able to overcome those by escaping the program and re-entering.

Web control doesn’t seem to be able to find the center during the chain calibration like ground control does. I have a 12’ beam and a larger than usual gap between the motors and work area, but I didn’t change the feed length in the ground control advanced settings. I let the chain extend to the default length in ground control on both sides, which wasn’t long enough to connect my sled. Then I selected extend to center and connected the sled, which was perfectly in the center the first time, and a about 10mm off center the second time. Webcontrol doesn’t seem to have a compatible button.

When I try to Set Sprockets & reset chains in webcontrol, the only option I have is to “manually Set the chains to 1650mm”, which isn’t the middle of my workspace. I’m also confused because I changed the advanced setting “Extend Chain Distance” to the recommended length for a 12’ beam (It was 22something in another forum post), but that doesn’t seem to have stuck through the repeated restarts. Even still, that wouldn’t be the real center of my workspace like the calculated ground control center. I can’t seem to find that value in any of the settings.

When I was trying to recreate this in Ground control, the message list reported that ground control was incompatible with the Maslow, which had a number of 55, or something. I went back to arduino and reloaded the firmware, and the message went away, but now it looks like I have to recalibrate from scratch again.

Is web control the future, or is ground control going to get the holey calibration eventually. That’s really the only reason I want to use web control. I find ground control to be easier to use and understand.

In the end… Ground control or Web Control. If Web control, how do I set the center?

when you switched to webcontol, did you import your groundcontrol.ini or did you
recalibrate (and if you recalibrated, did you use standard or holey calibration)

what firmware version are you using? webcontrol gives you two choices (normal or
holey)

in the settings there is an ability to change the standard chain extension, by
default this is 1650mm, make it a nice multiple of 6,35mm (I would set it to a
length that puts the sled near the middle, somewhere around 2444.75 may be right
depending on the top beam height, you can get the value from the spreadsheet at


)

we think that holey calibration is better, but we do not yet have enough testing
of it to merge it as the new default. In an ideal world, we will eventually have
firmware that supports both, but that takes programming expertise that we are
short of.

It is looking like the long run is going to be webcontrol in any case, kivy is
making it harder and harder to support groundcontrol

David Lang

correction, center would be about 2070.1mm, the prior numer I gave would be
bottom center.

David Lang

I imported the groundcontrol.ini. I tried to perform a Holey Calibration, but Web Control doesn’t seem to recognize that I have the stock z-axis motor installed, even though I’ve selected it in the options. It kept asking me to raise and lower the bit, which I can’t do with the motor attached, so I gave up and went back to Ground Control.

Thanks for the explanation that the firmware changes with the Holey Configuration. Now I understand why I can’t switch back and forth between the two.

If Web control is the future, I’m willing to be a tester. I have zero experience with cnc, but I do some beta testing on the side.

Do you want me to create a new forum topic, or is there a bug tracker like project locker that you use, or do you want me to do both? I’ve found int he past that side issues keep creeping up and make a single testing forum-style topic messy and hard to follow.

BTW, I meant to start all this by thanking everyone working on this project for their time and expertise. I’ve been lurking for some time now and was really excited when everything worked great before I ran into the first issue.

Does this mean you don’t have a ring or linkage kit or any other setup for triangulating the chains? This was the first huge improvement made after the kickstarter, which may be the root of your issues. I’m not sure we have seen a kit with the original hardware used in quite a while so things might be unclear in the calibration process for those.

I do have a ring kit. I was referring to the the controller.

Thanks for checking.

1 Like

Fantastic! The ring kit made a huge difference.

I wouldn’t worry too much about the center point as a mark of if things are calibrated. The chains are set to a known length, not the center of the work space to make it easier for people who have marked which link that is.

I would say that web control is the future, although I don’t personally have a lot of experience with it.

I started from scratch and only ran Web control.

I entered all the values in all the settings as per my measurements.

I also added these values in the spreadsheet

Name Value
motorSep 146.08
motorHt 41.58
workWidth 96.00
workHeight 48.00
sledWeight 24.00

I ran the triangular calibration.

The calculated values were 1063.20 for motor height, 146.6 for rotation radius, Chain Sag 20.13202.
I accepted the results and the “Chain position not found” immediately appeared and couldn’t be cleared. I tried resetting the chain length and no change.

However, I started looking through the settings and the distance between motors changed to 3601.2. There is no way the distance between motors is that small. I measured 3719.6 and ground control measured 3709.57 and 3711.57 on two different calculations.

The motor offset height changed from 1056.3 (from a previous calculation. I measured 1069mm) to 468.4. I do not know where that number came from because the calibration reported 1063.2. I think that this was my problem from the very beginning. My motors are higher than normal and the calibration seems to drop my motor height in half.

I also notice that the calibration indicated a rotational radius of 146.6. but the actual rotational radius was measured to be 146.6. Shouldn’t that setting have changed when I accepted the results?

I also noticed that the spreadsheet calculated the center to be 98.16", but the actual center was closer to 94.2126.

Center 0.00 0.00 98.16 98.16 41.92 41.92 17.96 17.96

I went to the manual control and played with the numbers until I found the center of the workspace, then I set the chain extender distance to that value, then manually set the chains to put the sled in the center. Everything seemed to work better and the triangular calibration cut the second time dropped by 35mm.

Would the maslow be more accurate if I put all the values as found and then just changed the numbers that the triangular calibration reported?

I just noticed that the chain sag didn’t change after I accepted the values.

make sure that the chain lengths are a multiple of 6.35 so that you can get back
to this point with the sprockets at 12 o’clock (even if this means you shift the
position a bit)

David Lang