Maslow Home Maslow Community Garden

Updated to Firmware 1.25, Lost Chain Length

groundcontrol
firmware
calibration

#1

I updated to Firmware V1.25, and now Ground Control is giving me, “Unable to find valid machine position for chain lengths…” error. Is there a way to recover my settings, or do I have to recalibrate? :frowning:


#2

You don’t have to recalibrate, but you do need to set your sprockets to 12 o’clock and then extend the chains in order to reattach the sled. If you run through the calibration process, you can just skip until you get to where you set the sprockets… do that step and the one for adjusting chains and afterwards, you can quit the calibration process.


#3

Thank you, @madgrizzle!


#4

Or press Actions then Set Chain Length Automatic which does the same thing


#5

Thanks @bar… I thought that was in there but I couldn’t find it in source code on my phone.


#6

It’s really screwed up. Set the chain lengths, but now it continually moves the sled down, no matter what I do.


#7

You probably have something wrong I either you ground control.ini file or stored in firmware. You may want to try wiping the eeprom in the controller…


#8

I had the same thing happen upgrading to 1.24. Had to do the full calibration again. Backup groundcontrol.ini would not work. Entering manually values did not work.

Also sled position error tolerance (advanced setting) was set to 2 which caused ‘sled not keeping up’ error.


#9

Ugh. Thanks for the tip.


#10

I erased the eeprom, and tried to recalibrate. When I tried to calibrate the z-axis, the sled would move down every time I clicked “raise” or “lower”. Did the firmware update brick my board?

I haven’t tried rolling back to 1.24, or reinstalling 1.25, is that worth trying? Any other suggestions?

I tried powering it off and back on (IT solution to everything).


#11

Hi - try the following.

Upload the blink sketch. Then go back to 1.22. GC/FW Attempt recalibrating.

Let us know what happens.

Thank you


#12

Thanks, @Bee, I’ll give it a try.


#13

OK, I uploaded the blink sketch to the board, and it worked. I made double sure it was working by changing the blink values and saw the LED change blinking speed.

I uploaded FW v1.22 and used GC v1.22 and was able to move the sled in all axes.


#14

Great. I tried going back to v1.24 after v1.22 was working, and now nothing works. I tried going back to v1.22 and that doesn’t work now either. The blink sketch still works. :frowning:


#15

Did you wipe the EEprom? When going back to 1.22?

Thank you


#16

Finally! I cleared the eeprom, reloaded 1.22, cleared the eeprom a couple more times. Went through the calibration process from the beginning. When it came time to do the z-axis calibration, it started moving on the y-axis again. But, after fooling with turning automatic z-axis button on and off, and going back and forth between screens, it finally started turning the z-axis when I clicked “raise” and “lower”. Then I successfully performed the test cuts, and finished the calibration.

Now, should I stay on V1.22 or upgrade? If I upgrade, is there some way to keep the settings from getting messed up again?


#17

I’d sit tight on 1.22 for now. Until after the Holidays. Just my opinion. A working Maslow is better then not. I suggested 1.22 because ti is before the “Sled Keeping up problems”

Thank you


#18

I guess this should be the general recommendation for the moment.
There are also strange things happening when changing (for example the feedrate) that does not get picked and leaves the arduino not moving until the 3rd restart and or disconnection of everything.


#19

Thank you, @Bee, I’ll take that recommendation.