Maslow 4 error 152 and many calbration fails

Mostly I Keep getting error 152. But this thing is very hard to connect to! Some Mac browsers won’t open the FluidNC upload button. Sometimes the captive portal that opens won’t load. Then you can’t get it to load in a regular browser either. Btw ip is …2 not …1. Is it always? When I do get the Maslow.yaml file uploaded and get through all the games with the belts ( 5-10 try’s normally to retract fully) then the calibration fails after 70 to 90 points. I tried reducing the grid to 5x7 but that might be when the yaml file stopped working. One time it said current exceed limit. Another time it said possibly stuck but wasn’t. Another time it seems it over taxed the browsers and that had a spinning beach ball.

I’m at a loss as to how to narrow down the
problems. Can we please just measure the frame carefully and type in numbers somewhere? Can we please get a troubleshooting workflow. Can we please not have to go back to 0 on each fail.

1 Like

Are you connecting directly to the “Maslow” wifi network or connecting to your home wifi network?

This error message means that it can’t read the maslow.yaml file with the machine configuration. Let’s start by getting that sorted out.

Thanks in advance! I was connecting directly so I was connecting to the Maslow wifi which then loads the captive portal browser window. On an old Mac that won’t fully load. On a current Mac it does but the fluidnc upload button doesn’t work. So I’ve been sort of trying to use one then the other.

What’s weird is with yaml file got in there and it got to calibration sometimes.

1 Like

I’ve had the one that pops up automatically behave strangely, but if I close that and open a regular browser window there will be a popup asking me to access it there which seems to be more reliable.

If you have a wifi network in your shop it is worth connecting to that because that’s even easier I think

Ok that’s good. Connecting to the existing wifi worked and Maslow.local worked. So this current safari browser seems to operate the FluidNC upload and download (after agreeing to accept files)

So this is the yaml file that I just downloaded that was giving the 152 error

1 Like

What is the name of that file?

It’s a little weird because I hit download a few times so it is last one and now called maslow-3.yaml. I guess in theory that is called maslow.yaml on the machine.

I think that might be a potential culprit for the error 152 issue. The machine will only recognize the .yaml file if the name is exactly maslow.yaml

I think it must be something else?? It is named correctly, I think. Could there be some sort of Mac version of a text file that is a problem. Or did one of my changes to dimensions, amperage and grid do something?

1 Like

Looks good to me. If it’s some weird line ending in the file or something like that it would be new to me, but great to learn. We really need to get rid of editing the file directly, it creates way to many opportunities for something to go wrong.

What happens if you restart by unplugging it and plugging it back in?

If you download the latest maslow.yaml file here do you see the same thing? Release v0.65 · BarbourSmith/FluidNC · GitHub

I just tried that one and it worked for me.

Can you send the one that isn’t working? I’ll take a look and see if I can get it to work for me

1 Like

Ok so connecting with shop wifi has made that visitent and I got the yaml uploaded and working
Made it to calibration

It moved across the 90 points and now nothing.

Last line in the log says [MSG: INFO: Point: 89 ….

What is supposed to happen?

Did I kill it by clicking out side the setup window? What are the guide lines I need to stay in to get through this? Can we please have some more comprehensive instructions.

1 Like

You shouldn’t be able to kill it that way, at least not in the latest version. That was one of the big fixes last week.

It sounds like you are doing things exactly right. If it’s not working that’s a software issue not a you issue.

Until everything is working I really really recommend doing a small say 2x2 grid near the center of the sheet so that the whole process only takes a few minutes rather than an hour so it’s easier to debug fast.

What do you see printed in the console at the end of the process?

Thanks for the help. Here is a photo of the end of the console scroll. Also do I have to take the belts of and do a retract/extend every time before a new calibration attempt. Assuming yes but didn’t know.

1 Like

I am also not 100% sure, but I always hit the estop button too to power cycle everything to be 100% sure that I’m starting fresh

This is almost what I would expect :confused:

There is one last step which is that I would expect it to say “Calibration Complete” at the end and then start the computation. Looking at the code I’m not seeing how it wouldn’t say that.

On the other console screen it has one more line:

Just that and nothing else.

I wonder if the wifi is inconsistent or some connection problem?

1 Like

Maybe, but you aren’t the first person to run into this issue so I don’t think it’s you. I think that there is a bug, I’m just not sure what it is.

One of the big changes in v0.65 was:

A more robust data hand-off system between the calibration process and the computer computing the results

When the calibration process finishes taking measurements that data is sent to the computer for processing. This system relied on the computer being ready to receive the data and would fail if the computer had gone to sleep or the browser window was closed.

Now the machine will confirm that the hand-off has been a success and will keep re-sending the data until it gets confirmation. This means that the calculation will resume automatically when the computer is woken up or the browser tab is re-opened.

Specifically I was hoping to prevent exactly this. In testing I was able to start the calibration process…close the browser entirely. Wait for it to finish, and then open the browser again and it would reconnect and finish.

You have the version 0.65 firmware.bin and index.html file right? (I know that there is no easy way to check, that’s been added to this week’s release 0.66 (edit: coming Wednesday)

Yeah I have 0.65 from Monday/tuesday. What else can I tell you… Yellow encoder cable lights come on for a few seconds intermittently and the blue led is flashing a code which seems to be 192 168 3 5 which is probably ok. My wifi router is

Also has this image when you click the work area.

1 Like

That all sounds normal :confused:

Can we try a 2x2 calibration grid with big offsets so that everything is right in the center of the sheet? That way we can get an answer really quickly and see if the same thing happens