Maslow4 cannot extend belts

Hi all! Super stoked to have received my maslow4 kit and built it over the weekend. Having trouble running the calibration routine per the user guide though, I’m able to retract all of the belts, but now 3 of the 4 belts fully retracted and are in a preloaded state. When I try to extend the belts, only the belt that isn’t fully retracted reacts to me pulling on it. I have a feeling this has something to do with the other belts already being preloaded, and thus not sensing any additional load being applied. Any thoughts on how to fix this?

1 Like

Yes, I know what you are talking about. I am going to make a video walk through of the calibration process today because I think that a lot of folks are stuck on different parts of it.

Are you using the “rock the belt end” technique to get it started? It gives you a lot of leverage to start the extending process.

You do have to use a decent amount of force to get the belts to extend from a fully retracted position. Using the rocking technique as Bar indicated, is a great way to do that.

I’m having a similar issue as you described where one of my belts will not fully retract. I’m wondering if that belt is longer than the others and can’t wind up any further without hitting the internal arm gears.

What happens if you click Retract All again? That might be an issue with it thinking that its fully retracted already. There is a software defined current threshold that it uses to detect when it’s retracted all the way and maybe I just set it a little too low.

It should really be a setting that can be changed…I’ll make it adjustable in the next firmware version.

I tried rocking it back and forth, but stopped as it felt like it might break if I applied more load that I was. I’ll try again tonight with more load and report back. How does the system tell we are applying load? Is it measuring a small rotation at the encoder due to a stretch in the belt, or can it sense the load through the gearbox into the motor.

As far as my one belt that does not fully retract, it seems like the diameter of the belt being wound is touching off on one of the motor housings and senses that contact as if the motor is fully retracted. I tried to fully extend that belt to fix the winding but it stopped before being fully unwound, which I haven’t spent much time troubleshooting yet

1 Like

I’m uploading a video walk through of the calibration process that shows how I would expect it to work. Take a look when you have a chance and let me know if it seems similar or different?

it measures movement of the pinch rollers, there should be enough give on the
belt to let that move a little bit even when fully retracted. but if there is
too much tension, there will be a problem (until Bar makes a firmware mod
allowing for manual motor movement)

David Lang

Yeah I’d imagine being able to manually move the motor would solve this problem in the meantime. Is there any way to do this even if it’s not supported in the UI? Thanks for the prompt help on this guys! The community around Maslow is very real

Check out the step at 4:15 in this video and let me know if that helps:

I’ve never found the belt to be so tightly wound that I wasn’t able to start extending it that way.

Maybe once they fully retract unwind them about 5 mm? Just enough to put a little bit of slack in the spool.

I have not looked at the video yet. I will do that shortly. I will relay my tale Of calibration.

I retracted the belts, made a nice pretty package that I could carry to the garage.
Extended all the belts until they stopped, and attached them to my anchors. At this point the sled was slightly below center.
Clicked retract belts and the sled moved to approximately center of my board.
Click calibrate, and the fun began! The bottom belts slackened quite a bit. The top belts unspooled, and did not quit unspooling until they re-spooled backwards and quit when they ran out of belt. So now the sled is in a lofty perch. The top two belts are drawn tight, and the bottom two belts are slack. After a moment of what the hell I removed the bottom anchors and clicked retract belts. The bottom, two belts started to retract as expected. The top two belts started to unspool. The sled came down from its lofty perch, and kept on going until the belt started to spool back up the correct way at which point I stopped it. Removed the top two anchors and then clicked retract belts again and the top two belts finished retracting until I had the nice pretty package again.

I will go watch the video

It actually used to work this way, but it was leading to the belt getting sucked into the drive gears occasionally. I’m sure that there is some happy medium way to do it though.

Give the video a watch. After setting it up on the frame you want to move right to “Calibrate”. Retract the belts will make the machine think that all the belts are fully retracted again.

I guess all is well that ends well :grinning: Had me scared there in the middle of the story :grimacing: