Calibration: Can't get Maslow to cut test pattern

I have gone through all the steps in the calibration but when I get to cutting the test pattern Maslow just sits there in the center and does not move. I know stuff works cuz I went through calibrations up to this point.

Sometimes, when I click quit and get the message that says if you quit, all is lost and the zombie apocalypse will start, then is starts to move.

Why is is doing this. How do I get this to finish calibration?
Advice would be appreciated. Thank you
Bill

2 Likes

Here are some thoughts that might help.
Is the power cable plugged into the Maslow board (not the Arduino)? It provides power for the motors, but nothing else. The green LED next to that socket should be on if there is power for the motor. The green LED on the opposite corner indicated that the Arduino has power from the USB cable.

Is GC able to communicate with the Arduino? When it first starts, it prints “connected on port …”. The calibration sequence doesn’t check for the presence of a connection before starting the steps.

If the Arduino is connected but the machine is uncalibrated, you might (should?) get a message when GC starts “Unable to find valid machine position for chain lengths…” does that come up? Not a problem, just another checkpoint on the way.

When GC first starts, can you make the motors move using the on-screen arrows? You might want to un-rig the chains from the motors for that if there is a danger that they could over-wrap or pull tight.

[Edit] - if there is no z-axis motor connected but the setting expects a z-axis motor, there is a several-second wait each time GC sends a movement command to that motor. It feels to the user like nothing is happening (GC shows ‘G0 Zxxx’ in the terminal window though)

Let us know if any of this helps, or if there is more help needed. :+1:t2::grin:

1 Like

We should actually change the popup to read that :grin:

Can you tell me a little bit more about your frame/sled combo (chains on top or on the sides? linkage kit? ring?)

It sounds to me like everything is working properly (Because like you said, you got that far)…I can’t think of any reason that it would stop just there, but I am thinking on it!

1 Like

Is z-axis installed and set that way in the settings?
How are the chains mounted to the sled?
Can you upload a copy of the groundcontrol.ini (home folder) and the log.txt Gc folder)?

2 Likes

I have the z axis kit but I do not have the coupler yet so I left the z-axis turned off. At least for now. I am attaching a picture of my setup. Chains are on the bottom. I have the latest ring with the V bearings. I have the Z-axis plugged into the board but if it is turned off in GC, would that matter?

Hope this helps answer your questions. Advice appreciated.
Bill

20180324_121455%20(640x360)

3 Likes

Oh excellent! You are the first person calibrating with the new setup.

What happens if you just click the arrows to move the sled around? Does it move normally?

1 Like

Fantastic…I’m the guinea pig!

Yes, when I use the arrows, it moves manually, and even in the correct direction!

3 Likes

Excellent! We’re off to a good start :+1: :+1:

Let’s try to run a test gcode file to make sure that works

mtn.nc (4.8 KB)

Here’s a pretty simple file. If you open it and press the green run button in GC, what happens? I would do it without a router bit in just to test, unless you want to end up with a cutout of some mountains :grin:

Also, please forgive me if this is a dumb question, but sometimes it’s easy to miss the simple things.

Did you press the “Cut Test Pattern” button in the cut test pattern step?

OK…stand by. I have another issue that popped up. I tried the test pattern again for the calibration after unplugging the cable for the z-axis. Again, it just sat there when I click to run test pattern but when I “quit” then the sled started to move but the chain started wrapping around the sprocket. See picture. Gotta figure out why it is doing this first I guess. 20180324_124406%20(640x360)

Darn! That is annoying! I haven’t seen that happen with the weight of the sled attached before.

It happens when the chain is new and stiff so it wants to stay on the sprocket more. Working the chain by hand will fix that, or it will just go away on its own with time. To unwrap it, I would disconnect the sled to take the weight off and then unwrap it by hand.

Ohhhhh I think I have a theory about what is going on…I will test it on my end right now

Yes…and after that, no movement.

Ok I think I know what’s going on! It’s totally a bug on my end. What’s happening is that a popup is opening to ask you to adjust the z-axis depth but it’s being hidden.

I will make a fix for it right now.

What computer OS are you using?

1 Like

I am using Windows 7

1 Like

Now I just need to get this chain to quit wrapping around the sprocket!

1 Like

Looks like a little WD40 loosened up the chain.

2 Likes

Good thinking!

It might be worth adding a note to the instructions that the chain might be stiff when it’s brand new and a little lubrication is a good idea.

I’ve got a fix for the bug added to the next version of the Ground Control. I’m compiling a new version right now for you to test.

2 Likes

Here’s a link to an early version of Ground Control version v1.10 which will be officially coming out on Wednesday.

It should fix the issue you were seeing and make a couple other tweaks to the calibration process.

I would love any feedback you have on how to make it better.

https://drive.google.com/drive/folders/1rx3hR1ddTKJygTvqTQ9YyCi9Z8BxLYpK?usp=sharing

2 Likes

OK…I’ll try it now and let you know.

2 Likes