Maslow Home Maslow Community Garden Newsletter

Calibration how to

I finally finished my frame, now I tried calibrating the Maslow. The resulting tests are not accurate at all. I did the tests with a pencil on paper taped to frame, which works surprisingly well.
The top horizontal line (see picture) looks like a sad smiley (bowing downwards on the sides) , not straight at all. What might I be doing wrong and how can I improve it?

The calibration step where the chains are automatically extended to hang the slide seems to fail, the chains are not extended enough to hang the slide. I then manually extend both chains further out.

Hmmm, I think you are right that the issue is that the calibration step which extends the chains is the issue. That step should extend the chains long enough to put the sled near the center. Is your frame much larger than the stock design by any chance?

Yes, it’s higher than the standard frame, the width is nearly the same

The calibration feeds out 1650mm of chain from each side, which puts the sled a few inches below center on the standard frame. Where does GroundControl show its cursor after you’ve calibrated?
Here’s something you could try. Do the automatic chain calibration, then instead of hanging the sled, click the Home button. Does more chain feed out to move the cursor down to the center? Might need to watch out near the Stop button in case it tries to use more chain than is available :slight_smile:. Does the sled hang in the center of the workarea then?

4 Likes

Thanks for the suggestion. Calibrating twice more did the trick, the lines are straight now!


I’m having another issue with the Z-axis, the Triton MOF001 router is far from ideal to connect. Before asking for help, I’ll do some more tests.

2 Likes

Hello, I am new to this forum, and writing from France. Congratulations for the forum, it is very helpful! Unfortunately I have been trying the calibration processes, both automatical and manual, without success (temporary sled so far).
My frame is larger than the standard one, because I had a nice 30mm thick, 3100 x 1530mm sheet of plywood. It is:
Distance between motors: 3666mm
Work Area width: 3100mm
Work area height: 1530mm
Motor Offset height: 345mm
Distance between sled mounting points: 211mm
vertical distance sled mounts to cutter: 140mm

When the chains finish being automatically extended, they are too short, I can’t reach the sled, something like 400mm or so is missing.
Arduino 1.8.5, Maslow Firmware Version 0.94, ground control 0.94

Would someone be able to help me? Thanks!

Welcome @Stephen!

I understand and I think what you are seeing is a bug. The issue is that the calibration process will extend the chains a fixed amount which is near the center on most machines.

Your motors are much further apart so this is not enough chain.

I have filed a bug for the issue here: https://github.com/MaslowCNC/Firmware/issues/323

And I will make sure it is fixed by version 0.95 on Wednesday. I will let you know has soon as I have a fix to test.

A workaround you could try is to use the return to center button in the action pane. That might extend the chains enough for you to hook up the sled. You probably need to buy some additional chain, though. That is a wonderfully large work area you’ve got!

1 Like

Thanks! I’ll be waiting for the new version and in the meantime I’ll try the return to center suggestion. Yes I need additional chain, I have to start looking for some…

1 Like

I forgot to tell that I also get the following message :
Notification
Unable to find valid machine position for chain length 1648.93, 1649.80. please calibrate chain lengths.

That message comes because the chain calibration has not completed. Run the chain calibration, in your case don’t hook up the sled yet, do the Action/ReturnToCenter, then attach the sled and click the Home button.
Having done this, you should be able to quit GroundControl and come back and not have that message pop up.
I get that message often when I’ve been poking around in the automatic calibration screens. As a way to get the chain calibration over more quickly in future, I took a moment when the chains stopped feeding out during chain calibration to paint the link of chain at the top of eack sprocket. Now when that pop up occurs, I can unhook the sled, put those painted links at the top of the sprockets, click Action/Advanced/ManualChainCalibration, then ReturnToCenter and finally Home to get back right with the world. If you need to be precisely in the same 0,0 point, you can use the sprocket rotation buttons in the Action/AutomaticChainCalibration to get a tooth pointing up and then set zero, then quit that dialog and go do the manual/painted link trick. Much of my work completes in one session, so I don’t worry if 0,0 is offset a mm or so after I re-cal the chains in another session. Too, I try to avoid visiting the full automatic calibration screens because the dragons there so often scramble my chain calibration. :smile:

2 Likes

This means that with the machine dimensions that the firmware knows, it cannot
figure out any way for these chain lengths to produce a valid position.

If your motors are further apart than stock, this means that the chains won’t
reach the sled, exactly what you are experiencing.

not quite. It means that the chain lengths are not valid. completing the
calibration step is supposed to make the lengths valid, but if you have a
non-standard machine, this isn’t the case.

1 Like

The chain calibration pays out a known amount of chain, a constant. It is independent of the machine geometry.
The subsequent separate step of ‘return to center’ moves the sled to the center of the workarea as calculated from the values measured and/or entered by the user in the calibration process. It uses a series of gcode commands to move to X0.0 Y0.0 with the Z axis above the workarea if Z is automated.
Home, which is a setting controlled by the user, both with the on-screen buttons and with the Settings dialog where he can choose the default location that GroundControl uses for Home when it starts up.

1 Like

the fact that the calibration step pays out a fixed amount no matter what the machine geometry is a bug, a limitation from the original design.

What good is it to pay out so much chain that it’s dragging on the floor, or so little chain that you can’t hook the sled to it?

Nothing in the calibration calculations require a specific amount of chain, they require that they know how much chain there is, but would have no problem with a larger amount.

So the system should pay out just enough chain to be able to hook up to the sled, and then allow the user to move the sled down to the center (or near the center if you always lengthen the chains by 1/4" steps so that you always have a sprocket pointing straight up so you can paint a link and re-hang the chains)

At that point, the system knows how much chain it takes to get to the center and can do the rest of the calibration from there.

New try today. Manual calibration OK, then return to center only moved a few centimeters, not enough. I clicked several times and it moved the same way each time. Then I was able to set home and the movements seemed OK. I closed GC and opened it again. Now impossible to have the motors move, nothing happens whereas all is connected.

There is a file named groundcontrol.ini, can you zip it and attach it to a post? Maybe looking at the settings there will give a clue.

I installed the latest firware and GC (0.95 vs 0.94) before seeing your message, still nothing happens.
Should that groundcontrol.ini file be in the “GroundControl-Windows.Portable.v0.95” folder? I can’t find it there

a few minutes later, it works again. Let’s go back to calibration process.
Still the same problem as earlier, the chains remain too short after “return to center”

Would that be too short to attach the sled, or too short for much movement after they are attached? Have you added some chain onto the ends of the stock chains? I think that will be necessary on the larger frame.