Maslow Home Maslow Community Garden Newsletter

Maslow cnc only moves straight downward

My Maslow will only move straight downward on the work area. When I start to calibrate the Z-axis instead of moving the Z-axis it drops the whole sled down. Is it possibly in my arduino coding?

@Martinb623 welcome to the forum! That is odd issue; sorry this isn’t working correctly for you. Let’s try something before diving in. Sometimes ground control and the arduino can get “out of sync” and sometimes resetting it can clear things up:
Unplug the arduino USB and power to the shield, close ground control, plug power back in to the shield and the arduino USB and then reopen ground control.

Ok I did that and now when ever I try to move it, it’s saying sled is not keeping up with expected position and has halted

I went back in and tried re-calibrating and when I click to move to center it lowers the left chain only and I have to manually stop it

It sounds like some data might have gotten corrupted? I’ve had odd issues like this before (I’m using v1.25 + holey calibration) and I hate to say it but you might have to wipe the eeprom and start over.

1 Like

Ok I’ll give that a try tomorrow after I get home from work. I’ve been reading a thread that sounds exactly like my problem. The very first time I tried calibrating it let me calibrate the z-axis but now when you click to move the z a is up or down it just lowers the sled or it says it can’t find the position for the chain length Thanks. I appreciate all the help so far

I agree with @WoodCutter4 this sounds like a funky calibration setting to me. If the machine thinks the motors are really far apart or something you can get strange behavior like that

Apparently I didn’t listen in second grade during the time we learned the multiplication tables. I had the distance from the work space to the motors set at 4600 mm. The distance between the motors is only 3000.77. Thanks you both for the help. I’ll finish the calibration and cutting the permanent sled tomorrow evening. Thanks again. You guys are awesome

4 Likes