Maslow Home Maslow Community Garden Newsletter

Maslow Looses USB connection and all data of location etc


#1

This is the 3rd time this has happened…I have have all power saving setting turned off, screen saver off, laptop is plugged in to a power cord with power.

During a 4 part sign cut it looses connection, i tried to reconnect the port and it wouldn’t…closed ground control and restarted…the location was about 18inches from current sled location and Ground Control thought the bit was 0.2 above work surface, but in reality it was in the last cut part about -0.18 below surface.

Is there a quick way to re calibrate with out going threw all the steps?

Any suggestions on what I am doing wrong?

Thank you,
James


Z axis stops reporting position on main ground control screen v1.20
#2

Do this include the BIOS power saving stettings? There could be something hidden there.


#3

Someone else mentioned they thought electrical interference could cause connection issues. But I have no experience with that.

But might be good to make sure your USB isn’t running beside power cables.


#4

if all else fails, get a mouse jiggler (software or hardware) to fool the system
into thinking that you are moving the mouse around and it shouldn’t go to sleep

David Lang


#5

I checked the bios, don’t see anything that would trigger the power savings


#6

Yes, you should only need to do Actions -> Set Chain Lengths Automatic, you do not need to do the rest of the calibration process.

I think electrical interference is the most likely culprit. We found that using Hannah’s laptop, the connection would drop immediately if a particular power drill was used in the same area.


#7

Using a shorter usb cable and putting the router and shopvac on another strip fixed it for me.


#8

This continuously was happening to me and it had to do with my windows power settings putting my “usb” devices to sleep.

Make sure you change tou power settings to high performance and never let anything sleep on a time basis. Your monitor can turn off but thats about it.


#9

which version of windows is that?


#10

I took the interference idea and did a test. If I enable my WiFi, MaslowCNC stand a great chance of loosing USB connection.

So far I haven’t lost connection since disabling the WiFi on the laptop while running ground control


#11

Windows 7 but i think all of them have performance settings that can be tweaked.

I think the router’s speed makes a difference as well. Certain speeds have given me that error and stopped after i changed the speed slightly.


#12

Electrical interference is defiantly the issue. I had the exact same problem.

#1 - The stock USB cable is not great. Replace it with one that have a ferrite core on the ends. Note that this needs to be a decent cable, if its a clip over core its completely useless, USB cables are braided and a core over the braid is a marketing joke. If the core is a molded part of the cable you are good. Please not that ANY USB cable longer than 2M is good practice to have a ferrite choke built in. Future Maslow motherboards should follow EMC testing recommendations such as this HERE.

#2 - Shop Vac’s are INSANELY noisy (electrically). My shop vac trips my arc fault breakers in my basements 100% of the time. That means its leaking enough EMI the breaker thinks its arcing and can start a fire. The only way to combat this is to put it on a separate circuit in your garage. Also a thicker gauge electrical cord helps.

#3 - Keep the USB cable away from the router power cable. As long as they are not taped together for a length this is completely negated by #1

#4 - If its a laptop then power savings settings can cause USB stutter, how to disable this is completely dependent on the make, model and OS. The mouse wiggler is a legit solution.


#13

I had the same problem and did not even get my sled made due to USB signal loss. I took these steps to fix and have had approx 20-30 hours of run time and have not had any errors since. Made a video on this and will soon do a follow up. Jon
https://www.youtube.com/watch?v=hMRFSuYll1w&list=UUXOmukuulDBaPhCKZgfh4kQ&index=4&t=0s


#14

I have same issues, 2 attempts at sled failed. So I beef up the USB and other cables and put the electronics in a cage.
Is there a way of resuming the cut run from where it left off, about half way through cutting the sled out?