Motors won't turn

I bought a maker made metal kit in march of 2019 and just finished getting it assembled. I could not get the Arduino to be seen by the computer, so I bought a new Arduino and shield combo from maker made. It still didn’t work so I tried a new USB cable and that worked. I downloaded ground control and I can’t get the motors to move during the calibration step. Before I buy new cables and motors for potentially no reason, I wanted to ask you all first. If I have to buy new motors and cables I will, but I would like to try other stuff first before I blindly buy parts.

Is the power supply for the Arduino plugged into the motor driver board? If it is plugged into the Arduino the motors won’t move.


It is plugged into the shield. Thank you for the reply:) is there a troubleshooting guide?

I saw the start of a troubleshooting guide somewhere, can’t find it atm, getting ready for work.
I’m using WebControl, more friendly user interface in my opinion. GC should have a test motors button, I tried it once, the motors should move a bit in each direction, does that work?



I went through the troubleshooting and nothing.

Have the motors ever worked? Is the shield properly plugged in to the Arduino, meaning pins aren’t bent or offset? Any messages at all? Are the ic chips intact, or are the cooling fins still in place?

What step are you at in calibration?

In WebControl you measure the distance between the motors ( you do not use the extend chain feature in ground control, sometimes the chains can wrap and ruin things). Then set the sprockets vertical. What corresponding point are you at in ground control?

Can you send a picture of your shield powered up, to show lights lit up. I assume you only have ground control running, not the Arduino ide. If nobody else responds , perhaps try web control rather than ground control. I’m not terribly experienced, and will be calibrating this coming week, but otherwise my sled moves.

Edit, link to web control.

Also I assume you never turned on fake servo mode. Easy in webcontrol, not so much in GC.

1 Like

I used my wife’s computer to start calibration and the motors turned for hers. My laptop sees the arduino, so I don’t know why my computer won’t work. I tried finding the ftdi drivers to update to but I could not . I will try webcontrol on my laptop.


I tried webcontrol and my laptop won’t connect either. It says trying to connect to controller on com4, and then repeats it again. What can I download to get it to work? I have reinstalled Arduino ide a few times from within the store and outside of it. I am running windows 10.

it sounds like a serial port driver. Can you use the arduino programming toolrm or the arduino serial port viewer to verify the serial port can be opened?

I don’t have a serial port on the machine I use unless I plug in a USB dev,ice, so one does not show up hence the orange error message at the bottom. What options do you have? If you set up the port to be the correct com port and 57600 baud, will it connect and do you see messages scrolling when it is plugged in and on?

I like realterm for serial testing because it will list all the available ports:

Webcontrol will show the repeating connection attempt until the board connects. You must select the proper port for it to work. Since the serial port is USB, it is a virtual serial port and may show up as a different numbered com port on a different machine or even at a different plug location on the same machine depending on the driver that is being used and what the device is.

I do see the scrolling with my laptop when I follow your instructions.

I switched to using a USB-C to USB-B cable and it works :slight_smile: At least testing the motors. Thank you for everyone for their help!