Maslow Home Maslow Community Garden Newsletter

New install motors wont move - SOLVED

I have a new install and I cant get the motors to move at all. I’ve pulled the motors and have set up on my test bench. Any help would be much appreciated. I’ve spent quite a few hours searching the forum for any solutions.

Arduino Mega 2560

Motors not moving at all after new install

Loaded the current ver. of Arduino IDE 1.8.15 on PC w/ Win 10
Loaded the current ver. of Maslow Firmware 1.26 on PC w/ Win 10
Opened IDE and successfully sent to Arduino via USB

Installed Webcontrol on PC w/ Win 10
Tried Quick Connect
Tried Upload Stock Firmware 1.26
Tried to execute any motor control “Alarm: Sled Not Keeping Up”
No motor movement at all with any control

Shield
Green light on shield steady ON ***( Should be 2 LED’s ON, one LED for USB power and another LED for Aux power brick power)
Shield connected good (no bent pins)
Motor connectors seated good on shield and to motors

Arduino
Green light steady ON
TX or RCV (cant tell which one under sheild) orange light flashing fast
“L” orange light steady ON

This happened to me and I had to move my powersource to a power strip that had a trip protector. This may help. worth a shot to try

the most common causeof this is the power supply being plugged into the arduino
rather than the motor controller

David Lang

1 Like

Thanks for the feedback. I do have the power supply that came with the Maslow connected to the shield board (motor driver). Solid green led

What shield do you have and where did you get v1.26 (from webcontrol)?

Is webcontrol in fake servo mode? (check upper right for red / green connection / disconnection status.

A couple basic questions because I’ve done these ones before: Did you turn off arduino IDE and close the serial port monitor to free the port and then select the port in webcontrol to establish communication with the mega? It should show the port name in the upper right. If not, go to settings, maslow settings, and choose the correct com port in windows and try again.

1 Like

Thanks for all the help.

It looks like the problem was power supply not providing the 12vdc to the motor controller. I didnt notice there should have been another steady green LED lit next to the power jack on the motor controller board. Got the power restored to the board, green led on, and the motors are now turning.

3 Likes