Maslow Home Maslow Community Garden Newsletter

Motors not responding but there is power to the board

New to all of this. I got everything all hooked up, powered on, firmware & GC downloaded. Spent half the day figuring out an issue with GC connecting and lost connection, but now the motors wont do anything, cant get them to respond. I tried clicking test motors/encoders…nothing. Tried manually moving with the arrows…nothing. Running GC v1.26 from what I can see that is the latest version

There is power to Ardunio/motor shield (lights are lit up the board and also lit up for the USB connection).
The power cord is plugged into motor shield, the connector on the ardunio has a plug in it so I know its plugged into the proper connector. When I open GC it does show connected to COM3, and the connection is constant now after I figured out that issue earlier today of losing connection every 2 seconds.

Desperately need help as this has been a long day of trouble shooting one thing after another…

When you tested the motorS/encoders, did you get fail messages on the screen or just nothing at all happened?

Nothing at all.

Most likely there is a connection issue then. When you startup ground control, it connects to the Arduino and you should see some text appear in the bottom right. If you don’t, then either you aren’t connected to the Arduino or the firmware isn’t loaded correctly. Did you load the firmware?

Yes. I did try re-loading it yesterday too while I was working on the issue of the connected/lost connection issue with GC. As far as I can tell that side of things is up to date, but new to all of this.

Should I try uninstalling it and reinstalling it again? I was thinking of giving that a shot trying to rack my brain as to what I’m missing

Well, you can try webcontrol as it has the firmware built in. It’s a web-based replacement for ground control and has a bunch more features. It has the firmware built in so you don’t have to load the Arduino idea or anything. If running windows 10, download the singlefile version (simpler from a getting started perspective) unless you know your way around computers (single directory you extract it and then run webcontrol.exe from within the directory).

Once you start it, it’ll startup a web browser that will connect to the webcontrol web server. We are working on docs to help people get up and running easier, but go to Actions->Quick Configure and enter the information it asks for. Then, I recommend installing the Holey-firmware from Actions.

I must have downloaded the App version of Arduino IDE the second time around yesterday because it was showing under my apps on my computer, and I did see some threads about issues with app version, so I’m downloading the non app version now. Ill give it another shot and report back once I try it out. If I still have the issues I’ll go the webcontrol route next.

1 Like

That must have been the issue. After I reinstalled the non app version I was to get the motors to respond. Ill work on getting everything calibrated and hopefully cutting today!

Thanks for the help

2 Likes