No Computer/Arduino Connection

So, after looking around in the forum and still experiencing the issue I’ll ask around. I was going to finish calibrating the machine tonight but it isn’t connecting to the computer. Power supply is connected to the maslow board and usb cord connected to the arduino and laptop. Opened GC and there aren’t any available ports for me to connect to (I had previously connected via COM3). Downloaded the latest versions of both the firmware and GC but when I was going to install the firmware in the arduino I still couldn’t connect to it. Checked the usb ports with other devices and they connect without any issues to the laptop. Thought the cable may have been damaged but the arduino lights go on when I connect it to the computer. Thoughts? Thanks in advance

1 Like

What Operating System are you on? Have you tried to check the comport in the Arduino IDE? The Comport may have been assigned a new number.

Thank you

1 Like

Windows 10. I’ll check that out, thanks

Also maybe try a different cable. A couple people have recently reported issues with their cable.

1 Like

If you have access to another computer that could be worth trying as well, it could be a drivers thing

Will do that

Tried on a different computer and nothing, same problem

Hmm that sounds like it could be an issue with the Arduino, if you send your address to we’ll send you a new one right away.

One last thing to test is will you remove the shield from the Arduino and confirm that it still doesn’t connect just to make sure that the issue is in the Arduino


Theres also a little red reset button underneath the maslow board on the Arduino itself…may be worth a try?


Pushing the reset button is a great idea

1 Like

I’ll test both options (without the shield and reset button) and let you guys know. Thanks for everything. Last option, I’ll send you guys the email @bar


Alrighty! So, as random as the problem was, as random was it solved (maybe, hopefully). Later that day I tested it without the shield and pressed the reset button and the connection still wasn’t there. Tried installing the drivers again and nothing. Frustrated, I backed off of it for a couple of days until I connected it today to show a friend it wasn’t working and voila! Everything worked perfectly hahaha Either one of the solutions worked, the com ports were all taken (and assigned a really high one?) or the Maslow just wasn’t feeling it that day. In the end I was able to finish calibrating the machine, test cuts are done and started cutting my workshop’s logo and learned my first CNC lesson:

It’s all about tabs…


Thanks everyone for the help!


Hey, I am have the same problem. I tried all of the above suggestions except I only have the one computer. It seems like the board isnt getting power from the USB port. Does anyone have any additional suggestions?

Hi @Rufino_Rodriguez!
You’ve been in the Forum for some time, so a ‘Welcome to the Forum!’ would be out of place.
Let’s make that a ‘Welcome to your first post’!

This one should be ruled out/confirmed fast.
If you have the same shield, without the power supply for the motors connected (remember that goes into the motor-shield on top {right bottom in the pic} and NOT in the Arduino-Mega {right top in the pic}, you should see a green LED in the top left shine bright if your USB supplies power to the Arduino.

If that does not light up, you could try an additional power supply for the Arduino.

To get a faster support, this information is essential to help:

  • Make and model of the pc used
  • Your Operating System with version (Windows, Mac, Linux)
  • Firmware and GroundControl version number you are using

Kind regards, Gero

1 Like

I do have the power going to the motor shield and not the Arduino Mega. The light next to the power input is on but the on the opposite side is not coming on (the same light you have in the photo). I have attempted to use different USB cables and ports with no affect. I removed the shield and pressed the reset button with no notable affect. The computer I’m using is a Dell inspiron running Windows 7. I am utilizing version 1.26 for the firmware and ground control.
Thank you for getting back to me so quickly