Maslow Home Maslow Community Garden Newsletter

No option to set chain length in Webcontrol?

OK, first, thanks to everyone who helped in the last thread I posted. Since then, I’ve set up chain guides, and I’m using a top feed instead of a bottom feed. I’m using 2lb fishing weights as my counterweight, and motion seems smooth. I’ve also re-mounted the motors onto angle iron instead of screwed into wood. This is much more rigid and I can keep the sprockets very planar this way. Before, it was always a little off. I’ve also used the angle iron to extend the distance so I’m at 12’ between motors instead of 10. I’ve had to get longer chains, and I’ve also upgraded the Z-Azis and sled (Thanks @Metalmaslow).

Now, I’m trying to get webcontrol set up. I’ve gone through the setup steps, but I don’t see any place to set chain lengths. Here’s the error I’m getting.

Message: Unable to find valid machine position for chain lengths 1654.38, 1654.38 . Please set the chains to a known length (Actions -> Set Chain Lengths)

  • I am using stock firmware
  • I have set the chain length under Settings -> Advanced Settings. There is no option for (Actions -> Set Chain Lengths)
  • My sled uses a ring
  • Motors are mounted on the top of my beam, feeding the sled from the top.
  • I’ve finished ‘Quick Configuration’, as well as ‘Set Sprockets & Chains’

Has anyone else seen this?

actions - > set sprockets and reset chains.

set your sprockets to 12:00 using the buttons
then extend left and then extend right or vice versa. They will then be at the known position.

Mark the chains. next time you just go to 12:00 and put the mark at the top tooth. then press manually set chains.

I’ve done that procedure again, this time marking the chain links at the 12:00 position. I’ve gone ahead and set the option in ‘Reset Chains’ to the ‘I have Manually Reset…’.

It’s exactly as it was before.

" Message: Unable to find valid machine position for chain lengths 1650.99, 1650.99 . Please set the chains to a known length (Actions -> Set Chain Lengths)

The only difference is there is a slight change in the numbers in the error message. The menu item they refer to does not exist.

EDIT:

I couldn’t get this sorted out. I decided to recalibrate in Ground Control, and then just import the ini file. Thanks @Orob I appreciate the help.

that is really odd. I’ve never had an issue with it working like that. I’m glad you were able to get it working.

Did you do the quick configure setup in webcontrol first or were you trying to set the chain lengths without having done that? If you had not entered anything in there, that would explain why it couldn’t proceed. The basic measurements and config such as chain position and sled type, all have to be entered there and then you only need the set chain menu when you lose position after that. Sorry if that was unclear.

First I did the quick setup, then I got the error. While trying to sort out why, I found the setting for chain length hoping that would take care of it. Quick Setup doesn’t have a setting for chain length, which surprised me. Everything else is listed there.

you have to feed out the chains so then it knows how long they are.

This sounds like an issue i was having yesterday. Try this and tell me if it works.
Clear your log first. Then reset your chain calibration. Once you finish, before doing anything else, click the save home button on the main screen. If that works, or doesn’t get a copy of the log and post it. I’m curious to see if we are having the same issue.

the chain length is set in webcontrol menu Settings->Advanced Settings


This number is to be a mutliple of 6.35. When you do the chain extension in the setup (watch the videos on quick calibration and chain extension I made here) it will know where it is. The home is then automatically set at the center of the work piece if your measurements are accurate. the initial extension will be high on the board unless you change the chain exension lengths to match your center.

1 Like

Yes, that was part of the procedure. After doing that, it have me that error.

I did do that. Still have the error.

Doing the calibration in Ground Control and then importing the file seems reliable. That worked straight away.