Maslow Home Maslow Community Garden Newsletter

No version of makerverse except 1.0.6 will work on my computer

I was able to load makerverse 1.1.2 on my hp computer once. It opened fine and I was able to perform a calibration on my M2. The next time I tried to use it, it only came up to a black screen. I had to go back to 1.0.6 to use my machine. I have tried several times to move to the newest version but each time I only get a black screen. I need the newer version to do some more calibrations on my machine but no luck. Any ideas?

@zaneclaes ?

Someone else reported a similar problem at one point. They eventually solved it as being something on their computer, but I can’t remember what. Some thoughts…

  • What OS version are you running?
  • Makerverse expects to be able to read/write the file $HOME/.makerverse and the directory $HOME/makerverse. Make sure both exist and that you have permissions to read and write both locations.
  • How did you install makerverse? Did you make sure to grant all necessary access? Makerverse cannot run unless you explicitly tell your computer that it is safe.
  • Can you post a screenshot of the black screen?
  • Have you tried acessing Makerverse from a different computer? e.g., run it on the same computer, just connect from your phone or whatever.

I’m using windows 10. When I install it asks me it warns me and asks if I want to continue. I click continue. I have tried it on two nearly identical lap tops. On the second one, it ran fine the first time and then the next time I tried, I got the blank screen. Here is a shot of the screen.

1 Like

Hmm. I’ve found some people reporting a bug with Windows 7 that sounds just like this. The bug is with something called Electron, which is used by Makerverse (here’s one link I read).

Long story short, the current version of Makerverse uses an old version of Electron. This is because Makerverse came from CNCjs, which hadn’t been updated in a long time. I am presently working on a new version of Makerverse which updates everything to use the latest versions, but it’s a big project. I don’t expect to be done soon enough to be helpful to you.

In the mean time, you might be able to get around the problem by upgrading .NET on your computer. The first link, above, describes this as a solution to the problem, though again it seems to be talking about Windows 7, perhaps it still applies. At least, the latest version cannot hurt. Here’s the download site: Download .NET Framework | Free official downloads

1 Like

I downloaded the latest version of .net framework. When I tried to install it, I got a message that said that it had already been installed. It was worth a try.