Maslow Home Maslow Community Garden Newsletter

Trouble with Makerverse setup w/ M2 2021

Hi. Makerverse/CNC/MakerMade M2 newbie here. I am a software/network engineer though, so I hope I don’t make too much of a fool of myself asking this question:

I can’t get the Makerverse software (Windows GUI and the Web Server - on Raspberry Pi) to list any of the Maslow products. Here’s what happens:

_ATTEMPT with WINDOWS 10

  1. Installed Makerverse 1.1.3 on Windows 10 laptop
  2. Created logins to MakerMade, MakerVerse, & Launched GUI & OpenWork.Shop.
  3. Disabled all Firewalls on laptop
  4. Connected USB from M2 brains (Arduino Due board) to laptop. Plugged in power cord to M2 brains. Initially heard loud, incessant buzzing noise from M2 brains. Unplugged USB cord at laptop and buzzing quit. Re-inserted USB and did not receive any buzzing.
  5. Launched GUI - The GUI launched OK and went to the login screen. I logged in and was taken to the “New Workspace” screen. Clicked on “Connect to a New Machine”. I noted a screen showed up saying “Loading” and indicating it was having trouble connecting to the community (or something… it came and went to fast to read fully) and took me to the “Connect to a Machine” page which shows only: Maslow() --SELECT-- and the “Create a New Machine” button. Nowhere do I see an M2 option as indicated on the calibration/setup instructions. See the image, below:
  6. In attempting to “Create a New Machine” I choose the “Maslow” option, and the following inputs:
    Brand - MakerMade
    Model - M2
    Baud Rate - <I’ve cycled through every option here>
    Enable hardware flow control: Unchecked
    Submit to community catalog: Unchecked
  7. At this point I was still unable to see any other options.
  8. Installed the Arduino dev GUI… was able to then connect to COM3 & COM4, but no matter what baud rate I used it wouldn’t talk with the M2 Arduino board.

_____________ATTEMPT with Raspberry Pi B3+ & Raspberry Pi ____________

  1. Pulled out an RPi B3+ and installed 2021-10-30-raspios-bullseye-arm64-lite on a 200MB card because nowhere could I find a Raspberry Pi distro as indicated in the instructions.
  2. Ran the OS, connected it to the wifi and performed an apt-get update and an apt-get upgrade.
  3. Installed Docker via instructions found on the internet
  4. Successfully ran: docker run hello-world
  5. Continued following all instructions at https://makerverse.com/installation/web-server/docker/ successfully.
  6. Executed
git clone https://github.com/makermadecnc/makerverse.git
makerverse/bin/launch
  1. After waiting for the install, it successfully launched and I was able to execute docker container ls and verify that the makerverse container was running. It showed the following:
    CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
    2f82cba1200e makerverse/core:latest “/home/node/bin/dock…” 18 seconds ago Up 10 seconds 0.0.0.0:8000->8000/tcp, :::8000->8000/tcp makerverse
  2. I was able to go to my laptop (since the RPi is headless) and use the browser to go to :8000 and get to the login page. Yeah! It seems to be running on the Pi just fine!
  3. However, I get the same issues as with the windows GUI… ie, no M2 listed and unable to connect to my M2 brains (Arduino Due)
  4. I also tried creating a new service and running it in the background, but I am unable to connect to it even though the docker container seems to be running… but this is not my main issue! I can work this at a later date… I really need to be able to talk to the M2, and then I’ll worry about automating the service…

Suggestions? Please!!!

Your help is greatly appreciated! I’m already falling behind on several projects that I desperately need this new M2 for!

-Aaron

Hi Aaron,

Welcome ! I’m running with v1.1.2 of Makerverse w/ M2 on Windows 10. I haven’t tried 1.1.3 because the additional features weren’t relevant for me. Connecting worked fine for me the very first time I tried it - with some slight deltas w.r.t. the instructions (see below). The buzzing sound you’re hearing sounds promising - assuming it’s a constant high pitched squeal. It basically means you have a physical connection. I’ve attached the v1.1.2 instructions in case they’re of use to you. The relevant steps start on page 9.

The slight delta I referred to is at step 6. I didn’t see “COM 4: Manufacturer Arduino LLC (ww …” but rather a simple “COM6 Microsoft”. The connection was still fine. I use a baud of 38400.

Incidentally, v1.1.2 of Makerverse also worked for me using a virtual machine running v18.04.5 of Lubuntu.

Hope this helps you out ! (unless of course others can help you tackle the specifics of the issue your seeing)

Calibration-Makerverse-1_1_2.pdf (2.2 MB)

1 Like

Thanks for your response bilzer046! I ended up performing a firmware update on the board using the Arduino IDE and was able to then get my M2 to talk via COM5 with Makerverse. It looks like MakerMade also had a server error (see ticket at https://makermade.freshdesk.com/support/tickets/5864) that was preventing preconfigured systems from showing up.

I’m off trying to do the calibration steps now…

Thanks again!

2 Likes

So… almost done calibrating… but I’m having some trouble getting my new M2 (2021) to move. I was able to control the motors during the calibration steps when setting up the chains (to the 12 o’clock position). But, once I get to the “Move to Center” step on the “Axes Check” part of the calibration (last step) the command to go to center doesn’t make the unit move at all. I see in the console the command being sent (G0 X0 Y0) but the unit does nothing. Attempting to move manually using the yellow buttons does nothing either…

Here’s a screenshot of where I’m at:

Any ideas?

unlock?

Thanks for the suggestion Orob. I did try that a few times. No change. Thanks for the suggestion.

Any other ideas?

close the calibration window, click the red reset button. I don’t recall if there was an issue with those buttons in one of the versions. What verison of Makerverse are you using?

You can close the calibration window and click the yellow home button, then reopen the calibration window and go back to where you were.

1 Like

I’m using 1.1.3 of Makerverse. I’ve tried all the steps you’ve suggested. I’ve even tried rebooting the M2 (and unplugging the USB) in between attempts. The yellow buttons are not greyed out… and when I click on them I see the command being sent, but the motors don’t even budge… I’ve tried resetting. I’ve even deleted the workspace and started over… same results.

Any way to know if the cables are properly connected if the motors don’t move? I’ve zip-tied everything and relieved all tension on the cables…

Any other ideas?

yes. The 12 Volt power supply. is it connected to the top board or the bottom board? There are 2 plugs. The 12 volts run the motor. The brain is powered by the USB. It will talk, but not move if the 12 volt isn’t connected.

Yes, The 12v supply is connected up as is the USB. I see a green light for the USB. No other lights are visible.

You want to move that 12 volt plug up to the other port. You should see a green light go on when it is plugged in.

What other port? I see only one place for the 12v supply to be plugged in.

Hi Aaron,

Glad to see you’ve made some progress !!

I haven’t experienced your latest problem myself, but I did think it odd that you’re getting some “problem messages” in the bottom left of the screenshot you provided:

image

Have you entered these values already? If so, it’s as if they haven’t correctly registered. I’ve no idea what could cause this but hopefully someone more savvy can say whether this is normal behavior in 1.1.3 of Makerverse (which I wouldn’t expect), and if not what could be done to try to resolve it.

Best of luck !

the 12v can be plugged in two places, if it’s plugged into the brain, the motors
won’t move

David Lang

the calibration should fill in all those numbers that are missing for you. you might just go back to the calibration and do the z axis. you don’t need it to be at home to get the z set up and then go back and see if you can get it to go home.

If things aren’t sticking, you may need to press the wipe button in the lower left and start over with the calibration. If you flashed the firmware, the eeprom is on the card, not part of the due, so if the size of the stored settings in the memory are different, you will need to reset the memory. Wiping does this (lower left of the calibration window you were showing above.

Hi bilzer046,

Thanks for your question. I assumed those errors would go away once I was able to finish the calibration process. Should they be going away one at a time as I enter the values?

-Aaron

Hi Orob,

Thanks for your continuing thoughts. I did the wipe with the same results. Nothing changed that I can discover. The z-axis doesn’t move either. I’ve seen the x & y motors move, but never the z.

Maybe I’ll try re-flashing the due board. It said it was successful the first time I did it, but I suppose it can’t hurt to try again. I followed the directions carefully, but maybe I did something wrong the first time.

Thanks again,

Aaron

Flash, wipe, reset home/chains, try calibration again… set up working size and enter measurements, then try to move sled with one hand on the power cord.

do you hear motor humming after the red reset button is pressed at the top? If not, you don’t have motor power.

Do you see garbage characters in the black terminal on the left when the system first turns on?

Hi dlang,

There’s only one power port that I can see on the exterior of the blue box. It’s on the top of the left side if you are looking at the box straight on with the words facing you. That orientation places the z-axis on the left side of the bottom face, and the x/y motor cable plugs on the center/right side of the bottom face. The USB plugs in on the same side as the 12v (the left face). There is a green connector on the right face, but I don’t have anything plugged into it. I assumed it was a test/programming connector for the due board. Where is the second plug location you are referring to?

Regards,

Aaron

Hi Orob,

No garbage characters when first powered on. I did see this once before I flashed it the first time. I’ll try reflashing and starting over from scratch.

I used to hear the slight humming from the motors back when I first started the calibration procedure. I was able to move the motors to the 12o’clock position, and then I spent time taking all the measurements. During that period the humming stopped. Since then I haven’t heard any humming.

Unfortunately, it will be this weekend before I’ll be able to get back to it. I’ll post my results and some picks of the plugs (assuming it doesn’t magically start working). In the meantime, if you (or anyone) has any more ideas of things to try once I’m able to get back to it, it is MUCH appreciated.

Thanks much,

Aaron