Maslow Home Maslow Community Garden Newsletter

I think my Maslow is dead

I am experimenting with designing a format to cut coroplast on my cnc for Christmas Light Shows. However, I went out today and the board powers up but the cnc is not moving. I tried to recalibrate and none of the motors are turning. I had problems this past year with poor ventilation in my shop. I didn’t use the shop for most of last year and had to throw away a lot of things with mold on it. The board doesn’t look corroded. What do you think is wrong and how can I troubleshoot it?

power to the shield?

1 Like

I’m wondering if I have a bad controller board

does it send data if you connect with the serial monitor in the arduino IDE? (arduino basics)

I’m not sure. I’m probably going to buy the shield and move from there to the arduino. I’ll clean it first with some alcohol just to make sure that it isn’t shorting anything.

@Orob’s suggestion about the power being worth checking is a good one. The electronics for the left and right motor are independent so if they both fail at the same time usually the power supply is the first place to look since it’s common to both of them.

Power supply is putting out 12.28 volts. No problems with it. I still get no movement on either motor or the z axis. I have the v1.2 shield. Which should I buy first, the shield or arduino? The motors can be rocked a tiny bit so it doesn’t look like they are locked up.

just to double check (since you didn’t reply to the earlier question), are you
sure teh 12v is plugged into the shield not into the arduino? This is a very
common mistake to make.

David Lang

2 Likes

We are going to pretend like I am not an idiot. That was the problem. Thanks guys. We are back in business

2 Likes

New issue. I have my motors wired the correct way. However the tracking is inverted and the a axis is not working. If I press left then it goes right and if I press up it goes down. When I try to move the z axis the right motor hums and I get a message telling me to move the z axis by whatever amount. I swapped the plugs for right motor and z axis motor and then when I move the sled, the left motor and z axis rotates. This rules out any issue with the z axis motor. How do I fix all of these? I am so sorry for needing so much help but I have been out of this for the last two years and have forgotten everything.

For calibration did you put your chains over the sprockets or under and around? This setting in calibration needs to match your setup. In the software, you need to have the z axis enabled.

1 Like

you lost your configuration in ground control. The key issue is that it’s asking
you to move the Z axis, that means it no longer knows that you have a motorized
Z

check your system for a groundcontrol.ini that may have the correct config.

otherwise you will need to start your setup from scratch.

As for the power plug issue, you weren’t the first and you won’t be the last.

David Lang

Thank you David. Long time no see. I missed you guys. I figured out that I didn’t turn on the z axis in the settings. That still doesn’t explain why my directions are inverted. I’ll redo a calibration and see if that fixes it. It looks like I found the config file and ground control has pulled all of my settings.

directions inverted probably means the over/under setting is wrong. This is why
I was saying to do a complete setup from scratch if you can’t find your old
groundcontrol.ini file.

David Lang