One belt won't retract during Retract All step (Maslow 4)

I’m having an issue with the “Retract All” step during setup. The bottom right belt doesn’t retract at all, but all 3 others retract successfully. I expect that the bottom right belt should retract too. It did retract when I calibrated previously, but now it won’t.

Things I’ve tried:

  • Update firmware, maslow.yaml, and index.html.gz to the files from release V0.67
  • Jog the motor manually with $BRI and $BRO. It successfully jogs the motor to move the belt in and out. So that rules out any connector or motor issue.

Any ideas?

I am running into the same problem and trying to figure it out. Does your Z axis move? I can’t get it to move and those motors get really hot.

Okay, I figured out my issue: That belt got a little tangled on the spool, and so the motor reached its max current and stopped.

Don’t be like me and think that you’re better than the instructions! While calibrating, be sure to manage any slack belts by gently pulling on them. Otherwise, you’ll have to take it all apart like I now have to.

For anyone else who ends up here, here’s another thread that might be helpful:

1 Like

Be really careful with these. I was really reluctant to add them because they make it REALLY REALLY easy to tangle the belts.

I’m still not 100% sure adding that option was a good idea.

For anyone else coming across this topic this setting is also relevant:

You can safely increase that to 1500 or 1800 and the belts will pull a little harder when retracting.

1 Like

I had to up those settings to 1800 to get retract all/extend all to work, and they still didn’t work reliably. But that might be an issue with the latest V 0.67 release, I’m not sure that the values entered through the web interface match what’s in the YAML file. The values displayed in the “Config Items” section seem to default to displaying the original values, even if I had changed them in the YAML file.

I had to use the $BRI/$BRO/etc. commands to get the motors to move. And then just resorted to powering the motors directly with an external power supply. It seems like once they retracted completely and extended completely a couple times they started working repeatedly with the 1800 threshold setting.

1 Like

Someone else reported something similar, but I couldn’t replicate it. Do you have a set of steps to make that issue happen?

OK, I played around with it a bit, and I think if I enter new values, and hit OK, but don’t save and reboot, it’ll still show the saved values even if I refresh the page or restart?

I think the first time I was expecting the values under “config items” to update if I uploaded a new YAML file and then refreshed the browser. But they’ll only update if I restart the board?

I was playing around with changing the settings by sending commands to the machine also and I found that this button was necessary to make the settings update

Overall I think that the settings menu might be an upgrade from the .yaml file but we can do even better. I want to make a calibration popup that asks for your input and then handles all the saving and updating the settings automatically. There’s still too many opportunities for things to go wrong.

Hey Bar, I am having the same issue and believe the drive and idler gears are binding. I had one arm where getting the gears in place was very difficult. On retract I have 3 that pulled in, one that didn’t move at all and all four report retracted. If you want a repo I can hold off on trying to take it apart and freeing it and bring the completed machine to the 4/13 open house so you can see what’s going on. If there’s a way to confirm this isn’t an issue during assembly of the arms it would be worth it to avoid taking it apart.

Were you able to try increasing the current threshold mentioned above? I’m happy to take a look at the open house, but we might be able to get it sorted out before then.

Yes, set to 1500 and then 1800 and all four report retraction but the one arm that I had difficulty getting the gear seated is still locked up with about 50cm of belt still out. I’ve set back down to 1300. I need to work on getting my floor setup with drop anchors so it isn’t a big deal to wait. On a neat features to consider, having a way to verbose log the current usage, especially before final assembly, would let you decide if arms needed rework if this turns out to be a common problem. Having some sort of “hang pull test” with arms connected to the controller with current data would let you know a given arm was tight before you latch everything together. This would catch tight gearing as well as over-tight bolts on the plate/spool.

1 Like

If you do Retract All and all arms report being fully retracted and then you give the arm that won’t retract a tug to extend it what happens? Can you get that arm to extend the belt if it won’t retract it?

I was able to tug it maybe 3mm before it doesn’t come any further. I tried tugging on the belts after retract as well as “extend all” and I can’t actually back drive/free spool any of them. Is there a way I can pull the lines out?

Try using the rocking technique to get the other ones to come out. You might need to be a bit more aggressive with them than you expect.

I used “extend all” (fan kicks in for the drivers) and pulled hard with a back-n-forth on the three that are fully retracted and none of them budge. Is there a different command I should use before trying to get the cables out?

I find that a rocking motion like this helps. It can be a little tricky to get the hang of at first

Ah! Okeydokey. The three of them started after using the base of the belt end as a lever (wow- that’s fun!) and the 4th one did come out a bit. On full retract it went back about 10cm further than the first time. I repeated doing the extend/retract and at one point got a belt slip … now it’s fully retracted. Still seems a bit sticky but think I’ve got everything working. Thanks for the help!

1 Like

Excellent! Great work!

Happy to help!

I had much the same issue, my solution was to unplug the three motors that were behaving properly and then issue the extend all command and use a piece of wood for a leverage to get the belt to start extending. Once extended the belt retracted further on the next attempt and finally fully retracted on the third round of extend & retract commands.
The rocking method works fine when the belt is fully retracted but a belt that is hanging out requires a surprising amount of force to get started

1 Like

for extend all when there is slack, you can push the belt in a bit then pull on
it to let the system know it’s supposed to run the motor out.

David Lang

Bar wrote:

1 Like