Maslow Home Maslow Community Garden Newsletter

Power glitch trouble

I am having a problems with my Maslow.
I have had it for e few weeks and have just recently got the time to put it together, although I started to get some issues when trying to cut out the sled.

First I got a message that the sled wasn’t keeping up.

Sled

At that time I followed the tutorial on how to fix this issue.
For some reason my motors wasn’t working and I figured out (with the help of the tutorial) that it had to be something with the power supply. Since none of my motors were working.

Looking at the powerlight it doesn’t shine as bright as the USB-light.

If I wiggle it around it lights up.
And to keep it like this I had to secure it with a cable tie.

I think I have a glitch in the Arduino Shield since it only works when I wiggle the contact and not the power cables.

After I secured it with the cable tie it worked fine.
However now I´m afraid that the power will be affected by the vibrations of my machine and the glitch will come back.

Is this a common problem?
Can you help me?

Hi Kim,
Possibly a connection issue between the motor and the shield.
unplug and reconnect both ends of each motor cable and then hit “test motors/encoders” under actions. If you get no failures then try the cut again.

1 Like

If you own a soldering iron and know how to use it, or know someone, this sounds like it can be solved in minutes. A picture of the bottom of the motor shield (power connector region) could give a clue.

If not, so far i’ve seen that all new suppliers are continuing the amazing {no cost replacement} fast and efficient same as Bar used to have. To speed up, use both channels. Email and after 2 day no answer use the Forum would be my route :wink: .

Kind regards, Gero

3 Likes

Sorry @Kim, I misread your post. @Gero has provided the right advice for this.

2 Likes

Thanks for giving this some time Gero and John.
I was able to try your solution John before Saw you last message. It made no difference, but still I tried it.

For you Gero I don’t own a soldering iron unfortunately.
I might know someone who do but to let them have a try to solder it might make more damage than it would solve.

Even if it’s not the optimal situation I rather have a damaged Shield than a completely broken one.
I managed to get the machine working with the cable tie so that is how it has to stay in that case unfortunately.

The machine runs on the motors but I still get a Fail on all the motors, as the picture below. All the motors sounds like they are trying, but there is something that is failing them.

Is there something else wrong with my machine?

I would contact the supplier to a get new motor shield.
The cable-tie might look to work on a first glance, but can have unpredictable negative side effects.
For example, if the Arduino is mounted on the frame, the vibrations could cause on/off spices are not visible to the eye when looking at the led, put can be deadly for the electronics.
I would not operate a Maslow with a damaged shield.