Maslow Home Maslow Community Garden Newsletter

Powered down for awhile and now the motors won’t power up

Can’t get the motors to power up. I have an M2 and it has been calibrated and running. Haven’t run it for awhile, and now I get no power on the motors. There is power on the board. Could the Arduino be bad?

Hmmm are you 100% sure that power is getting to the motors? If you unplug the USB cable from the computer does the 12 volt power light on the board stay illuminated?

1 Like

Yes, I checked all of the connections, and reseated the DUE. Still no luck. There is definitely power to the board. Thanks for the come back.

1 Like

Do you know which version your M2 is? Also, when you reseated the DUE board were there metal screws attaching the DUE to the case? Or nylon screws? The metal screws have been replaced in later versions due to a possible short circuit. MakerMade’s support should get you straightened out with a replacement.

Thanks for the assist. It has the nylon screws, but I’m not sure of the version. I will try to contact MakerMade support. I really enjoy running this thing.

Definitely reach out to MM support. They can get that board swapped out for you. I assume you are using their power supply (it has their logo on it) that shld be providing the right voltage and amperage to the board. The metal screws are only on the first batch of M2 v2.0 so I assume your version is 2.2 or later.

At the risk of just saying the same thing over and over, it’s worth making sure the power supply is plugged into the MakerMade board and not into the Arduino. It can plug in either place, but only the upper one makes the motors work :stuck_out_tongue: …Sorry if I’m repeating myself :roll_eyes:

It’s a good thing to make absolutely certain that all possible causes are checked and double checked. Not at all a risk to repeat yourself. I definitely had the plug in the right board. I even checked the power at the plug itself with a Fluke digital VOM. It had 12 volts at the plug. What’s a mystery to me is that I had run a test cut on a project and moved the sled off to the side to access the piece more easily. I put the motors to sleep, and removed the piece I had cut. When I went to move the sled back to work zero, the motors never powered up. Decided to reboot the system as I thought there might be a software issue. I shut the laptop down doing this. Brought the laptop up and opened Easel, and Makerverse. At that point, there was a comm 9 error when trying to open communication with the Arduino. This has happened to me before on several occasions. Uploaded the sketch, shut down the Arduino software and tried again to connect to the Arduino. Got it to connect, but still could not get motor power. I did get the option to put them to sleep. Tried to reset power to the board. No result. Also saw that all the calibration settings were missing. At that point I began to suspect there might be a power problem. Checked all connections and verified they were correct. After reading your initial reply, decided to check power again. That’s when it used the Fluke to confirm the right power level at the plug. I can’t think of anything else to do other than ordering a new DUE. At a cost of $200.00, I want to be certain I’ve ruled out all possibilities. I’m sure that you have a great deal more knowledge and experience with this system than I do, so I’m open to any suggestions you have to offer. If you think ordering a new DUE will get me up and running again, that’s what I’ll do. Thanks.

This is the set of boards. The DUE is a version 2.1.

The com9 error is your key. Can you open the arduino IDE software, plug in the due and select com 9 and then open the serial port monitor? Do you see any information ? the communication speed should be at 38400. If com 9 is not available, choose the one that is and see if that will open and send data. It is possible that the com port didn’t close correctly and when you restarted it assigned the due to a different number. That happens sometimes. You will need to add a new machine to makerverse for the new port, but you will not need to recalibrate if the sled is in a known position. Calibration and sled position are stored on the due, not in makerverse. Makerverse is really just the display interface for the due.

1 Like

Darn :grin:…that would have been an easy fix. When was the fluke last factory calibrated?..just kidding

I think @Orob’s suggestions are good ones

Hi guys,
This is where I stand now.

I had to take a break from it yesterday and shoot 18. At this point, do you think it’s time to order a new board? I’ll do whatever it takes to get running again.

I’m not all that familiar with makerverse, but there should be a “test motors” button somewhere that I think would be worth pushing before buying a new shield.

Since the circuits to control the left and right motors are completely independent usually when a board fails only one motor stops working. When it’s both motors it’s almost always something else. Usually a power supply issue or something in calibration.

Ok Bar, I will look for a test motor mode. I would think there should be one on there.
Thanks.

1 Like

a couple things that we have seen happen on other systems (don’t know if they
apply to yours)

  1. the firmware gets set in ‘fake servo’ mode, where it responds to the sending
    machine like it’s running, but doesn’t actually move

  2. it things you hit the stop button and does nothing until it gets sent the
    command to resume.

both of these should show up in the log. Clear the log, restart everything, and
post the log (this way you don’t have to figure out what in the log is
important, and we don’t have to dig through a huge amount of data)

David Lang

no don’t order a new board.

Your board is connected on com9, so that means it is working. If the shield has power, then you are likely constrained by a soft limit error or the motors are asleep. If you don’t hear humming, click the red reset button at the top and they should hum.

1 Like

Also, clicking the reset button has no affect.

the picture you showed of your contoller… do you use it like that or do you put the top on the case? That M2 shield as so few pins in it that when you connect the motor wires to the connectors, if the case cover isn’t on, the board and motor shield can separate and then stuff gets weird.

This is where I’m at now. Does this mean the machine is stuck in the sleep mode? When I hit the reset power button, nothing happens. I also don’t get the options to unlock. Also, where is the access to the log and how do I open it?
Thanks again for all your help.
Rey

The case cover is always on normally. I only had it off to check if the DUE was seated properly.