Problems during initial calibration

If you delete log.txt and the run GroundControl, does it re-appear? I’m pretty sure it gets recreated every time. That happens on Linux and the mac. Not sure about Windows file dating, though.
I’ll warn you that it is very full of ‘stuff’, most of which tries to hide whatever you’re looking for :wink:

The file is empty and has the date/time that GC was installed, same as the rest of the files. Windows has essentially the same file dating as Linux, create/access/write. To be different it’s a 64b int in 100us increments since 1/1/1601 (just incase M$ uses it’s time machine, I guess) rather than seconds since 1/1/1970. OT: Didn’t figure when the M$pocolypse will happen but it will undoubtedly involve an expensive upgrade much bigger than the Y2K money grabbing yawn (spent that new year’s party in our ISP/phone switch hut with the generator powered up and on the ham emergency net - if civilization was going to end at least we’d still have our dial-up Internet).

I mispoke (mistyped?) in the first post; it was trying to measure the inter-motor distance when it went into try to pull the frame apart full power mode, not the left chain length. It hasn’t happened since, and that part worked fine in yesterday’s adventure. Tighten chain just tightened it a bit, not the full tilt see how hard it can pull boogie. At maximum tightness there was a noticeable sag in the chain, but I’d guess that’s consistent and compensated for.

I think grep was invented to prune log files…

Yes, “grep -v” is my friend :wink:.

I spent that night in the Situation Room of the regional airport. No airplanes fell out of the sky, but many donuts and cups of coffee were consumed.

I found that three bumps of the ‘tighter’ button pulled the motors 12mm closer together. Convinced me of the need for a stiffer between them.

I find the same thing, though I don’t have a real Maslow connected to my virtual Windows machine… the file isn’t written until a valid interchange takes place.

I’m considering leaving the temporary frame while waiting and seeing what sorts out. I’ve already cut the 2x4s, but lots more where they came from.

Donuts? I sure missed out on that one.

Brung ‘em - left nothing to chance! Emergency preparations, after all :stuck_out_tongue_winking_eye:

Ok, after almost a month of sitting in the box, I have the time to put my Maslow together. I have tried the chain calibration a few times today. I get both sides where they are about even then it stops and I am getting the “Unable to find valid machine position” message.

It has set for a while at that message, 30 minutes while I was working on cleaning up a bevel gauge I bought today.

What should I try next? (Everything is the latest as of this morning)

Wow, that’s a new one for me. You say you get to “Calibrate chain length” and and then it bocks? Firmware & GroundControl on 0.85 (0.84) ? Do you have a ‘Continue’ button?

Yes, I have a “Hold / Continue”. Click continue and I am at the run calibration screen again. GC is 0.84

You put your setting in that can’t be done automatic in GroundControl and then did ‘Calibrate Machine dimensions’ ? If I’m to fast, tell me please :slight_smile:

What happens if you click Actions -> Calibrate Chain Lengths Manual?

This will manually tell the machine that the chain lengths have been set.

Yes, I did. Trying again now.

OK, got to step 6 and the “unable to find valid machine position” comes up. Will not let me retry the length calibrations at this point. Had to go back to the beginning.

Stopping for the day before I get frustrated. :slight_smile: I will sharpen some hand planes now.

3 Likes

Will try that tonight and see what happens.

2 Likes

Managed to find some free time yesterday and spend some Maslow time. I have a gear design program (Gearotic), and for my first test cut decided to try an 8" diameter 24 tooth gear before charging into the real sled. Pic below, pretty sad. It measured pretty close to round, maybe a sixteenth off (and that might have been the scroungy teeth), but the teeth look like they need dentures. Those are circle spokes, guess they made a lengthy stop at the bar first. Pass to pass alignment was overall very good, and suspect where it wasn’t had more to do with the sled and 9" wide scrap, note the tooth just under the right center. Gearotic puts out accurate involute tooth gears, and I’ve cut a lot of them on the tinyBot, those are nowhere near accurate. Not gonna start my 4’ diameter gear kinetic sculpture just yet.

I made some should have known better errors, including assuming that old 3/4 scrap T&G flooring was 0.75 (it’s 0.70 +/- .01), which made the .06 tabs pretty worthless. Cut a non-circular gear with the right thickness and the tabs worked out great, just a little push and they snapped right off. The actual cut wasn’t much better, though.

This is with the temporary sled (need to correct that) on the temporary frame (waiting to see what other idea come along), 0.25 depth of cut, and the Freud 3/16 bit recommended (wiki? early forum post?), 25ipm with 5ipm plunge, and gearotic generated gcode. We uncovered a lot of odd size scrap in the barn cleanout project to the material is pretty scroungy. Started a wall of shame, at least until the insulation and drywall show up.

The actual speed was nowhere near 25ipm, which might have something to do with the part being made up of many small straight segments. It was very jerky (no bricks, temporary sled?). I kept light manual pressure on it most of the time, sanding the sled and rounding off the edges helped a bit with the second much smaller gear. The cutouts were fall and bounce inside the router outs (did the first gcode in the house and winged the depth, won’t do that again) but lifting the router up while the Z retracted got rid of them. Have a small vac on the Zenbot I’ll pirate and put it and the small cyclone out in the barn for now which should help, but measuring will help more…

It wants to make the center 21" up from the bottom edge, not 24". I’m guessing this has to do with the motor height but don’t want to start the whole calibration process over again, what with those 6 1/2 minute chain adjustments.

Not quite sure what’s the best way to go from here. I’ve got a fair amount of pretty rough scrap that I could try a first pass at the round sled with (think ACX that got left outside under a dog house) before diving into that $55 new sheet.

1 Like

manual pressure on the sled is a horrible substitute for the weight. the software assumes that the sled is free to rotate and that can’t happen when you are doing it manually.

too light a sled for the angle that you are doing will cause the sled to stick and round corners, so that could very easily be the cause of those problems.

The actual speed was nowhere near 25ipm, which might have something to do with the part being made up of many small straight segments.

that is a major problem for performance.

It was very jerky (no bricks, temporary sled?).

this is probably the cause of the rounded teeth

Not quite sure what’s the best way to go from here. I’ve got a fair amount of
pretty rough scrap that I could try a first pass at the round sled with (think
ACX that got left outside under a dog house) before diving into that $55 new
sheet.

get the motors attached to a beam, even if it’s a 2x4 and getit a foot or so
above the workpiece, that will do wonders for your accuracy.

Off the main topic but…
My 2³ worth on affordable gear programs,
I like Gearotic just because of some features but my favorite is “Gear template generator” found at https://woodgears.ca/gear/ made by Mathias Wendell.

Not that a change in gear design program would make much of a difference in how your machine would have performed, but have you look at or tried the above program?

@heidenmason. Yes, I’ve used that gear generator along with a number of other free ones. It was one of the reasons I bought Gearotic :grinning:

Seriously, woodengears.com is great if you want one or two round gears. Gearotic is in a whole different class. I was one of the very early users (get a quick reference in the about credit’s, even) and it’s evolved considerably from then, plus it has a great user community. It’s really Art Fenerty’s retirement project, never know what will show up in this years development cycle. It’s very eclectic these days, nth order motion controller, kinetics simulator, webcam to bas relief portraits. Plus many kinds of gears.