Calibration Adventures...

Hello fellow Maslovians, I’ve been lurking the forum trying to find a solution to my troubles, but I’m at my wits end and I’m posting in the hopes that someone out there has seen and solved my issue.
The story so far… I received my kit with the last batch and have slowly built the default design, but mounted to my garage wall. I had an engineer friend of mine help me out to make sure the build was as accurate as I could get with my tools. I believe I was running firmware 1.12 or 1.13 initially. To make a long story short I was able to get it working, but my accuracy was significantly off. My circles where quite obviously ovals. So before I tried to cut my final sled I wanted to get the machine dialed in.
I’ve been following the various related troubleshooting threads but none of them solved my issue. It looked like a firmware update was coming that might help, so I just waited. This weekend I finally got some time and spent the day updating the firmware and GC (1.15) and trying to recalibrate. The problem is that now with the new firmware I cannot even get past the calibration. When I get to the part where it uses the chain to measure motor distance, the left motor turns the wrong way and the chain simply drops. What’s weird is even if I switch the chain to the opposite direction the left motor turns the same amount (-46) and then stops. It then taunts me by congratulating me on a successful calibration. :blush: I’ve tried everything I can think of like wiping firmware /resetting GC, setting to bottom feed in advance settings and power cycling the duino. I inspected the chains and they seem to be in perfect order. The Motor/Encoder tests run perfectly, and I’m using the stock power supply and two bricks.
Anyone out there have any ideas?

since you’ve tried lots of things, let’s go back to the start and make sure there’s nothing odd lurking around from this.

First save a copy of your settings .ini file and let Ground Control create a new one.

Then wipe the eeprom on your arduino (using the options under advanced in GC)

then do a motor test to confirm all motors are moving properly

then do a calibration and tell us what happens each step of the way.

I realize this is covering some things you’ve already tried, but starting from an unknown state is hard, so lets get to a known state (no .ini or eeprom settings from prior work) and go from there.


I’m sorry for the trouble! Let’s get this sorted out.

This sounds like the first issue we need to solve to me.

To make sure I have a clear understanding of where we are starting, you are saying that after placing just the first link of the chain on the left sprocket, like this:


And then press the extend button:


The chain will move the wrong direction and fall off?


Thanks David and Bar! I took David’s advice and started from scratch.

  1. I reset GC to defaults.
  2. I then restarted GC
  3. I then connected to arduino via /dev/ttyACM0/
  4. I wiped the eprom.
  5. When I reconnected to the Arduino I got the following.
  6. I then ran the motor test. Left motor rotated back and forth, right motor rotated back and forth, then z axis when back and forth.
  7. I started the calibration routine.
  8. Chose triangular
  9. Measured distance from workspace (430)
  10. I set the sprockets to 90 degrees. I tested to make sure each motor moved both cw and ccw in 5 and 1 degree increments. All good and as expected.
  11. I hooked up chain as asked and low and behold it extended as asked! Success!!! No idea what I did differently this time.
  12. I chose the rotation radius of 140.
  13. When it got to the adjust to known length section I received the following error. Then I could no longer talk to the motors.
  14. I restarted GC, and then got the following error.
  15. I ignored it and skipped to the sprocket alignment.
  16. I then made it all the way to the end and tried cutting the test pattern. This caused some strange behavior. It started well, cut the first two cuts and the froze at cut three.
  17. I shut everything down and tried again and it looked like it worked. I entered all the measurements as asked.
  18. Finally I tried to cut the maslow logo at 3mm depth and it worked like a charm! The measurements were almost perfect.
  19. I then tried to cut out 6" circle and the accuracy was great except for the z-axis which did not go as deep as I expecting. It was a couple of mm short of cutting through the plywood.

So my first question is, do any of the above errors worry you guys? It seems to work well so should I just thank my lucky stars and move on to cut the final sled?

Secondly, I noticed that my router seems to have some dead space when changing from raising to lowering (or visa-versa). Is this normal? To be honest I’m a bit confused about mounting the router. I’m using the recommended Rigid router, but I’m confused as to what to do with the button/clip that is attached the the lead-screw. Right now I just leave the security latch open. I’m also wondering if its just me, or does the router have to almost bottom out before being able to get through 3/4" material. I know this depends on the length of the bit, but I feel like there is a lot of distance between the collet and the material leaving the bit very “exposed”.

Thanks you both so much for your help. The community really defines the success of the project, so I really appreciate your time.

1 Like

Many folks use a bungee cord or stout rubber bands to maintain a bit of down force on the router body. There is also a trick of adding a bushing to one side of the z-axis traveller and a washer under the circlip at the end of the z-axis shaft to address the slop. Search the forum for ‘bushing’ to find several good discussions.


Close the latch and tighten/loosen the screw so that the router can move freely up and down. Don’t make it too tight for the router to move or too loose for the latch to pop open.

As for bottoming out, it very much has to do with the length of the router bit… but post a few pictures of the sled and maybe we can see something off.

1 Like

It sounds to me like we are seeing the same error occur several times.

This error:

Seems to me like the same issue as this error:

This error can’t cause any harm, pressing the “stop” button will clear it and give you back control of the machine, but it’s annoying and it is indicative of something else being wrong. Your original post mentions that

so it sounds like everything is normal. Are your frame dimensions pretty typical?

1 Like